Optical Drive Not Recognized In BIOS

September 26, 2010 at 19:55:39
Specs: Windows Vista, dual core 2.1 Ghz/ 3 GB RAM
My cd/dvd drive refuses to show up in the BIOS on my hp dv6900 laptop.

I"ve tried 2 other good drives, took out the CMOS batt, flashed the BIOS... all to no avail.

If I take the drive out, it boots normally. With the drive in, it hangs for about 2 min. during POST.

Does anyone have any ideas?

See More: Optical Drive Not Recognized In BIOS

September 27, 2010 at 04:11:06
Is the optical drive the same drive that came with the laptop?

After it hangs for 2 minutes does the laptop then finish booting?

Is the drive removable without the use of tools?

Report •

September 27, 2010 at 04:40:24
Optical drive is the original, but I've tried 2 other drives that I know are good.

It does finish booting after the hang on POST, but the drive is not recognized in Windows anywhere.

Sure, it's easy to remove although you do need a screwdriver. Quite simple. I've done it numerous times and with various drives.

Report •

September 27, 2010 at 16:08:00
Hey, I'm stumped too. I may take it apart further to see if possibly the adapter that goes from the drive to the MOBO could be loose.

If anyone has ANY ideas, let me know! Has anyone else experienced this?

Report •

Related Solutions

September 27, 2010 at 19:10:06
The same controller runs both the hard drive and the optical drive on laptops. Possibly the connector is not making good contact on the optical drive.

Did this problem appear all at once or little by little?

Report •

September 27, 2010 at 19:21:35
Same controller? I was talking about the adapter that goes from the back end of the cd/dvd drive to the mobo. If that's a controller, I sure didn't know it.

It definitely did work a little when I first looked at this thing, but it was still taking a crazy long time to post. That's actually why the person sold it. They thought it didn't post anymore. Turns out you just have to wait 2 min.... but now the optical is giving grief.

Report •

September 28, 2010 at 04:44:43
The drive controller is part of the motherboard chip set. I was pointing out that if the hard drive works then the controller must be working. That eliminates that part of the circuit from your troubleshooting. I think the connection at the back of the optical drive is probably the issue. You probably need a service manual to determine how thing go together. Could be a short cable that is loose or damaged at either end.

Report •

September 28, 2010 at 08:51:44
OK, I see what you are saying about the controller. Makes sense.

I actually think that the optical drive plugs directly into a slot on the mobo for this model. Last night I took it apart down to the keyboard and that's what it looked like to me anyway. I should maybe take it apart further sometime when I have time.

Report •

September 28, 2010 at 16:01:50
You may have a loose solder joint or something of that nature.

Report •

September 28, 2010 at 16:21:45
so if i can't see anything abnormal, would a mobo reflow be in line?

Report •

September 28, 2010 at 19:39:49
I can't say. I happened to think after my comment about the controller that you may have SATA drives, which are somewhat different.

Have you checked the BIOS to see if any options there may shed some light?

Report •

September 29, 2010 at 02:57:29
Yes, this is a 2008 laptop.... it has SATA drives. At least the hdds are SATA. The optical is neither SATA or IDE; it's one of those regular combination plugs.

As the title of this thread states, the drive is not detected period. Even in the BIOS. I did change a few settings that are there, but your options our extremely limited. This is not a custom built desktop. (I build them too)

Hey, thanks for your help. I'll see what I can figure out.

Report •

September 29, 2010 at 05:48:51
Keep us informed if you find something. Good luck. I do understand about limited (dumbed down) options in pre-built computers.

One left field thought is that someone may have flashed the BIOS with the wrong version. I think that model laptop came in several configurations. Or the BIOS is corrupted. Check out the link below. Choose the exact model and then look for BIOS & drive firmware updates.


Report •

September 29, 2010 at 06:20:51
Hey if you'd look at my first post you'd see that I've already done that. (twice actually) :-)

I'll keep you posted.

Report •

Ask Question