On Board USB Stopped Working

Asus / P5k
April 15, 2009 at 08:11:11
Specs: Windows Vista 64, Q6600/4GB Corsair
My machine had been working perfectly for the last year, no issues or problems. Yesterday I went to install a new Graphics card. Installed and had to rearrange some things to get everything to fit without issues.
Now when I boot up my machine it reaches the motherboard splash screen and asks me to either Press DEL to go to Setup or press Tab to go to BIOS.

Only problem is suddenly all my USB ports aren't being seen. I've played around with the cables and connectors to see if something came loose or disconnected but everything seems to be plugged in properly and as it was before.

I even went and picked up a PCI USB Card thinking I could just bypass the on board USB just to get my keyboard to work but without the drivers installed for the PCI USB Card it doesn't see it either.

I tried using a USB to PS/2 adapter for the keyboard and no dice there either. It's almost like all my I/O ports don't work at all now. Just for the record I tried all USB ports both front and back ones and the back PS/2 port.

Everything else seems to be working, I just can't figure out how to get into the BIOS to see what is going on. I don't think the Mobo went bad on me as I don't think it would go to the MoBo splash screen like usual if the MoBo was fried.

Does anyone have any ideas or suggestions or something similar to this?

My motherboard is the Asus P5K model, note that it is the standard P5K and not any of the P5K - E or -WS type models.

Any help would be greatly appreciated.


See More: On Board USB Stopped Working

Report •

April 15, 2009 at 10:25:50
My guess would be that when you unplugged the computer (you did that didn't you) the BIOS reset to default settings due to a dead CMOS battery.

If you are using a USB keyboard it may not function in the pre-Windows screens. That is by default. You need to enable legacy USB devices in the BIOS. However, you can't do that when using a USB keyboard.

The solution is to at least temporarily connect a PS/2 keyboard while you are shut down. That should allow you to enter the BIOS to change the setting.

If you know for sure that your USB ports are not functioning when in Vista then this is not the solution.

Report •

April 15, 2009 at 11:07:35
I have tried using a USB to PS/2 adapter to hook up my keyboard to the PS/2 Port. It didn't respond to that either.

It's like all my I/O ports aren't being recognized. And yes I did remove all power from the MoBo before removing old hardware and installing new.

I do believe this is a simple issue of the BIOS not seeing the USB right now, but am clueless how to get around the issue of the keyboard not working and having to use the keyboard to get the BIOS up.

Report •

April 15, 2009 at 11:12:24
Using an adapter may not work because not all USB devices work with adapters. You need to use a PS/2 keyboard.

Report •

Related Solutions

April 15, 2009 at 11:17:51
Oh. I wasn't aware of that. Guess I will have to go buy a PS/2 keyboard. When will they stop making those though, I can't believe people would still use them.. lol.

Will update once I've tried that, but any other suggestions would be welcomed.

Report •

April 15, 2009 at 11:28:43
I hope they NEVER stop making PS/2 keyboards. They are superior to USB in every way. You could just borrow one or pick up a used one at Goodwill or anther resale shop.

The real reason why OEMs went to USB is to eventually eliminate the PS/2 ports from the motherboard to save money. That doesn't make USB better, as you have found out.

Report •

Ask Question