Old system won't boot new drive

February 16, 2009 at 07:36:20
Specs: Windows XP, PIII - 650
My ’03 eMachine started freezing up and then stopped completely. I think it is a power supply problem. I took the system drive (new in ’07) and put it in an old tower I had. I first booted the old tower to make sure it worked; everything was fine. With the newer drive it got through the BIOS and recognized the drive, but when it would normally load Windows it gave me a “LOAD ERROR”. I pulled the jumper off and the BIOS recognized it as a slave and still would not load. I connected it as a slave to the old system drive; it was recognized as a slave, Windows runs fine from the old system, but the new drive is not being assigned a letter and I cannot get manager to assign one; the option is grayed-out. I think this is a GoBack problem. Any suggestions? I really need to at least get some files off of this old drive ASAP. Thanks.

See More: Old system wont boot new drive

Report •

February 16, 2009 at 09:05:07
You can't just swap a HDD from one system to another. The XP installation is tied into the machine it was originally installed in. You will have to reinstall XP using the "repair install" method. Otherwise, you can install it in another working system as the slave, then retrieve your files after "taking ownership".




Report •

February 16, 2009 at 09:49:12
3 years old, relatively, is not old.

Since you are talking about a jumper for slave/master, I am assuming you are talking about (an) IDE hard drive(s) - SATA drives do not have such.

Older mboards/bioses (e.g. 5 years old or older or so) will NOT recognize an IDE drive AT ALL if it is jumpered as slave and is by itself on an IDE data cable, or if it is jumpered cable select and it is on the middle connector of a 3 connector data cable, and is by itself on an IDE data cable.

Newer mboards/bioses will recognize a IDE hard drive installed by itself even if you do have it jumpered as slave and it's by itself on an IDE data cable, or if it is jumpered cable select and it is on the middle connector of a 3 connector data cable, and is by itself on an IDE data cable.
However, it is NOT recommended that you do that, because some things will NOT work correctly unless the drive is jumpered as it should be when it is by itself on a data cable - as master, or as cable select and on the END connector of a 3 connector cable.

Some IDE hard drives (e.g. some Western Digital models) have TWO ways they can be jumpered as master - as master with no other drive present on the same data cable, or as master with a slave drive present on the same data cable. Such a hard drive may not work properly or be recognized properly if it is set to master with a slave drive present when there is no slave drive present.

If you are using an 80 wire data cable for the IDE drive (that's a requirement for any hard drive that supports UDMA66 or higher) the blue connector on one end of the IDE data cable MUST be connected to the mboard header, otherwise you are likely to have problems.

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittant, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

emachines computers are well known to have el-cheapo power supplies that tend to fail more often than average, and when the power supply fails completely, they are a lot more likely than average to damage something else, often the mboard.

If you have not been fiddling inside the computer case just before this happened and have not changed the ram installed in it, it is very likely that if you replace the power supply BEFORE it fails completely, doing that will restore your system to working fine again.

Unplug the cord to the computer, or otherwise switch off the AC power to it, open up the computer case, and find the label on the power supply - if the brand is BESTEC I advise you, if you find ANY indication the power supply might be in the process of failing, DO NOT trying booting the computer anymore - if the PS fails completely there is a strong likelyhood it will trash your mboard!!!!

Failing power supplies are common and can cause your symptoms.
They often partially work, fans and hard drives spin, leds come on, yet you get no video and the mboard will not boot all the way.
Check your PS.
See response 4 in this:

DO NOT replace the power supply with another BESTEC one!
In most cases you can replace with a standard sized standard ATX power supply.
If you tell which emachines model it is, I can probably confirm that.

Standard PS/2 size - 86mm high, 150mm wide, 140mm deep, or 3 3/8" h x 5 7/8" w x 5 1/2" d , or very close to that, though the depth can be more or less for some PSs.

"With the newer drive it got through the BIOS and recognized the drive, but when it would normally load Windows it gave me a “LOAD ERROR”...."

When you install and try to boot a hard drive that has already had 2000 or XP Windows set up on it when the drive was connected to one mboard, on a different mboard, if the chipsets are more than alittledifferent, the hard drive will boot, but 2000 or XP will not boot all the way into Windows. Typically, you see the first bit of Windows graphics you normally see, then a black screen with a blinking cursor top left and nothing futher happens - there are no messages at all. If you were seeing that, running the "Repair install" (I prefer to call it a "Repair Setup" - Windows has never been installed using an Install program) procedure jam has mentioned will fix the hardware settings incompatibilty problem in Windows without you losing the data you have added to the Windows partition after the last time Windows was installled from scratch.

However, going by your description, you are getting an error message that I have never seen in that circumstance - that error is probably caused by something else.
- you jumpering the drive as slave when it should be jumpered otherwise
- or - you have another problem with the data cable or the connection of the drive to it
- or you have some other problem.

A common thing that can happen with ram, even ram that worked fine previously, is the ram has, or has developed, a poor connection in it's slot(s).
This usually happens a long time after the ram was installed, but it can happen with new ram, or after moving the computer case from one place to another, and I've had even new modules that needed to have their contacts cleaned.

See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:

If you have installed ram that was not installed before in the same mboard when the system was working fine, it may not be 100% compatible with the main chipset of the mboard, or on more recent mboards not 100% compatible with the memory controller built into the cpu. If you still have the ram that worked fine previously in the same mboard, try installing just that ram.

The original hard drive, or less likely the newer hard drive, may be starting to fail.
Check your hard drive with the manufacturer's diagnostics.
See the latter part of response 1 in this:

(thanks to Dan Penny for this link:)
Hard Drive Diagnostics Tools and Utilities

If you don't have a floppy drive, you can get a CD image diagnostic utility from most hard drive manufacturer's web sites, but obviously you would need to make a burned CD, preferably a CD-R for best compatibilty, on another computer if you need to.

If the hard drive itself tests okay, any data problems found can be fixed, one way or another.

Report •

February 16, 2009 at 12:28:43
Goback is a drive overlay that needs to load before the drive contents can be accessed. When you connect it as a slave, Goback doesn't load so no access. Likely XP isn't even seeing the Goback partition as valid. That's why it's not assigning a drive letter when it's used as a slave.

You've got two problems in recovering the data. First you need to boot from the drive to get Goback to load. Secondly, it's an XP drive so it needs to be in the original PC for XP to load. So you need to fix the emachine. If it's just the PSU then that's no big deal.

Circumstances like this are why you should never ever install Goback.

Report •

Related Solutions

February 16, 2009 at 12:48:23
Did you actually install GoBack and use it to load a previous configuration when the one you were using wasn't working?
If you didn't load a previous configuration by using it when the one you were using wasn't working, it's got nothing to do with your problems.

Report •

Ask Question