Odd USB sounds

October 18, 2009 at 23:49:54
Specs: Windows XP Professional 2002 SP2, Pentium 4 3.00GHz/3.01GHz/2GB
My computer seems to make odd, high-pitched whining sounds when I connect certain things to the USB ports. Specifics include my Adaptec GameBridge and digital camera. It doesn't seem to occur when I connect my iPod or PlayStation 3 controller. It doesn't matter which USB port I use, it still makes an odd, obnoxious sound. It's not incredibly loud, but it's audible and obnoxious. Any ideas?

See More: Odd USB sounds

Report •


#1
October 19, 2009 at 15:51:05
See if you can determine if the sound is coming from the power supply.

Report •

#2
October 20, 2009 at 12:49:28
I can't tell. It does seem to be coming from the back, however, the sound isn't loud enough for me to pinpoint where exactly it's coming from.

Also, I was wrong, it does occur when I insert my iPod or video game controller into the USB slots.


Report •

#3
December 4, 2009 at 20:17:50
This problem is still occurring. Does anyone have any other ideas?

Report •

Related Solutions

#4
December 5, 2009 at 00:24:45
To help you isolate the sound get a piece of flexible tubing. Stick one end in your ear and use the other end as a stethoscope. USB devices typically are powered from the port so it could be your powersupply is protesting at the added load.
What brand/model PSU do you have and what are the amp ratings on each rail? A label on the side of the PSU will give you this info.

Goin' Fishin' (Some day)


Report •


Ask Question