NTFS/FAT error trying to recover dropped 1TB USB HDD

August 15, 2012 at 05:39:35
Specs: Windows 7
So... my external Harddrive (WD Mypassport 1TB) dropped from about a foot off the ground and now windows sees it (when I look in device management) and, though it takes a few minutes, even assigns a letter (when I look in windows explorer) but when I try to right-click in order to go to properties/tools the system freezes and I get a "not responding" window.

Through computer management, I get the same "hang" when I try to look at the storage data for this HD.

My guess is the File allocation is corrupted but I don't know how to recover it. Worse case scenario, I could reformat the drive (though I rather recover the data on it first) but even for that, I would need to right-click on the drive letter and it "hangs" when I try to do that.

Any ideas?

See More: NTFS/FAT error trying to recover dropped 1TB USB HDD

Report •

August 15, 2012 at 06:09:54
The file allocation doesn't get corrupt by dropping the drive. You physically damaged the drive by dropping it. If you can take it apart, check for any physical damage. See if you jarred it loose from the fall. I doubt it though. If you can get it apart, remove it from the enclosure and slave it to your computer. If it doesn't read connected to the computer, it's toast.

Report •

August 15, 2012 at 08:47:51
Follow the advice in #1 above. If there is a drive letter assigned you could try recuva. Most likely you have damaged at least some of the heads/platters. Some may be recoverable. Get recuva from the link below.


Report •

August 15, 2012 at 09:02:56
Try recovery software like testdisk, photorec, recurva or others before you get too far along.

Don't know what part is bad but the heads could have damaged a spot or more on the disk inside when it was dropped.

Google is evil

Report •

Related Solutions

August 15, 2012 at 13:15:13
Just to state the obvious, when #1 says "take it apart" it means the external casing only, not the drive itself! Most of them use security screws novwaday, which would make it impossible to disassemble the actual drive.

Report •

August 15, 2012 at 16:57:45
Left the drive alone for a while. Tried testdisk but couldn't find any partitions. Then closed testdisk and opened an explorer window. To my surprise, the drive was reading correctly and main file structure was there but no data in them. When i checked the drive through disk management, it said drive was NTFS, healthy, no partition info or something like that. Left the computer for a while and when it came back from sleep, i had no access to the drive again.

So apparently the drive is not completly fried but i can't figure why testdisk couldn't even read the partition information.

Then i tried recuva but either it froze or i didn't give it enough time. Program didn't seam to be responding.

Again...any other ideas? I kind of want to try all my options before opening it up.

Thanks for the responses so far and the ones to come.

Report •

August 15, 2012 at 20:12:26
The only other choice may be to remove the drive from the enclosure and put in either in a new enclosure or computer to attempt to recover data.

Google is evil

Report •

August 21, 2012 at 05:21:42
Kernel for Windows Data Recovery is impeccable and most proficient Windows Disk Recovery software that has been devised to cater the need of recovering the data lost from computer's hard disk or other storage media like PEN drive, ZIP drive, etc. The tool has got GUI that further makes it easy to operate and user-friendly Windows data recovery utility.
For more details - http://www.downloaddatarecovery.net

Report •

August 22, 2012 at 13:37:17

Your post appears to be advertising material taken from a website or websites.
Many Google hits include the same words, such as "impeccable".

Do you work for them?

If not can you personally vouch for the product?

Always pop back and let us know the outcome - thanks

Report •

Ask Question