Solved No post with RAM installed but beep without RAM

November 17, 2012 at 22:10:04
Specs: N/A
When I don't have RAM installed there are three beeps, which means the CPU has been detected but no RAM right?

After I put the RAM in there is silence and no post. Why is this?


ASRock z77 Extreme4
Kingston HyperX 8GB 1600 DDR3
GTX 660 Superclocked
Seasonic 620W

See More: No post with RAM installed but beep without RAM

Report •

November 17, 2012 at 23:17:18
It's not likely the problem is the ram. When you remove the ram you get a ram error beep. When the ram is installed you don't get the ram error beep. The problem is somewhere else.

Did anything happen to the PC or did you make any changes between the last time it worked OK and the first time it didn't?

Are you sure the monitor is OK and has a tight connection to the PC?

Report •

November 18, 2012 at 05:01:45
Has this system ever run or is this a new build?
If it is, pull everything and bench test it.
If it has worked, pull the video card and try the on-chip graphics.
Try it with only one stick of memory.
Remove anything not required for posting, including hard drive.
Reset all connectors.
Make sure CPU fan is plugged into the CPU Fan connector (some motherboards will not post unless there is a CPU fan installed).
Clear CMOS, then if it posts, reset to defaults and then manually set the required settings.

You have to be a little bit crazy to keep you from going insane.

Report •

November 18, 2012 at 23:48:01
✔ Best Answer
Thank you, DAVEINCAPS and Fingers for the responses. It was the peripherals that weren't responding for some reason and causing my motherboard not to post. After reconnecting the monitor and keyboard everything worked out fine. I'm sorry if that's pretty noobish but I very much appreciate the help!

Report •

Related Solutions

November 19, 2012 at 00:21:48
You're welcome. We're glad you got it working.

Report •

Ask Question