No easy fix - Windows can't open Add Printer

Microsoft Windows vista ultimate - 32-bi...
January 19, 2011 at 16:13:33
Specs: Windows Vista
I have been using the same laptop (Sony Vaio - VGN-N320E) and All In One Printer (HP Office Jet 7310) for 2 years. About a week ago my printing function stopped all together. Thinking it was maybe a change in drivers or something got deleted somehow, I unistalled the printer, restarted my computer (just to be safe) and then went to reinstall the printer. I tried to install the printer from the HP installation disc, it says that I am not the administrator even though I was logged on as the Administrator (I have 2 users: Administrator and another that I use for everyday use). I then tried to install the printer from the Control Panel/Printers using the "Add Printer" function. I immediately receive a pop up box saying "Windows can't open Add Printer". I have been through countless forums on this topic and have yet to find anything that works (including ensuring my print spooler is running and set to automatic). I am completely lost!


See More: No easy fix - Windows cant open Add Printer

Report •

January 19, 2011 at 16:22:51
Maybe your Vista files are corrupted. As a starting point go on-line and find out how to use your installation disk to run a repair on the OS, then try again. I've done it before but it was several years ago and don't specifically remember how to do it, but it's not a difficult or complicated process. You will have to go into your bios and change the boot sequence so the CD is first in order to run the program.

Report •

January 20, 2011 at 09:47:28
I will give it a shot and let you know how it goes. Thanks for the response!

Report •
Related Solutions

Ask Question