Solved No A drive or cd access to install W95 HELP!!

September 15, 2011 at 13:11:14
Specs: Windows 95
Hi, I am trying to install a windows 95 operating system to an old HP Pavilion. I put the cd in and have a 95boot disk. I can get it into safe mode and it starts windows 95 but the OS is still NOT installed. Is says the A: drive is no longer valid ( dos system says this) and the cd does work with another boot disk (Ultimate boot disk)but not when I put the windows 95 disk in. The system also says they might be running in dos, and when I try to access the A drive is reads NOT READY or in use?? any takers on this one? haha
Thank you.

See More: No A drive or cd access to install W95 HELP!!

Report •

September 15, 2011 at 14:59:15
✔ Best Answer
How old is this 'old' HP pavilion? Maybe there's a hardware issue.

You only need the floppy bootdisk to start the installation, which is what seems to have happened. After that it's done its job and the installation continues with the hard drive and cdrom so I don't understand how an 'invalid drive specification' error is coming up with the floppy drive.

The system will reboot once or twice during the installation but it needs to boot from the hard drive so be sure the floppy bootdisk is removed or you'll just be starting things over again.

You mention the ultimate boot disk--a bootable cd--but I don't think the 95 disk is bootable. I don't know if when you said the 95 disk didn't work but the ultimate disk did you meant the 95 cd wasn't booting up.

Report •

September 16, 2011 at 03:28:04
Hi, thanks for your response. The Pavilion is I believe around 1999 or 2000? not sure, it was handed down and worked great when we got it. I was messing with the thing and changed it from fat 16 to 32, that is when I noticed the A drive not working and it would say the drive is "NOT READY". and that it was in DOS mode? Then I had the brilliant idea to go into the fdisk and I think I erased the whole thing because I could not even use the A: drive to reinstall the system so I ordered a hard drive with windows 95 and that is was I am trying to install now. The Ultimate boot disk is one I ordered thinking it would maybe fix it so that it would initiate the A:drive but of course that would have been way tooo easy! haa
I'm not sure I have the bios set properly either I just set it to default and it picked up on the new hard drive but will still not install the OS.
Thanks again for your reply.

Report •

September 16, 2011 at 10:42:21
Fdisk only works with the hard drive, it won't affect the operation of the floppy drive.

Sometimes windows 95 or 98 will put a drive in 'msdos compatibility mode'.and it's hard to figure out why it happened but usually the drive is physically OK--it's an OS problem. When that happens it won't show in 'my computer'.

That's different than a floppy drive that won't work from the beginning--before the OS loads. When that happens you've got a problem with the drive, its connections or maybe its bios settings. The bios default setting should work OK for the floppy configuration but you need to go back into cmos/bios setup and set the boot order to have the floppy drive as the first boot device. If the hard drive comes before the floppy in the boot order then the computer will try to boot from the hard drive, find that it can't and give an error message and stop there.

I'm thinking your floppy drive is physically OK but you're just not booting from it.

What size is the hard drive and what version of 95 are you trying to install? Assuming you have an OEM 95 cd, look at the line above where it says 'for distribution only with a new pc'. It'll start with something like '0196 part no.' or '0795 part no.' Post back what it says there. The first version of 95 wasn't fat32 capable and it'll affect how you set up the hard drive.

Also you just say it won't install the OS but it must give you some error messages. What does it say exactly?

Report •

Related Solutions

September 17, 2011 at 10:19:06
Hi, I made mistake earlier and said it booted from the ultimate boot DISK. it is an ultimate boot CD. sorry. The windows 95 CD starts with 0796part number000-45234. also,when the machine starts up sometimes it will go rite to the menu for safe mode or regular... but other times I start and it goes directly to "No operating system found".
really weird. It says on the first menu(before the little blue dot in the corner of the screen comes up) that it is reading Drive A: and the CD is also listed but when i can get it into safe mode and go to the media center it says there is NO CD attached??
I will have to get back to you on the hard drive and I am not sure of what version of windows 95 the disk only says windows 95?
Thanks again.

Report •

September 17, 2011 at 14:09:10
Yeah I thought the ultimate disk was cd. I think that's the only way it comes.

The 0796 means it's a later version and does have fat32 support.

In 95 safe mode the cdrom isn't recognized so that's probably the reason you don't see it.

You may need to start over. Fdisk to remove and recreate the partition. Format and install it again.

But post back the hard drive model number or it's size. If it's too big that'll be a problem for 95. Also how much ram is in it?

Did the computer have 95 on it when you got it? If so, there shouldn't be a hardware problem affecting the install.

Report •

September 18, 2011 at 13:46:21
Hi, the hard drive is a Cavier,Western Digital 21600 3148cyl,16heads,63spt 1624.6 mp? I am not sure of the RAM. This is the one I puchased with the windows 95 cd. I took the one that came with it out because it wouldn't do anything, I could not get it to go into safe mode it would only go the blue screen and say"No Operating system found.
Thanks again.

Report •

September 18, 2011 at 13:58:24
Also the computer had windows 95/98 on it. I pretty sure.

Report •

September 18, 2011 at 17:08:30
OK, that's a 1.6 gig drive so 95 shouldn't have any problem with it.

'No operating system found' means the bios can't find the system files on the drive it's trying to boot from. In some cases that's because the floppy drive is first in the boot order and you've left a non-booting floppy disk in it.

Otherwise the problem is with the hard drive. Have you verified the jumpers are correct on it and it's connected right? Does the drive show up in cmos/bios setup and/or the posting screen?

If all that looks OK you should probably start over and fdisk and format again. I went into some detail on that in my # 13 here:

(95 will be the same as 98)

Some 95 bootdisks aren't the best. Some don't even have cd support. If you think you may be having problems with it you can use a 98 bootdisk. There's some for download at places like or I can email you mine.

If you continue to have problems installing 95 you might consider 98 instead. If you can't find a 98 disk locally I can probably burn a copy and mail it.

Report •

September 19, 2011 at 05:54:25
Hi, used another disk and it finaly worked! happy day!! Thanks for all your advice.
have a great day.

Report •

September 19, 2011 at 14:15:07
You're welcome. I'm glad you got it fixed.

Report •

Ask Question