New Build Won't Power Up

June 2, 2009 at 12:21:41
Specs: N/A, AMD Phenom X4 9500 2.20Ghz Socket AM2+
Hey everybody,
I just put together a bare bones kit (Specifications below) that I bought online and I'm not able to get it to power up.
I have everything hooked up and ready to go, but when I plug it in and flip the switch--no fans, no POST beeps.
My instinct tells me that it is the power supply, however there is an LED on the system board that lights up when I plug in the power cable, so I think that negates that theory.
I've tried minimal install-just graphics adapter, 1 memory DIMM and the CPU and fan--and it still doesn't power up.
My only theories are
1. Bad power supply.
2. Bad power switch connector or
3. Short in the chassis or
4. Bad motherboard

It's been a while since I've put together a computer so I'm not sure if there is something obvious that I have forgotten. If anybody has any advice that could help me out it would be greatly appreciated.

Thanks in advance.

System specs:
Asus M3N78 PRO ATX Motherboard
AMD Phenom X4 9500 2.20GHz Socket AM2+ Retail Processor
OCZ SLI-Ready Dual Channel 4096MB PC6400 DDR2 800MHz Memory (2x2048MB)
Sparkle GeForce 9400 GT Video Card
Sony DRUV200A/BR DVD/CD Rewritable IDE Retail Drive
Ultra LS500 Lifetime Series 500W Power Supply

Also at:

See More: New Build Wont Power Up

Report •

June 2, 2009 at 12:29:19
You should always benchtest before installing the hardware in the case. Strip it down to the bare minimum & try again...disconnect all drives (both the power & data cables), use only one stick of RAM, remove video card & connect monitor to the onboard video, disconnect all case wiring except power switch (make sure it's correct), unplug all case cooling fans, disconnect all external devices except keyboard, double check the two PSU connections to the board. Then try to boot. If it doesn't work, remove the board & benchtest like you should have done in the 1st place.

Report •

June 2, 2009 at 13:19:18
Have you gone through the mobo manual and made sure that ALL of the jumper settings are correct?

Report •

June 2, 2009 at 14:11:46
Thanks jam,
I should have noted that it is stripped down to the bare minimum--I guess that was implied--though you're right, I should have bench tested initially.
I have pulled out the MB with just the essentials connected and I get the same thing.
I actually tried switching out the power switch and speaker with one I had around that I know works-just in case-since the ones on the case seem somewhat cheap.
I would assume the power supply is the problem except that the LED indicator on the MB is activated.
The fan in the PS and the CPU fan still do not spin up.
What do you think?

Report •

Related Solutions

June 2, 2009 at 14:12:49
Thanks warwickboy,
There's actually only one jumper and that's for the CMOS reset. Good advice though.

Report •

June 2, 2009 at 15:43:35
"I would assume the power supply is the problem except that the LED indicator on the MB is activated"

All that's telling you is the PSU is putting out enough power to light up an LED.

Report •

June 2, 2009 at 15:53:04
It's either the PSU or motherboard. Try another PSU and if it does the same thing then it's the motherboard and return it.

It happeneds. sometimes you get a bad batch.

Iron Sharpens Iron.

Report •

June 3, 2009 at 11:50:12
I tried a different PSU that I know works (However it is a 450W and not 500) and that did not work either.
Though the manual for the MB suggests using a 600W PSU or greater, I bought this as a kit and it came with a 500W PSU.
I find this curious as well--though I doubt they would sell a kit without enough power to start.
Thanks for the advice guys.

Report •

June 3, 2009 at 12:54:29
I'd return the entire kit for a replacement. You need a solid starting point out of the box, not a crapload of problems to solve.

As to the power supply, compare this 550w against yours

Note the differences, especially on the +12vdc rail.


Report •

Ask Question