New Build - Unable to enter Gigabyte Z390 BIOS

June 14, 2020 at 15:21:59
Specs: n/a
Sorry to spam the community with yet another post about this. I have unsuccessfully scoured the web for the last few days trying to find a solution, but apologies if I've missed something glaringly obvious.

This is my first full build, with all new components, and I am experiencing unsettling activity when booting, and am unable to access the BIOS page. I have tried the following solutions based on what I've read so far:

1.Spamming the delete key (the specified key for entering BIOS with the Z390 MB)
Spamming all the other keys for good measure
Removing the CMOS battery for long enough to prompt a message upon re-boot telling me BIOS has been reset. Clicking 'okay' here does not take me to BIOS settings, only to the main systems page
Used all the USB ports available. USB 3 and 2
Tried warm and cold boots
Tried multiple RAM configurations
Tried one stick of RAM only
Removed both hard drives and the graphics
One solution I haven't tried yet is using a PS2 keyboard, as I've read that this can resolve the problem. I will be able to try this solution next week.

I am able to access the other menus by pressing F9 (system information) and F12 (Boot Menus). Not the BIOS. though.

Fast Boot is disabled.

And, the other problem I'm experiencing - which i'm guessing is probably related to the BIOS issues- is when doing a cold boot the system turns on and off 2-3 times before staying on. And although all fans are on and seem to be working fine, the CPU fan is not seen by Gigabyte, which displays 'N/A' next to the name. I have confirmed that the CPU fan header is correctly connected on the MB,

My specs are:

MB: Gigabyte MB INT 1151 Z390 Designare D4 ATX
CPU: Intel Core i9-9900K
Graphics: Sapphire Pulse Radeon RX 580
RAM: Corsair Vengeance RGB PRO 32 GB
Cooling: Raijintek Orcus 280
PSU: Seasonic Focus GX 750 750W
Hard Drives: Samsung 970 EVO SSD 1TB + Samsung 860 EVO 1 TB SATA 2.5

Any help would be massively appreciated, I think I'm at the limit of my abilities here. Thanks in advance.


See More: New Build - Unable to enter Gigabyte Z390 BIOS

Reply ↓  Report •

#1
June 14, 2020 at 16:31:48
Were you ever able to get into the BIOS using your USB keyboard? At what point did you reset the BIOS? The reset may have changed the USB keyboard setting. I'm guessing a PS/2 keyboard will work.

Reply ↓  Report •

#2
June 14, 2020 at 16:39:22
Hey, thanks for your reply.

I haven't got into the BIOS setup yet, no.

I reset it after trying out quite a few other solutions.

Yes, hopefully the PS/2 keyboard will do the trick. No point despairing until ruling that out, at least!


Reply ↓  Report •

#3
June 15, 2020 at 03:40:31
So I realised what was going on. I have been following a particular build guide, which was using terms that reference an older version of the Gigabyte BIOS. It turns out that in the latest (F8) iteration, Gigabyte have redesigned not only the layout, but the names of the tabs. This isn't reflected in the manual either.

Long story short, I've been getting into BIOS the whole time but I didn't know it!

Thanks for the help, much appreciated.


Reply ↓  Report •
Related Solutions


Ask Question