network adapter code10 until new adapter in

Gigabyte / Nvdaacpi
July 16, 2010 at 10:31:44
Specs: XP Home SP3, 3.0 / 1gig
Another weird one. This pc had a problem
with bogus AV - AntivirusGT - sorted that but
ended up with the integrated network adapter
(Broadcom) having a code 10 error. Couldn't
find any more recent drivers for it so decided to
put in a cheap PCI LAN card & disable the
original one. As soon as I installed the new
(Realtek) card the original started working!
Removed the new card & the broadcom
stopped again. Tried another, cheaper, card &
this time didn't even need to install the drivers,
the broadcom sprang into life. Not too worried
about leaving the 2nd LAN card in to keep
things working, but has anyone else come
across this & have an explanation?

"I've always been mad, I know I've been mad, like the most of us..."

See More: network adapter code10 until new adapter in

July 16, 2010 at 12:18:39
That is why I reload the whole deal.

See what hardware manager and event logs say for more info/

I support the 'Everybody Draw Mohammed Day'. A religion doesn't deny my freedom.

Report •

July 16, 2010 at 12:34:56
Bit overkill reloading the whole thing - adding a cheap network
card was quick, simple & solved the problem, but I can't
immediately see why. Device (hardware?) Manager is where the
code10 error appears and Event Viewer in XP doesn't give any
more clues.

"I've always been mad, I know I've been mad, like the most of us..."

Report •

July 16, 2010 at 13:12:41
"This pc had a problem
with bogus AV - AntivirusGT - sorted that"

What did you use and/or what did you do yourself to get rid of that?
That was crap installed by the makers of "rogue" anti-malware software. Malwarebytes specializes in getting rid of that, and is probably the best at getting rid of that without doing damage to your Windows installation otherwise.
Whenever you suspect you have that, search using the name of it that's obviously popping up along with Malwarebytes.
E.g. AntivirusGT Malwarebytes
If you get lots of hits saying Malwarebytes will get rid of it, don't bother using or doing anything else, use Malwarebytes. If many things are disabled, there are ways around that, that allow you to use Malwarebytes.

Did you install some hardware device, other than a USB connected one, and it was after that the onboard network adapter was showing the code 10?

The fact that you have the code 10 when the other network adapter is NOT installed in a slot, and you don't when the other card IS installed in a slot, assuming there's nothing wrong with the "drivers" for the onboard adapter, probably indicates there is a resource conflict - for an IRQ probably - when the card is not installed that is solved when the card is installed, because Windows often shifts which device uses what IRQ when you install a new device.

DO NOT install any PCI card other than a PCI video card in the first of the PCI slots closet to the center of the mboard. That slot is forced to share it's IRQ with the video, and you're likely to have problems with that card, or with some other device because that card is in that slot, unless the card is a PCI video card.

If installing a PCI card results in another device being disabled or for it to have a problem, install the PCI card in a different slot, other than that first one.

Any hardware device that's built into the mboard is NOT a CARD - a CARD plugs into a mboard slot and is removable.

If you have installed "drivers" for the onboard network adapter, you may have installed the wrong ones, or installed the right ones the wrong way.

If the "drivers" for the onboard network adapter are not built into Windows, the Gigabyte web site has the proper "drivers" for the integrated network adapter in the downloads for your specific mboard model.

BEFORE you install that software...
You should un-install any listings you see in Control Panel - Add / Remove Programs for the onboard network adapter.
If you did un-install that, reboot.
DO NOT install drivers for that network adapter while booting by pointing Windows to where the drivers for it are.
Go to Device Manager - if the onboard network controller is still listed, RIGHT click on it, Un-install it .
DO NOT install drivers for that network adapter while booting by pointing Windows to where the drivers for it are.
Run the "drivers" installation for the onboard network adapter after you have gotten to the desktop screen.

Report •

Related Solutions

July 17, 2010 at 00:21:19
Oh dear, a long one. OK, for a start, I removed Antivirus GT
manually - all registry entries, files & starutp-up links. It's not
one of the worse ones so was straightforward (do a Google &
you'll find numerous walkthroughs).

I did then run Malwarebytes, the original and genuine, but it
found nothing else.

I never said the original adapter was a card - I did say it was
integrated & I do know the difference.

It is an Asus motherboard, in a mini 'designer' case so (1)
Asus don't list it any longer hence not being able to find any
drivers & (2) Broadcom list the adapter but don't have any
more recent drivers than 2002, same as the existing one. (3)
There's only 1 PCI slot and 1 (unfilled) AGP slot. I went
through the process of uninstalling & rebooting it to try & find
the drivers - Windows update hasn't got any newer ones
either, but as the device is recognised correctly, the driver
version is the same as the 'latest' one from Broadcom & so I
don't suspect a driver problem, especially as the addition of
the second (plug-in) card makes Windows load the correct
driver for the original one.

I like the idea of an IRQ conflct, shall look into that when I get
a chance later - hadn't thought of the possibility of another
adapter 'pushing' the old one's IRQ around, & not totally sure
if that would work as there has been no change in the
hardware, only the removal of the malware, but certainly
sounds like the best shot.

Many thanks for response.

"I've always been mad, I know I've been mad, like the most of us..."

Report •

July 18, 2010 at 08:11:04
" It is an Asus motherboard, in a mini 'designer' case so (1)
Asus don't list it any longer ..."

Gigabyte has (and some other mboard makers have ) definitely lost the info and support for some of their older mboard models, but I've been able to find drivers listings for all the Asus retail mboards that I can recall.
Asus (and Gigabyte, etc.) makes many OEM only mboard models - they're supplied only to brand name system builders, and there is no support for the model on the Asus web sites. They're very similar, but not identical, to Asus retail models.
If you supply the model and Rev. or Ver. printed on the mboard surface, we may be able to dig up info and the drivers listed for it.
They also make / have made a small number of Asus systems. A mboard that's in a Asus system may not be in their mboards listings.

If you find the model on the Broadcom chip, you can find the correct drivers if you make sure they're for the right model, but randomly searching for Broadcom drivers without that is likely to find ones for the wrong chip.

Generally, network adapter drivers are quite stable, and it's not surprising that no newer drivers would be available. Whatever drivers worked fine before should work fine now.

Sometimes you see indications of what the problem is in System Information, sometimes you don't.
(shortcut - Start - Run - type: msinfo32 , click OK or press Enter)
On the left side, open up Hardware Resources - IRQs
When the device is built into the mboard, it's usually okay for more than one of certain devices to use the same IRQ, but it's preferable for the built in network adapter to be the only one that uses a specific IRQ.
When you have a network card in the PCI slot, you will probably see that the two different network adapters are assigned an IRQ, probably two different ones.

When you don't have a network card in the PCI slot, when the Broadcom adapter is showing code 10 in Device Manager, there is probably no IRQ listed for the Broadcom adapter.
Also, when the Broadcom adapter is showing code 10 in Device Manager, if you open up Components - Problem Devices, you may see that there is something listed about the Broadcom adapter.

Built in USB 1.x controllers that older mboards have use one IRQ. Built in USB 2.0 controllers that newer mboards have use two IRQs, one for USB 1.1 support, the other for USB 2.0 support. There is usually more than one USB controller related listing than uses the same IRQ, that's fine, but you can have problems in some situations if the IRQs the USB controller related devices use are shared with other devices.
On a desktop system, you're more likely to have that problem when a card is installed in a mboard slot other than the dedicated one for a video card (the AGP or PCI-E X 16 slot on newer mboards).

Things you could try.

When the Broadcom adapter has the code 10 error in Device Manager, look at it's Properties
- if it says it's disabled, try enabling it.
- if it says there is some other problem, RIGHT click on the Broadcom adapter's name, choose Un-install, click on OK, reboot.
That MIGHT re-install the drivers automatically and it might then work fine. If not, try re-installing the drivers for it, taking into account what I told you you need to do above (un-install any listing for it in Add Remove programs, reboot if that apllies, un-install it in Device Manager if it's still listed there, reboot, install the drivers after the desktop has loaded.)

Go into the bios Setup and find the setting for "PNP aware operating system (OS)" or similar - whatever that is set to, try setting it to the other choice, Save bios settings. Sometimes changing that shifts IRQ assingments in Windows and solves an IRQ conflict problem.

These also might shift IRQ assignments and solve an IRQ conflict problem...

If you're not using a PS/2 mouse, go into the bios Setup and disable the PS/2 mouse support - doing that usually frees up IRQ 12, which a few devices including network adapters and USB controllers can use.

Go into the bios using a PS/2 keyboard. Disable all the USB controllers, if you can (you may only be able to disable the USB 2.0 controllers , not all of them, which is less likely to help.)
Boot the computer into Windows a least once.
If you were using a USB mouse and have no mouse in that situation,
- if you need to Logon while booting, use the Tab key to toggle which choice is active, Enter to choose it, type the password if you need to
- after Windows has loaded, press Alt-Ctrl-Del, then Alt-U, then R to Restart the computer.
Go back into the bios Setup and enable the USB controllers.
Sometimes doing that shifts which IRQ(s) the USB controllers use(s). E.g they can often use IRQ 12 .

Report •

July 18, 2010 at 08:25:37
Thanks for reply

It seems to have temporarily cured itself. The second time I removed the PCI card & rebooted it happily started the original on-board adapter - whether it needed a proverbial 'boot in the IRQ's' I don't know.

For info, the board is an Asus P4RBT (no Rev. no.) in an 'Asus T2 Terminator' small form case. Can't remember off-hand what the broadcomm adapter was but Windows recognised it, just had the code10 issue.

"I've always been mad, I know I've been mad, like the most of us..."

Report •

July 18, 2010 at 10:18:46
"....the board is an Asus P4RBT (no Rev. no.) in an 'Asus T2 Terminator' small form case."

That's not a case name - it's a Desktop PC - Barebones name.

I found no manual for the specific mboard itself, but there is support for the Terminator T2 Desktop PC - Barebones series.

Apparently there are Terminator T2 models with mboards for AMD cpu sockets / cpus, and T2 models with mboards for Intel cpu sockets / cpus.
In the manual I looked at for the series, they all have 1 PCI slot, 2 ram slots, and one PCI-E X16 slot (NOT an AGP slot).

"P4RBT" - the T2 model would probably be T2-P, or T2-PH1 or T2-R

Is there one of those on the outside of the case ??

Search results for using T2-R here:

If that's not yours,
Select Model - T2 - T2-P, or T2-PH1 , OK

Scroll down - at left - Download
Includes manuals.

I found no Broadcom or any other wired network adapter listed for any of T2-P, or T2-PH1, or T2-R for XP or 2000, so the support for that is built into 2000 and up.

There are listings for a wireless network adapter but that does not mention Broadcom.

All T2 products

Scroll down to Barebone PC - Minitower - T2

The search box at top left only finds retail mboard models.

On the right - General Downloads
Product - Barebones - Terminator/T2 - Select T2-P something or T2-R
Product - Desktop PC - Home PC - T2-PH1
Manual - T Series Installation Manual (Multiple Languages)

Report •

July 18, 2010 at 11:04:51
Thanks for that, it's definitely an AGP slot, think it must be the T2-P Deluxe, judging by the majority of the specs, though the LAN is listed as a standard Realtek so not too sure. Anyway it's up & running now - need to add a bit more RAM & it'll be a serviceable bit of kit.

"I've always been mad, I know I've been mad, like the most of us..."

Report •

July 18, 2010 at 11:30:19
"the LAN is listed as a standard Realtek "

Realtek apparently provides device drivers for many things that have chips that were not made by Realtek. E.g. I've noticed that some older D-Link wired network cards have Realtek drivers built into XP. Either the chip or card manufacturer's drivers or the Realtek drivers will work fine.

Don't randomly buy ram.

Ram that works in another mboard , or any ram you buy or have lying around, may not work properly, or sometimes, not at all - even if it physically fits and is the right overall type (e.g. SDram, DDR, DDR2, etc.; PCxxxx, xxx mhz) for your mboard. In the worst cases of incompatibilty your mboard WILL NOT BOOT all the way with it installed, and the mboard may not even beep - the ram has to be compatible with the mboard's main chipset, or in the case of recent mboards, compatible with the memory controller built into the cpu.

See response 5 in this for some info about ram compatibilty, and some places where you can find out what will work in your mboard for sure:
Correction to that:

Once you know which module ID strings (part numbers) work in your mboard, you can get them from anywhere you like that has ram with those ID strings.

If you have brand name ram, it is usually easy to look up whether it's ID string is in a list of compatible modules found by using your mboard or brand name system model number.
If the ram is generic, that may be difficult or impossible.

Report •

Ask Question