Need Shuttle 661V31 motherboard BIOS

Dell / Mxc051
August 2, 2009 at 16:19:31
Specs: Microsoft Windows XP Professional, 1.7GHz P-M 740 / 2GB DDR2-667
Have a Slot-1 motherboard which in the lower left says "661V31". Google results suggest it is a Shuttle motherboard.

Shuttle's site has nothing at all except stuff for their current lineup

Board works with a Pentium 2, looking to put a P3 in it (but currently the POST locks up when it goes to write out the CPU name on the screen). P2 is destined for a different computer so getting the P3 working would be nice...I'm hoping a BIOS update was released at some point and is out there, and would allow use of a P3 CPU (so far I've been very lucky; every slot-1 board I've worked with had P3 compatibility fixed by an update...hoping this one will be the same).

If anyone has links to archived Shuttle motherboard files or anything like that (heck, maybe even the CD that came with it?) please let me know. Would like to get this system built up and sold before it's 100% valueless.


Edit: used Internet Archive - found the model in the list but they didn't archive deep enough :(

Could be either of these depending on what the "V" in 661V31 represents:
-HOT-661 v3.1
-HOT-661V v3.1

That "V" might be significant so I'd rather not take my chances bricking the board (I can find BIOS for these question has now changed to "what exactly is the model?")

See More: Need Shuttle 661V31 motherboard BIOS

Report •

August 2, 2009 at 17:21:59
Googling for Shuttle Slot 1 motherboards comes up with lots of hits on eBay. Here are three links that seem to show the model is 661V31.

How much can a system with that MBoard in it be worth? Doesn’t seem like there would be any market. If I am wrong I should try selling some of my SlotA systems. Have 3 in operation at the moment.

Report •

August 2, 2009 at 18:00:28
There are small sort of niche markets in the "kids' first computer" and "getting grandparents online" and "I want a working computer to take apart and learn how things work" areas. I've successfully sold a few systems of similar age in the area of $50 a pop including keyboards and mice...

Get the keyboard and mouse for about 2 bucks each in a thrift store (clean them so maybe a dollar in water and cleaning supplies), power cord the same, parts accumulated through past repairs/replacements basically free. Less than $10 worth of electricity and internet getting the software all set up and it's good to go. I never put more than about $20 into a single system so if I get more than that back, it was worth it.

---back to the topic at hand though---

661V31 is the model number as written on the motherboard, however, this model doesn't actually exist. It is a code for a board in the "HOT-" series, I've found, since the Shuttle website didn't have this board listed under "661V31" anywhere, but did have "HOT-661V v3.1" and "HOT-661 v3.1". Other google results suggest the 661V31 corresponds to something in that "HOT-" series also.

Question is though...which of those two HOT-661 models is it?

Report •

August 2, 2009 at 18:26:07
So, why do you say that model doesn't actually exist. I see many references to that model on the net. Appears Shuttle has pulled all legacy support off any website. I think Shuttle is closing shop on manufacturing motherboards.

Report •

Related Solutions

August 2, 2009 at 18:31:54
I say it doesn't exist because it doesn' is the number written on the board, but the actual model number itself is different from that (if you look at it you see it is the same number exactly minus series name and spaces)

I used Internet Archive to view the version of the site from '02 and sure enough this board is one of the ones I mentioned, not a "661V31" since it didn't exist (and didn't match their model naming scheme anyway). That if anything makes me think it isn't a Shuttle at all, except for all the many google results saying it is.

True, Shuttle is moving towards making only small-form-factor PCs...I've seen a few in local retail stores and they're fairly neat. My concern ends up being heat...the traditional upright case seems to manage heat a lot better.

Report •

August 2, 2009 at 18:54:37
Why not leave the BIOS as is? No P2 processor?

Report •

August 2, 2009 at 19:23:55
I have one, but it's better suited to an IBM which is in a very inconvenient case. I'd rather put the better performing hardware in the more desirable case and leave the older stuff (even if only marginally older) for the less desirable one.

I'd put my Celeron 733 in a slotket adapter and use that but there was no POST when I tried it (I don't even know vcore on these CPUs but I'm certain that's a vcore issue).

Basically, I have the P2 CPU available and know the board works because of it. I would be using that CPU installed during the BIOS update, since it works with it. Hopefully, the updated BIOS (if any) would then "open the door" to using a P3 and then all would be good. Another annoyance is that the aforementioned IBM requires its BIOS to be reflashed every time you swap the CPU for a different one, and I've already got it set up using the P2, so I'd prefer to be able to just pop the P2 back in it when I'm done setting up this Shuttle mess.

Report •

August 2, 2009 at 20:14:31
Updates patched to support recognizing up to and inc. 128gb hard drives (the original update it was made from may not be the newest one available)
661 v3.1 and 661v have DIFFERENT bios strings - shows that here

Note the bios string at the bottom of the first screen as you boot, and compare that to the bios strings listed at the above link.
- usually you can press the Pause key to read it and copy it down.
Press any key but Pause to continue booting.

OR, if it has Windows on the computer....

Go here, download BIOS AGENT.
Run BIOS AGENT to find your bios string.
- here's the link that downloads Bios Agent

The current Bios Agent calls the bios string the Bios ID.

661 manuals
661V manuals

661 bios updates
661V bios updates

Report •

August 2, 2009 at 20:46:43
Just a couple quick comments...

For sure, use the BIOS String to id the board and update.

I couldn't get a slotket to work on a Hot 661 board either; it wasn't a vCore issue with me...just wouldn't work with three different S370 chips.

It's a really good motherboard.


Report •

August 2, 2009 at 21:27:51
Thanks tubes - first link did it. It's a 661, not a 661V. String matches except date; the date of the one for download is two years later (2000 vs 1998 current, probably the original).

Skip - it looks like this was intended to be some sort of professional or maybe gamer board, it has 4 fan connectors and an advanced temperature monitoring system with connections for a front LCD panel. Of course, all that is only so useful today when the best CPU you could pop in here is probably a 600mhz P3 (if the slotkets don't work). If they did it'd be a 1ghz P3.

About to flash it...wish me luck. If it ends up being toast I guess it's not that much of a loss, I have an AOpen in the spares pile which WILL work with the slotket...I'm just a little iffy on its reliability and haven't tested it for long, the Shuttle I saw in operation for like 6 months in its former home.

Though, Award does have that built in fallback system which lets you write a BIOS to a blank or corrupt existing one, so with any luck it wouldn't be toast anyway.

Report •

August 2, 2009 at 22:06:52
(issue that was in this post is gone)

Corrected by using awdflash v 776 (awd776.exe) instead of 8

FLASH SUCCESSFUL, now supports the P3 chip no problem. Thanks for the help

Report •

August 2, 2009 at 22:23:40

It's very important to use the right Award flash utility version sometimes.
However, I've never heard of the wrong version causing a write protect error message.

Report •

August 2, 2009 at 22:27:08
Eek was hoping you weren't writing a reply in the middle of that edit.

Basically it was the fault of me for using a too-new copy of AWDFLASH. Reverting to older copy caused it to work and now I'm having no issues and it supports the P3 chip like I had hoped.

Report •

August 2, 2009 at 22:38:32
"Eek was hoping you weren't writing a reply in the middle of that edit."

I was. I suggested you check the 661 manuals I pointed to if you haven't already, and that sometimes there's a write protect setting in the bios Setup.
And that some of the old PCChips bioses were un-intentionally write protected in the code on the bios chip - there's nothing you can do about that problem other than replacing the bios chip with one that's already flashed with non-write protected code, such as from, with the bios version you want to try.

Report •

August 2, 2009 at 22:59:53
Not that it matters now but the 'V31' is likely 'version 3.1' meaning changes were made in later editions of the board. Sometimes there were different bios' for different versions. The V in 661V may have meant those use a VIA chipset. Asus and some others specified their model numbers that way.

Report •

August 2, 2009 at 23:49:09
Yeah, it looked to me like:

could be
661V, 3.1
661, v3.1

Either way, definitely 3.1...but coulda been a 661V depending on who made the decisions about writing out those numbers I suppose.

I'll be hanging onto that Shuttle HOT-661 v3.1 manual and BIOS file (with correct copy of awdflash) for a anyone in need of it and unable to find it can try contacting me to see if I still have it. Takes up next to no space so I should have it for a while (this is more or less targeted at people in the future who will find this through search results).

Report •

August 3, 2009 at 06:34:43
If there were a V in the model # I would guess that would identify a VIA chip set. Do you have a VIA chip set?

Report •

August 3, 2009 at 07:41:37
Nope, this one's got the Intel 440...think it's BX.

That would suggest according to the "V for VIA" concept that the V meant Version.

Report •

August 3, 2009 at 08:06:24
That would be my guess.

Did you find any BIOS updates for any models? Seems like you are spinning your wheels. Do you even know for sure that a BIOS update will allow the P3 to work?

Report •

August 3, 2009 at 09:04:23
Reply 9 - I found the BIOS file
Reply 10 - I originally had issues, then edited the post saying I got it working perfectly.

Did discover though it was a disaster waiting to happen...was using faulty RAM (discovered this during OS installation). Could have, but fortunately did not, corrupt the BIOS file when it was stored in RAM during the flash. If there was any sort of corruption, it wasn't serious enough to cause malfunctions because machine is running properly.

Report •

August 3, 2009 at 10:46:48
"....was using faulty RAM (discovered this during OS installation)."

99% of the time, there's nothing actually wrong with the ram - it's either not getting a good connection in it's ram slots, or at least one module is incompatible with the mboard's main chipset.

A common thing that can happen with ram, even ram that worked fine previously, is the ram has, or has developed, a poor connection in it's slot(s).
This usually happens a long time after the ram was installed, but it can happen with new ram, or after moving the computer case from one place to another, and I've had even new modules that needed to have their contacts cleaned.

See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:

Ram that works in another mboard , or any ram you buy or have lying around, may not work properly, or sometimes, not at all - even if it physically fits and is the right overall type (e.g. SDram, DDR, DDR2, etc.; PCxxxx, xxx mhz) for your mboard. In the worst cases of incompatibilty your mboard WILL NOT BOOT all the way with it installed, and the mboard may not even beep - the ram has to be compatible with the mboard's main chipset, or in the case of recent mboards, compatible with the memory controller built into the cpu.

If you still have the ram that was installed when the system worked fine, try installing just that ram.

See response 5 in this for some info about ram compatibilty, and some places where you can find out what will work in your mboard for sure:
Correction to that:

Once you know which module ID strings work in your mboard, you can get them from anywhere you like that has ram with those ID strings.

If you have brand name ram, it is usually easy to look up whether it's ID string is in a list of compatible modules found by using your mboard or brand name system model number.
If the ram is generic, that may be difficult or impossible.

If you do a ram test, do that AFTER having tried cleaning the contacts and making sure the ram is seated properly - otherwise any errors found may be FALSE.
If the ram is incompatible with the chipset, or on more recent computers, incompatible with the memory controller built into the cpu, it will likely FAIL a ram test - that is NOT a true indication of the ram being faulty - there is probably nothing wrong with it, and it will pass the test if installed in a mboard it is compatible with.
If a ram test DOES find errors, if you have more than one module installed, try the test with one module at a time - sometimes they won't work properly when more than one is installed, but it will pass when by itself.

If you want to try a memory diagnostic utility that takes a lot less time to run a full pass than memtest86 does, this one is pretty good - Microsoft's
Windows Memory Diagnostic:
It can be toggled (press T) to do a standard or a more comprehensive set of tests - use the default 6 test one first - if it passes one pass of that, use the latter one. A few of the tests in the latter set are intentionally slower.
If you don't have a floppy drive, see the Quick Start Information at that Microsoft link for how to make a bootable CD of the Windows Memory Diagnostic (you need Windiag.iso - you don't necessarily need to use the program they mention to add it to the CD).

Report •

August 3, 2009 at 12:08:10
Hate to reply to such a lengthy message with such a small one, but I know the RAM is faulty...I had just forgotten about it before using it in this build (has displayed problems in other boards before and is the reason I still have it, actually...keep putting it in systems, finding problems, then taking it back out and tossing it with the other RAM).

Report •

August 3, 2009 at 14:58:45
I have encountered a few ram modules that will only work properly with certain chipsets, or work fine by themselves but not in combo with most other modules, but I have NEVER encounterd an actual BAD module since SIMMs first came out, at least not one that wasn't physically damaged. It's possible for a new module to be bad from the get go, or for ram modules to be damaged after they have been installed by something such as a power supply failing, or a power failiure event, or a lightning strike, but I have never encountered any.

Report •

August 3, 2009 at 16:27:54
This is RAM that has never worked properly in any computer I've tried it in (that'd be 4-5 socket 7 boards, 3 slot-1 boards, a 370 board).

That of course doesn't count the additional 370 board which blew up during the test...and since that was the first one of all, I'd guess that's why the RAM is faulty.

Report •

Ask Question