Need help with wireless printer Canon MX410

February 12, 2012 at 06:14:20
Specs: Linux x86, 2/2
Hello folks,
Maybe someone have experience or could help me with the issue with my wireless Canon MX410 printer?
I"ve bought this printer but Canon does not provide support on Linux. I downloaded and installed drivers for printing and for scanning. I figured out how to connect printer wirelessly to router and I can print now.
The problem is with scanning. When I try to scan document it does not recognize computer to connect with ... while it recognizes it when I'm printing.
Could someone try help me with it?
I have 2 laptops: one is running Ubuntu and another Fedora and both have the same issue with scanning.
Thanks in advance.

See More: Need help with wireless printer Canon MX410

Report •

February 12, 2012 at 06:27:56
Did you use the official Canon Linux drivers ??

Googling is quicker than waiting for an answer....

Report •

February 12, 2012 at 06:43:39
Yes I downloaded it from Canon website .. it's 1.70 but someone mentioned that it'll work only starting from version 2.80 ... which I don't know where to get from.

Report •

February 12, 2012 at 12:45:15
I know this isn't answering your question but wouldn't it be easier to just connect the AIW printer using a network cable.

If you are using the scan feature you must be next to the equipment.

I noticed Windows drivers are numbered 2.80 so someone probably go mixed up when telling you about newer Linux drivers.

Report •

Related Solutions

February 12, 2012 at 13:13:24
hi OtheHill,
Thanks for reply. Actually I checked myself Canon site and it states about driver level ..
.. Please note that there is only support for scanning on Linux in version 2.80 or higher of the Linux drivers - there is a seperate Scangear download for this purpose.
I also tried utility called SANE and it also didn't help me. Actually I think the only problem is to get driver 2.80 or higher and I'll set it up myself. And I think that usb connection won't make a difference for me since anyway it'll need a driver for communication.

Report •

February 12, 2012 at 19:33:44
I think you are confused, there is no newer driver version, does you Linux Distro meet the requirements ?

Fedora 13 (32 bit, 64 bit)

openSUSE 11.3 (32 bit, 64 bit)

Ubuntu 10.10 (32 bit, 64 bit)

X Window System is required for either distribution.

FYI Sane / XSane does not support the Printer.....

Googling is quicker than waiting for an answer....

Report •

February 12, 2012 at 22:33:42
The Canon USA site lists no Linux drivers for your model.

Which country did you buy the MX410 in ?

If you didn't buy it in Europe, if you got the software from the Europe web site, the software from the Canon Europe site may not work with it properly.

It's quite possible that the MX410 sold in different regions is slightly different and needs different software / drivers.
If you download that from the wrong region it may not work properly.

The most frequent reason for the software / drivers not working properly is the person who installed them didn't follow the installation directions.
Did you follow them ?
In most cases.....
- you are required to install at least part of the software BEFORE you connect the computer to the printer or multi-function device
- you DO NOT install drivers for the device when Found New Hardware pops up !
You CANCEL that and install the software by using the program on an installation CD or DVD that came with it. or you run a software installation program you downloaded from the web for the model.

The "drivers" software includes both actual drivers and associated software that must be installed properly along with the actual drivers. If you install only the drivers by using Found New Hardware, it's likely the device won't work properly

If you're sure you installed the software the right way, and you downloaded it from the right region, there are web sites all over the web that deal with getting devices to work properly with Linux that you could look on.

You could try the Linux forum on this site, but it may take a while to get the answer(s) that solve(s) your problem

Report •

February 13, 2012 at 02:52:40
Hi Jolicloid,
I run Ubuntu 11.10 32 bits and it has X windows.

Report •

February 13, 2012 at 03:08:59
Hi Tubesandwires,
That's right I downloaded both printer and scanner drivers from Europe site because USA site does not have it. Printer works fine so I expected that scanner driver will work as well which obviously was not true. I bought my printer in USA. Unfortunately. I can't find any other web site for for scanner drivers for MX410. Which web sites you referenced that could help me?
Thanks a lot.

Report •

February 13, 2012 at 08:14:20
It is VERY important that you install the software for your MX410 properly. The above info applies to Windows, but similar probably applies to any operating system - e,g, don't connect the computer to it until you have installed at least part of the software (you are often prompted to plug i the device after some of the software is installed so tat the device ca be detected properly at that point, then more software is installed).

I haven't used any version of Linux, but I have noticed that I often get "hits" when I search for info about devices on some version of Linux's help related site.

Use something appropriate to search the web with, e.g. MX410 in Linux, MX410 in Ubuntu, or MX410 in Redhat, whatever.

e,g. searched for: MX410 in Linux

(Regarding getting the Canon Europe web site's Linux drivers to work, this "hit" says the scanning features may only work when you connect to the MX410 via a wired network connection.)

Ubuntu forums
HOW TO: Install Canon Pixma mx410 wireless printer

"Unfortunately, it does not install all of the tools that the Windows version does but it will allow you to print with wireless and scan (wired only I believe) with its software scangearmp."


VueScan works with the Canon MX410 on Windows, Mac OS X and Linux.

Try Viewscan free

(Standard Edition $39.95)

Download / Install Canon Printer Driver for Ubuntu

If you have any canon printer, and met some difficulties while try to install it on ubuntu, we hope this will be your solution, before start the installation, add Canon Driver PPA repository through following command

sudo add-apt-repository ppa:michael-gruz/canon
sudo apt-get update

•Canon MX410 Ubuntu Driver - cnijfilter-mx410series

refers to:


Adding this PPA to your system
You can update your system with unsupported packages from this untrusted PPA by adding ppa:michael-gruz/canon to your system's Software Sources. (Read about installing)

Click on the Read about installing link.


Searched using: cnijfilter-mx410series

Ubuntu Portal
How to Install Canon Printer Driver for Linux Ubuntu

December 14, 2011


To install Canon printer driver for linux ubuntu you need to do add PPA below in your ubuntu system.

sudo add-apt-repository ppa:michael-gruz/canon
sudo apt-get update

Command to Install Printer Drivers Canon MX Series on ubuntu

Canon MX410 series Ubuntu Driver

sudo apt-get install cnijfilter-mx410series

I know from previous experience that many older HP multi-function printer etc. devices connected via a USB connection to a computer have no problem printing over a network connection from any computer in a local network, but their scanning features only work with the computer they are directly connected to.
I have no idea whether similar applies to your case, but that's possible.

Report •

February 13, 2012 at 19:33:14
Thanks everyone for trying to help. Eventually I was able to resolve the issue and now I can wirelessly print and scan.

Report •

February 13, 2012 at 19:36:17
Would you care to share how you resolved the issue? That information may help someone else down the road when searching this forum.

Report •

February 13, 2012 at 19:44:18
I realized a few things that prevented me to do it at the beginning. Printer driver was installed without problem from the beginning. Scanner driver failed to install and I had to modify script and comment out that block of code which was checking for rpm and arch. After successful install I had to start scan process not from the scan machine but from computer by opening program scangear.
After that everything is working fine.

Report •

February 13, 2012 at 19:58:33
Are you using the Linux version 1.70 scanner driver then?

Report •

February 13, 2012 at 20:13:21
yes, printer driver 3.50 and scanner driver 1.7

Report •

February 13, 2012 at 20:19:53
OK then, good luck.

Report •

February 14, 2012 at 06:44:38
Wew're glad to hear you solved your problem

"Scanner driver failed to install ...."

That MAY have been caused by this...

NOTE that sometimes the resident module(s) of anti-malware programs - a part that runs all the time scanning for suspicious activity - will interfere with the proper installation of third party software, the software will not install properly, and you may get no indication of that at all while installing the software.
To avoid that possibilty, you should always DISABLE the resident module(s) of anti-malware programs, BEFORE you install third party software (software other than most Microsoft Updates, etc., that did not come with Windows ), especially when it's a major or complicated software package.
E.g. if you are using the free or paid version of AVG, you should disable the Resident Shield in AVG's 's settings in Windows (in AVG 2012 that's done under the title AntiVirus). In Norton (Symantec) products, there may be several things you need to disable, or set so they don't load for a specific short amount of time.
If you don't know how to do that, tell us which anti-malware software you are using.
When you are sure the software has installed correctly, re-enable the resident module(s).

Report •

Ask Question