NEC ND-3550A Wont play Game DVDs

Dell / Dimention 2300
April 27, 2009 at 15:37:02
Specs: Windows XP
I just installed the NEC ND-3550A DVD/CD-r/rw and updated the driver to v1.06. It will play dvd's, cd's. i havent tried to burn any dnd's or cd's yet beacause i ran across this problem. It will not play recognise or bring up anyhitng when i put in a DVD software game(wow the original, Painkiller overdose. etc.) could ANYONE please help, im getting to the point where im about to trash this thanks

See More: NEC ND-3550A Wont play Game DVDs

Report •

April 27, 2009 at 15:43:50
What driver did you update? Sounds like you may have updated the BIOS?

You need third party software in order to burn DVD media. WinXP can't do that natively. You may have gotten a copy of Nero or Roxio with your burner drive.

After inserting a DVD disk go to My Computer> double click on the DVD drive and select Explore. Then look for a setup file.

Also, you may need to install some codecs. Look at the link below for a good codec pack.

Report •

April 27, 2009 at 15:45:38
Does the game disk show up in the drive in My Computer?

Report •

April 27, 2009 at 16:11:00
well i just burned a cd via windows media and it burned but the cd wont play. The game disk wont show up at all. the drive lights up like its supposed to and the quits. the drive doesnt spin up and the driver i use was from NEC corp.
the driver was for the drive not the BIOS.
Sorry im retarded. I forgot to mention that its in a dimension 2300, i pulled the drive from a dimension 3000

Report •

Related Solutions

April 27, 2009 at 16:40:23
a dimension 2400, is just a simple IDE connection, no driver should have been needed. it would have been interesting to see if it functioned correctly, before you installed a "driver".
"i pulled the drive from a dimension 3000", are you sure it was functioning correctly before you pulled it??


Report •

April 27, 2009 at 16:43:03
YEs the drive was fully funtional in every aspect on the dimension 3000. I updated the driver because of this problem and it hasnt fixed it..of and its a Dimension 2300.

OtheHill, i did what you said about explore and there is noting there... what does that mean???

Report •

April 27, 2009 at 17:59:19
That means the drive is not reading. I would try another data cable if you are sure the drive is OK.

Report •

April 27, 2009 at 19:20:55
But it plays everything but DVD game discs. i would think that if the data cable was messed up that it would do anything...and it will burn cds but they wont play. could it be a hardware conflict it being a drive from a dimension 3000

Report •

April 27, 2009 at 20:16:12
You don't think that different wires of the 40 data wires might be used to read and write? Try another cable instead of trying to rationalize.

Report •

April 27, 2009 at 21:23:31
umm.. just so you know i wasnt bein a smart a** i was acually trying to ask a ligitamate question. so before you jump to conclusions the data cable was fine when i took i out and when i put the original cd drive in guess what it works fine... nothing wrong with the cable..... rationalize that
So if their is someone here that can help instead of filling up this post with mindless nonsence i would be very gratefull

Report •

April 28, 2009 at 02:15:52

check youve not bent any pins on both ends mobo and dvd, & have a read here no drivers required
is the drive set to cable select? set it to slave.

i use nec alot of DVDRW's, but not seen that fault before, have you got some previous games loaded which might have used

Respect our Authoritah!. lol

Report •

April 28, 2009 at 03:36:25
I know you were asking a legitimate question. However, your logic is faulty.

Each time you remove and/or install an IDE data cable you risk damaging it. The wires are fine and the connector simply presses into the coating. Looking at the cable is of no use.

I don't know if the cable is damaged or not but that is a simple fix and therefore should be tried first.

While on the subject of the cable are you using an 80 wire cable? You can tell the 80 wire by the connectors. Master drive end connector is Black. The Slave drive connector is Grey. The motherboard connector is usually blue but can be other colors, but not black.

Are the game disks originals or burned copies?

A burner may appear to burn a disk but not actually be successful.

It sounds to me like the drive is NOT fully functional. Most combination drives (CDR/DVDR) have TWO lasers which both operate at different intensities. High for burning, lower for reading. Any number of things can go wrong. It is common to have on laser or the other become defective. The lenses over the lasers can get dirty from the burning process. The laser tries to compensate by using more power. This may work for a while but the read function may not be strong enough to see through the dirty lense.

There are lense cleaning kits available. New drives are cheap enough too. Look at the link below for some.

Part of the way down there is a Lite on RETAIL with free shipping. That drive comes with a

Report •

April 28, 2009 at 07:38:37
heres a thought , have you installed daemon tools?

Report •

April 28, 2009 at 08:31:59
I have not installed Daemon tools. Not sure what that is. and OtheHill All 3 data cables i have in the case have black connectors on either end, also all three of them connect seperatly to the Mother board, i am not sure what pin they are but the ones to the HD and the DVD drive are bigger than that of the one that is on the floppy i belive is a 32 pin? and the others im pretty sure their 40 pin. now the one that goes to the Hardrive is a black connector but has a blue tag on the end of it. I checked all the ends and their are no bent pins. also the back of the drive where you change from mast/slve/cbl the selector if your looking at it directly is all the way to the right
....i do have some games already on the computer and they do require the disk to play but the disk are not a DVD software game, just cd rom. And all the games i have tried are original games no backed or ripped

Report •

Ask Question