My Samsung S2 Portable 1TB external HDD wants to format

January 25, 2014 at 12:40:06
Specs: Windows 7 64
Hello :)

My hard drive (Samsung S2 Portable, 1 TB) seems to have some personal issues, that needs to be dealt with. There's two problems with it; 1) I get the "You must format to use"-error, and it seems like it really wants to point out this error. When I plug it into my desktop computer it just keeps on giving the message over and over again if I ignore it. 2) It's not even visible on my computer. It tends to be visible for a couple of minutes, and then dissapear, with the errors beginning to stack up.

When I plug this hard drive into my laptop, I still get the message, but I am able to copy to and from the hard drive.

The hard drive is a couple of years old, but it has never suffered from any falls or been damaged afaik. It receives its power from the computer, and does not have its own power plug.

I've tried a lot of fixing programs and tutorials, but those guides doesn't cover both issues.

Anything will help! :)

See More: My Samsung S2 Portable 1TB external HDD wants to format

Report •

January 25, 2014 at 16:23:02
There are two possible problems with a portable hard drive (external), first, the drive is bad, and second, the case/board is bad. If your external drive is not under warranty and you can figure out how to open the case without destroying it (many can), open it and remove the drive. Plug it into your desktop computer as a second internal drive (computer off, then restart), nd see if it is recognized. If it is, back up the contents ans consider getting a suitable external case for it. If it does not, look in Disk Manager to see what it shows there and also run factory test utility or Seatools (Seagate) for the quick test and see what it tells you about the drive.
Post back results.

You have to be a little bit crazy to keep you from going insane.

Report •

January 27, 2014 at 06:46:25
Improperly removing an external hard drive can corrupt the file system on the partition.

Look for the drive in Window Disk Management. If the file type is reported as RAW then that is the problem.

I don't think this is your problem but it is a step in the process. Post back what you find in Disk Management.

Report •

January 27, 2014 at 09:58:45
Okay, so I tried to open it, but it turns out it will break the case if I try. I think I would need some other tools.

Weird thing though, I just plugged it into my laptop, where it seemed to function decently - it told me it needed to scan and fix it. Anyways, I entered the disk without doing so, and copied all the files onto my laptop instead for backup.

Then I plugged it into my desktop computer, where it tells me the same thing, and I let it scan and fix. So now, it's scanning and fixing. During this, the Scan and Fix message comes up again.

I see no trace of the previous messages I had; that it needs to format to continue.

This is what Disk Management tells me:

Just after this, I looked on My Computer, but the harddisk disappeared. And yet Disk Management tells me the exact same thing: Healthy and Active.

Also, the Repair and Fix thing has frozen, and hasn't moved at all (stopped at 91 files processed).

Thanks guys!

Edit: And now I can see the drive again in My Computer :/

message edited by fnhs90

Report •

Related Solutions

January 27, 2014 at 10:05:10
OK, then there MIGHT be an issue with the drive itself. I don't think Samsung has a hard drive fitness test. I believe that the one from Seagate or Hitachi may tell you if there is a problem with it.

First let Windows check the drive. See the link below to learn how.

Report •

February 4, 2014 at 11:39:14
Hi guys

I backed up all the data, and let the disk do what it really wanted to - to format. Seems to have solved the problems. Guess it just needed a quick reminder that life isn't that bad after all.

Thanks for your inputs though, you seem like a nice bunch of people :)

Report •

February 6, 2014 at 03:17:53
Had you posted the information I asked for in #2 you may not have had to format the drive and lose your data.

Report •

February 6, 2014 at 09:24:43
@OtheHill He did eventually access the drive temporarily, and was able to retrieve his files apparently. Read Post #3 again.

My guess is that either the drive itself is beginning to degrade or some undue exposure to magnetism might have messed with the file system a bit. I don't know how big the drive is, but I would recommend getting a new one if this error begins to pop up again in the future.

Not everyone can decipher Klingon script...
chay' ta' SoH tlhe' vam Doch Daq

Report •

February 6, 2014 at 13:59:48

Thanks for that heads up. I misread #5 above.

Report •

Ask Question