My power supply doesn't work/do anything!

June 11, 2013 at 14:41:58
Specs: Windows 7 , i5 3.1 / 4 gb
I just built my first PC and my power supply doesn't turn on. No light, no sound, no fan. It just doesn't do anything. I've tried all the plugs in my house and nothing happens! I don't know what to do, please help!

PS I haven't even booted my computer yet! I have Windows 7 home premium but haven't installed it yet!


See More: My power supply doesnt work/do anything!

Report •


#1
June 11, 2013 at 15:11:26
If you are trying the PSU outside the computer it will not do anything, unless you bridge a couple of pins. See this:
http://dodji.seketeli.com/downloads...

Always pop back and let us know the outcome - thanks


Report •

#2
June 11, 2013 at 15:11:27
Is it brand new? Did it ever work?

Report •

#3
June 11, 2013 at 16:07:21
Take Derek's advise of indeed you are starting it with PSU outside. If your PSU is brand new, there should just be a connection problem. have you tried disconnecting and everything and reconnecting them back again? There maybe just some loose connection in there.

Report •

Related Solutions

#4
June 11, 2013 at 19:13:10
Temporarily jumper the green wire to any black wire then plug in the power supply. If the fan spins up, it's most likely OK. Do NOT run the PSU for any length of time like this:

http://cache.gawkerassets.com/asset...


Report •

#5
June 11, 2013 at 19:44:08
It may seem obvious to most, but not all power supplies have them. Did you look on the power supply for a manual on/off switch (usually a rocker switch).

You have to be a little bit crazy to keep you from going insane.


Report •

Ask Question