My hard drive stopped working.

February 21, 2010 at 07:01:59
Specs: windows xp sp1, 512MB
I'm trying to fix my hard drive.

One day, I plugged in this 20GB ide drive(i use for data storage only) that I know was working, and now it doesn't work. When I boot up, during POST it takes longer than normal, and when I look in explorer, it's there, but "view properties" takes forever and it says "drive is not formatted". Actually, the first time when it happened, I was able to browse the directories but not actually read files. Now it just says "not formatted", xp thinks the drive is blank.

PLEASE HELP. I need to access what's on the drive.

Why it's not working, here some clues-

1. I *did* drop the hard drive from like 3 inches in the air, but didn't land too hard, and it landed on carpet. The next day, I tried connecting it and it went "click click click". Tried a few more times, and eventually it worked, like once. Then the problems started.

2.The original OS that partitioned the drive was win 2000. so it uses win2000 ntfs. but xp is backwards compatible, right?

3.My current OS is VERY screwed up. Crashes all the time. Long story short, that drive has screwed up partition tables caused from a bad resize attempt. It is a 70gig ide drive. I do plan to re-install win xp, before I try any solutions to fix my broken 20gig drive. Because there is a chance, that simply hooking it up to such a screwed up win xp installation is what caused the problem to begin with.

Ok, I have heard if a drive spins up at all, I can install "data rescue pc 3", and it can recover bad ntfs volumes. Question, is there a free solution?

And is this fairly safe? I wish there was a way to put the drive in "read-only" mode so I know I'm not harming it any further.

-Thanks for your time.

See More: My hard drive stopped working.

Report •

February 21, 2010 at 08:45:43
try running chkdsk

Report •

February 21, 2010 at 09:59:57
I'd remove the drive and use a USB adapter to connect it to the computer.

Dropping the drive, and the subsequent clicks usually means the drive is bad or getting there.

Do you have backups of the data?


Report •

February 21, 2010 at 10:21:39
Thanks Jennifer. I have heard other ppl talk about recovering info off damaged drives, using a usb adapter. I guess there is an advantage to doing that, as opposed to just hooking up the ide cables like normal? My local computer shop might sell a usb thing.

I dont have any backups. And I can't use norton ghost on a drive that is being seen as blank. I've never had to take a drive to a repair shop, but it's not looking good at this point.

@ the guy who recommended chkdsk.

After, oh I don't know, about 50 RESTARTS, chkdsk still pulls this crap about every 4th restart. Lately it's getting worse.

NOW KEEP IN MIND THAT DRIVE^^ IS NOT THE DRIVE I'M TRYING TO FIX. That is my OS drive. I'm only showing you because chkdsk, the standard proprietary tool for this exact ntfs problem, does not fix the problem. Actually I know it's the partitions that are to blame but why doesn't chkdsk let me DO something about it? Instead it "fixes" things, and next time I boot if finds hundreds more errors. So silly.

Report •

Related Solutions

February 21, 2010 at 10:38:28
Also, I don't mean to say chkdsk can't fix my 20gig drive. Maybe it can. But I just don't have confidence in it. Actually pretty afraid to let it try.

Report •

Report •

February 21, 2010 at 11:37:12
You could also try some other file recovery programs to save your data. Then try a repartition/format.

PC Inspector (freeware)

Also free - Thanks to 'Emma Lee'
Glary undelete

Zero assumption Recovery
The demo is limited
It will only recover 'up to' four folders per run
But you can make multiple runs


Ontrack's 'Easy Recovery'

File Scavenger

Report •

February 21, 2010 at 11:45:23
Thanks. I'm installing win2000 on a spare hd as we speak. Windows install always takes a long time. Gonna have a nap and then tackle this stuff when I wake up.

Thanks for all the links and help guys!

Report •

February 24, 2010 at 16:02:55
Good news is, I made lots of progress, and I figured out what was wrong. (incorrect cluster size when I first formatted the disk)

Now all I need to do, is fix that problem and I'm done. I will ask in a separate thread, as it's a separate issue.

Report •

Ask Question