My display on my Toshiba Satelite L55 doesn't work @ boot up

January 6, 2016 at 22:17:44
Specs: Windows 10, intel i5 /8gigs ram
I have a Toshiba Satelite L55 B5294 laptop.
When I first turn it on the screen (this is a replaced screen because the original screen was cracked due to mishandling) the screen is white with some vertical lines and then the some colors seem to shift from left to right. After a good bit of time (say 20min or longer) the normal screen appears after fading light to normal several times.If I get to a normal screen it stays good until I shut down and restart. Also if I hook an external monitor to the laptop things work as they should from the start.Was wondering if it's the screen,video cable? This LED screen has the inverter built into it so could it be the problem? Any direction on what to check would be appreciated.

See More: My display on my Toshiba Satelite L55 doesnt work @ boot up

Report •


#1
January 7, 2016 at 06:08:56
As you say, it could be screen or cable. Another possibility is one of the connectors working loose at either end.

Watch the screen as you slowly close the lid. If there are any drastic changes then it could be cable wear at the point where the screen hinges.

Always pop back and let us know the outcome - thanks


Report •

#2
January 7, 2016 at 09:25:39
Hi and thank you for your response. Closing the lid I see no changes. I tore down the laptop and checked the video cable on both ends. Pins look correct so while powered on I twisted and bent the cable trying to cause a flicker or something but everything stayed the same. I hate to do it but since this screen was a replacement screen I do believe I'm going to get another screen and see if that corrects the problem.Thanks aain for your response. George

Report •

#3
January 7, 2016 at 10:05:47
OK, thanks for the update and good luck with it.

Always pop back and let us know the outcome - thanks


Report •

Related Solutions

#4
January 8, 2016 at 23:28:31
I ordered an LED screen it should be here by Wednesday will post results after that. George

Report •

#5
January 13, 2016 at 23:11:21
The new led screen fixed the problem. Thanks for your help. George

Report •

#6
January 14, 2016 at 08:48:55
Glad to hear it and thanks for popping back to let us know.

message edited by Derek


Report •

Ask Question