My BIOS is driving me crazy, please help!

September 12, 2010 at 05:29:25
Specs: Windows 7, Intel P4 @ 3GHz + 2GB RAM
Hi everyone,

I've been trying to fix my problem for the last 3 days but nothing happened :(
I'll explain in details with screen shots to make it crystal clear.

My PC:
- MB (Mother Board) is Gigabyte Intel 945 [SATA 0, SATA 1, SATA 2, SATA 3 + IDE CH.1, IDE CH.2 and IDE CH.3]
- CPU INTEL P4 @3.00GHz
- 2GB of RAM
- SATA HDD - 250GB
- IDE HDD - Maxtor 40GB
- IDE DVD Driver - LG

Problem is:
Please check the screen shots and I'll explain later:

Screen 1) - Please ignore the part that talks about Windows and Ubuntu.

Screen 2)

From the above two screen shots, you might be able to figure out what's going on with my PC. Simply, my BIOS detect my Maxtor IDE 40G HDD as SCSI while I don't have anything related to SCSI at all. All what I have is 3 HDDs (2 SATA + 1 IDE) and that's all.

I've tried everything you could imagine for 3 days (cables, settings, etc) but nothing happened.

In screen 1, you could see that My SATA HDD1 is on IDE CH0 Master (which is SATA but not sure why it says IDE) and my SATA HDD2 is on IDE CH0 Slave.
Neither screen 1 nor 2 shows where my IDE Maxtor 40GB HDD is connected but it's connected to IDE CH2 on my MB.

The main problem (as shown in screen2) is my BIOS detect my IDE Maxtor 40GB HDD as SCSI while it is NOT SCSI at all. I did everything on the BIOS but failed. The BIOS keeps reading it as SCIS (screen2).

When I tried to switch between the DVD driver (connected to IDE CH1 on the MB) and my IDE Maxtor 40GB HDD (which is connected to IDE CH2 on the MB), I lost the DVD Driver completely but BIOS is able to detect and read the Maxtor 40GB HDD as an IDE device not as SCSI.

I have no clue what's going on and why's that? I suspect that something is wrong with my BIOS settings.

I know someone would say connect the Maxtor IDE HDD to IDE CH1 - Master and connect the DVD driver to IDE CH1 as Slave but that can't be done for one good reason: there is NO ROOM in my case to install 3 HDDs and I have to pull out the DVD driver and put it outside the case so that I can connect it with the Maxtor IDE HDD on the same cable (Master and Slave).
Obviously, I can't keep my DVD Drive outside the case with my HDD. It will look so funny and unsafe to do that for many reasons.

Now, is there anyone who could help me with this?
I've been searching the internet for many days but couldn't find similar scenario of mine :(

Thanks a lot.

See More: My BIOS is driving me crazy, please help!

September 12, 2010 at 06:23:45
Do you have the latest version of the bios installed? I understand that it's normal for an ide drive to show as scsi. Does it work after the installation?

Report •

September 12, 2010 at 06:35:20
I guess I have the latest version of BIOS.
Well, this is the first time it happens to me. Never had this problem before!

Yes, I can access all the drive except in the case I explained above when I install the DVD Driver to IDE CH2 and install the IDE HDD to IDE CH1. Only in that case, I can't access the DVD drive nor the BIOS can detect it. Except that case, I can access all the drivers.

Report •

September 12, 2010 at 07:07:04
If the IDE drives are on separate channels/cables, each of them should be Master. Make sure you're resetting the jumpers correctly on the rear of the drives.

Report •

Related Solutions

September 12, 2010 at 07:27:03
Some BIOSes do have a convoluted way of configuring drives. I have seen similar problems before.

The SATA drives being configured as IDE is OK. The IDE configured as SCSI is not.

If the only issue is how to connect the drives then I can suggest solutions.

What do you mean there is no room for three drives? Even small cases have at least 4 total drive bays. How many of each 5 1/4 & 3 1/2 bays do you have?

Worst case is you may need to get a 5 1/4 to 3 1/2 adapter for one of the hard drives.

Report •

September 12, 2010 at 07:40:32
By the way, I disconnected all the other HDDs (SATA) and I kept my IDE HDD and the DVD Drive. Guess what? the BIOS yet again was detecting my Maxtor IDE HDD as SCSI instead of IDE. I thought if I would unplug the SATA drivers that could help but it did not help at all. And yes, I tried different settings, jumper, etc but no way. SCSI is the only type that BIOS gives to my IDE drive as long as it's connected to IDE CH 2 or IDE CH 3.

The only way to fix that is to connect it to IDE CH 1 and as I wrote before, I can't do that because both my DVD Drive and IDE HDD must be outside the PC' case.

Report •

September 12, 2010 at 07:49:55
"The only way to fix that is to connect it to IDE CH 1 and as I wrote before, I can't do that because both my DVD Drive and IDE HDD must be outside the PC' case"

That's reeediculous. You either need to get a 5.25" to 3.5" bay adapter as suggested by OtH, or get a different IDE cable (round) that has a longer "spread" between the plugs.

Report •

September 12, 2010 at 07:50:21
Hi OtheHill,

I was reading some other threads and I found some cases almost like mine except they couldn't access their IDE HDD. In my case, I can access it except my BIOS detects that HDD as SCSI instead of IDE and it happens ONLY when my IDE HDD is connected to IDE CH 2 or IDE CH 3. When I connected my IDE HDD to IDE CH 1, everything will be fine except, again, I have no room for that HDD :(

The stupid case I have has ONLY 2 trays for HDD and 4 for DVD/CD Drives. I did my best to find a place to put that HDD but trust me, there isn't any :(

"Worst case is you may need to get a 5 1/4 to 3 1/2 adapter for one of the hard drives. " << do you mean SATA cable with 1 IDE end so that I could use my IDE HDD as SATA?

And, do you say that there's no way I could solve this issue? I know I tried many ways but I was wondering if there's something else I haven't tried yet?!

Thank you!

Report •

September 12, 2010 at 07:54:28
@ jam

I would have done that if I knew there's such cable. As I said, I could keep my HDD and my DVD outside the case but that's so silly if you ask me and I don't like it.

I've never seen a longer IDE cable. Anyway, I'll check if there's any but I doubt. Sometimes, you can only find particular parts in some countries.

Thanks anyway!

Report •

September 12, 2010 at 07:58:05
I don't think you''re grasping OtH's suggestion for the bay adapter. I assume your case has more than one place (bay) where an optical drive can be installed? With an adapter, you simply install the HDD in one of the unused optical bays, that way you *should* be able to use a single IDE cable to connect both drives to IDE-0. They generally cost about $'s an example:

Report •

September 12, 2010 at 07:59:08
Guys, even though I'll buy that cable (that if I'll find it here), my IDE HDD will remain outside the case/tower.

I could use that IDE HDD as an external HDD and connected to a USB but I won't be able to install Linux Ubuntu (that's what I'm planning to do - also have dual boot with Windows 7) nor any other OS.

If there's another way to fix my problem, I'll be very happy to read it from anyone!

Report •

September 12, 2010 at 08:03:19
Why do you need the 40GB HDD in the 1st place? It's sure it's old & slow, plus it obviously doesn't have much storage space. As for Linux, just use the built-in WUBI installer & install it as an application within Windows. No extra HDD or partitioning is necessary. It's just like installing any other program (game, anti-virus, etc). And if you want to remove it, you simply go to Control Panel > Add or Remove. WUBI takes all the complexity out of it.

"If there's another way to fix my problem, I'll be very happy to read it from anyone!"

Response # 9.

Report •

September 12, 2010 at 08:11:15

Your last post overlapped the last one by jam.

Look at the link he provided and get a pair of adapters. They fasten to the 3 1/2 drive and then install into a 5 1/4 bay.

Install the DVD drive in the second from the bottom 5 1/4 bay and then with the adapters install the IDE in the lowest 5 1/4 bay. Then use Master jumper settings on the hard drive and slave settings on the DVD drive. That way the cable doesn't have to go up and then down. If you are using CS jumper settings the Master is the drive connected to the end of the cable. When using Master/Slave you can connect to either connector.

You shouldn't need the round cable. Also, as jam pointed out, you don't really need the 40GB drive. However, I have explained how to use it and have all your drives inside the case.

Report •

September 12, 2010 at 08:11:30
If we're talking about such equipment and if I could find it here, that would fix the problem for sure. As I wrote earlier, I have 4 places (bays) for Optical Drives, only one is equipped with DVD Drive and other 3 are empty. I'll try to search for it in the market.

Thanks for the example, it was good :)

As for why do I need that drive? well, that's another story. My main SATA HDD is dying and it could stop at any moment. Above all and let's assume there's nothing wrong with my main SATA HDD, almost everyone recommended NOT to use Wubi.
I've been on Ubuntu's forum for days and you can check this out:

Report •

September 12, 2010 at 08:19:18
OtheHill and jam,

Thanks a lot, guys :) I really appreciate that. I'm going to search for these tools in the market and hope I could find them. I'll get a cable just in case and these adapters as well.

If I couldn't find anything in the market (worst case scenario), then I'm going to remove my dying SATA HDD and install my IDE instead OR (I doubt that) I might buy new SATA HDD.

Once more, thank you guys :)

Report •

September 12, 2010 at 08:49:55
I have one machine that is strictly Linux & two that are dual boots with XP. Obviously the "pure" Linux machine has a full install with the required Linux partitioning & file system formating...the others are installed within Windows.

The built-in WUBI installer is different that installing the WUBI app separately, THEN installing Linux. If you simply boot into Windows then pop in the Ubuntu disc & wait for the menu to pop up, it's VERY easy to do. Just click on "Install Inside Windows", choose where you want to put it & how much HDD space you want to allot to it, set up a name/password & let it install. That's all there is to it. The dual boot menu is setup automatically. And as I said...if for some reason you want to remove it, all you need to do is use "Add or Remove".

Report •

September 12, 2010 at 14:39:16
Wherever you are in the world you should be able to find someone selling those. If you have a local shop they probably have some lying around. I have three or four sets myself. There is a second style that is one piece. Serves the same purpose.

Report •

September 13, 2010 at 14:40:36
Okay, this is really too much ... either I lost all my mind or there's something wrong in Ubuntu?
You know what guys? I'll forget whatever I've learned about Computers from personal experience and will start from ZERO as this is totally new to me. With Windows, I've never had such problems whatsoever!!!!!

There you go!

Everything was extra perfect last night and this morning. Afternoon, I decided to return everything to its place (those who have been following up with this thread, will understand what I mean) which means I had to return my Maxtor IDE 40GB HDD to its place and same for the DVD Drive as both were outside my tower/case. Why is that? because simply my main SATA WD HDD is DEAD :'( that's it, it won't work anymore (there was tick-tick sounds months ago, I took it off and put it somewhere, I decided to check it recently and it was working fine until I had to turn my PC on and off for 100 times for the last 3 days so it passed away. Tick-tick sounds came back without stop and I've tried my best to get it work but nothing happened).

What happened is, I tried to check whether Ubuntu will boot up if I connected my Maxtor 40G IDE HDD (this is where Ubuntu installed) to another IDE channel [ I have 4 SATA Channels - SATA 0, SATA 1, SATA 2 and SATA 3] + [ I have 3 IDE Channels - IDE Channel 1, IDE Channel 2 and IDE Channel 3] and the MB is Gigabyte.

Yesterday, when I installed Ubuntu and it worked, my Maxtor 40G IDE HDD was connected to IDE Channel 1. Today, I connected it to IDE Channel 2 and yes, same hassle, BIOS detected it as SCSI ( so I turned my PC off and installed my Maxtor 40G IDE HDD to IDE Channel 1 where BIOS detect it as IDE and everything should be fine. So far so good.

I turned my PC on, couldn't boot from Ubuntu AT ALL. I've tired everything you can imagine but absolutely nothing. I even unplugged every other device (my 2nd SATA HDD and DVD Drive) so that my Maxtor 40G IDE HDD will be the only HDD/device installed on my MB but still, NOTHING.
Above all, when I tired to put my USB-Stick to install Ubuntu again, I couldn't do that. ALL what I get is either lots of codes/info and there's something start with "init" like that (init .....) but I forgot the word (sorry) OR Ubuntu logo with the dark purple background with the 5 flashing dots. I left my PC for 1 hour doing that (flashing dots) and still no response.

Now, I've tried again but the only way I managed to boot from my USB-Stick and access the Internet and write here is:

1- I unplugged ALL the devices from the MB
2- Plugged an external HDD to USB port
3- Booted from the USB-Stick (the same one I used to install Ubuntu yesterday)
4- And here I'm able to access the forum BUT without my Maxtor 40G IDE HDD.

I hope it's clear so far.

Summary: my Maxtor 40G IDE HDD has Ubuntu just installed yesterday and I was able to login this morning, afternoon, NOTHING at all. The worst part that I don't ever understand is I CAN NOT even install Ubuntu again using my USB-Stick.
I got the Menu where it says:
1- Run Ubuntu from this USB
2- Install Ubuntu
3- Boot from the first HD

But when I choose all the above options, same dark purple background with Ubuntu's logo and the 5 amazing flashing dots!

By the way, I can not install Windows nor Ubuntu on my 2nd SATA HDD because simply it's all what I got now with ALL my data. I can't take the risk of losing more stuff.
My External HD is 20GB. It's an internal HD and I put it in a HardBox so that I can use it as an external HD.

Is there any chance that I might get my Maxtor 40G IDE HDD working again with Ubuntu or what shall I do now?


Report •

September 13, 2010 at 15:12:04
I didn't start new thread/post because this is a follow up for my main issue!

Report •

September 14, 2010 at 00:41:51
Well, is there any one who could possibly help me out? I didn't start new thread because I'm back to square 1 with worse issues!

Thank you :)

Report •

September 14, 2010 at 04:44:25
If you are starting over then start by explaining what you have connected NOW and what is happening. Sounds like you have a SATA hard drive that is going bad.

Is the ticking your hear coming from the SATA drive? does it tick when out of the case? If not, then you may be installing screws that are too long, or the case may be distorting the drive. I have seen chap cases that you couldn't even install all four mounting screws on a drive. Either of those conditions may have already damaged the drive.

Report •

September 14, 2010 at 06:09:18
I dont think you have the latest bios version becuas there is write "copyright 2000-2004"
2004 was 6 years ago
try updating!

Report •

September 14, 2010 at 14:25:26
My SATA HDD is dead, that's all :(
The ticking is from the HDD itself. Of course I can tell the difference if it wasn't connected probably with screws.

As for my problem explained above, I managed to fix it after some tries. I had Ubuntu on my IDE HDD which wasn't booting at all. Thus, I tired to use my XP's CD to boot and it works. I formatted my HDD and start from scratch.

Now, I got both XP and Ubuntu and so far so good!

I'll keep you updated in case something will go wrong or I might start new thread.

As for the BIOS, I'll check and I'll update for sure in case I need to :)

Thanks a lot!

Report •

Ask Question