Mouse and keyboard not working after startup

August 3, 2010 at 18:41:56
Specs: Windows 7 64-bit
I was trying to restore my iTouch and neither iTunes or my computer would recognize the device. So I decided to restart the computer. Clicked restart in the start menu but when the computer restarted my USB drives were not working at all. Keyboard, mouse, flash drives don't work. Also, the ethernet cable slot was no longer working. I shut down by holding down the power button, tried safe mode because I can use the keyboard before I've completed startup. Also, the computer auto logs in to the main account, so I can get past the user screen. Safe mode didn't work. I tried other stuff but don't really remember.
I had Input Director installed but the ethernet cable slot that it works through doesn't work so I still can't access the messed up computer..
Any ideas?

See More: Mouse and keyboard not working after startup

Report •

August 3, 2010 at 19:26:59
How do you know the ethernet isn't working if you have no means of input?

Do you remember what you did to try restoring iTouch?

Do you have a full version Windows 7 64bit DVD?

Are your KB and mouse wireless?

Report •

August 3, 2010 at 19:42:50
Theres an icon in the tray showing No connection.

I opened iTunes, downloaded an older ipod firmware, used the shift-click thing in iTunes when restoring but there was an error. A bunch of sites gave a way to fix that error number, which was:
1. Open in notepad: C:\Windows\System32\drivers\etc\hosts
2. Add "" at the end.
Then my computer stopped recognizing the iTouch.

Yes, I think I have that.

No they're wired. Also, the computer has no PS/2 ports so I can't try that type of mouse/KB.

Report •

August 3, 2010 at 19:51:00
Well, first try to boot into Windows 7 safe mode by tapping F6 at start up. If you can get into safe mode then try restoring to a time preceding the problem.

If that isn't possible then you can perform a repair installation by booting to the Windows 7 DVD and following the prompts to repair Windows.

Report •

Related Solutions

August 3, 2010 at 21:53:24
Found the problem, I uninstalled libusb incorrectly or something.
Any way to uninstall this without my keyboard lol?

Report •

August 3, 2010 at 22:27:51
F8 during startup and system restore worked perfectly.
New lesson: avoid libusb

Report •

Ask Question