Solved Motherboard won't load from any attached I/O device

August 3, 2012 at 23:26:03
Specs: Linux x86_64 (Ubuntu 12.04 LTS 64-bit), AMD Phenom II X4 955, 3.2GHz; 8GB RAM
Motherboard won't load from any attached I/O device.
After more than a year of uneventful operation, my home-built tower system's motherboard has suddenly stopped loading from any and all attached devices. I run Ubuntu Linux 12.04 LTS OS on my boot HDD, with Windows XP Pro SP3 on a second HDD running (when I use it) as a VM under Oracle's VirtualBox.

The symptom is that when I power up the system, it goes through POST apparently successfully, checks devices and displays the GRUB menu. I select loading Ubuntu 12.04 LTS and after a brief delay the following message displays:
run-init: /sbin/init: I/O error
Kernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: run-init Not tainted 3.2.0-27-generic #43 Ubuntu
Call Trace:
followed by 7 lines of trace information. Then the system halts, with the caps lock and scroll lock LEDs on my keyboard flashing in sync. If I select Windows from the GRUB menu instead, the screen about Windows not having started successfully displays. When I select "Start Windows Normally", the Windows splash screen displays briefly, then the system restarts and loops back through POST, ending on the GRUB OS selection menu again.

I've tried a number of things to identify what's going wrong, but none has helped so far -- the result is always the same. They are:
1. Reseat cables; 2. Replace IDE signal cable to first optical drive; 3. Rub possible corrosion from video card and DRAM contacts; 4. Disconnect SATA cables from HDDs and SATA optical drive, singly and in various combinations, re-booting each time and attempting to load Linux LiveCD or Linux rescue CD from either of the optical drives, or Windows from one HDD, or Linux from the other; 5. Change boot device orders in BIOS: 6. Clear CMOS: 7. Reset BIOS to default settings; 8. Disable all but first core in processor.

I'd sure appreciate some help fixing this problem -- I'm about out of ideas.


ASUS motherboard - M4A88TD-V EVO/USB3
AMD processor - Phenom II X4 955
NorthBridge chipset
RAM - 2 x 4GB Corsair DRAM, 1333MHz
Maxtor 250GB HDD (Linux)
Western Digital 250 GB HDD (Windows)
ASUS DVD-RW optical drive (SATA connected)
Sony CD-ROM optical drive (IDE connected)
ASUS Extreme N6600 GeForce video card
IBM KB (PS/2 connected)
MS optical mouse (USB)
HP LP2275w display
HP 5550 printer (USB)

See More: Motherboard wont load from any attached I/O device

Report •

August 4, 2012 at 05:47:15
✔ Best Answer
Try disconnecting the HDDs, then see if you can boot from & run a LiveCD.

You have sort of an odd configuration. Considering the "new-ness" of the board & CPU, why the IDE CD drive & outdated video card? What are your power supply specs?

Report •

August 5, 2012 at 15:20:41
Thanks for the response. I had tried disconnecting the HDDs before, but followed your suggestion and tried again. Tried to boot an Ubuntu 11.04 64-bit LiveCD, an Ubuntu 12.04 LTS 64-bit LiveCD, and Linux SystemRescue CD. None would boot, although the two LiveCDs boot fine on my laptop.

Then I thought of removing an unused and unconnected IDE controller card that's been sitting plugged into my motherboard. Wow! Progress! I now can boot from the optical drives (but not from my HDD). Time to go looking for what's the matter with the Linux HDD...!

Report •

August 21, 2012 at 19:33:23
Well, once I was able to boot from the Ubuntu LiveCD it didn't take long to determine that my Linux HDD was bad - MANY bad blocks. Fortunately, I was able to recover all the data that had been modified since my last backup. I replaced the HDD, reloaded Linux and my Virtualbox Win XP file and all is well.

Thanks for the prompt reply, rllder.

Report •
Related Solutions

Ask Question