Monitor doesn't turn on, cpu doesn't shut off

July 19, 2012 at 08:24:29
Specs: H
OK so I took apart my CPU for dusting cause it was really dusty, put everything back together, and there was a long beeping sound and the monitor power was on but it remained blank, i opened up the CPU, removed the ram and placed it back, and that solved the beeping sound, but now the monitor still wont show anything and the power knob on the CPU turns the CPU on but wont shut it off . HELP!

See More: Monitor doesnt turn on, cpu doesnt shut off

Report •

July 19, 2012 at 09:30:09
A tower or system isn't a CPU. CPU is a small chip installed on a board socket.
How did u remove the dust(compressed air can or vacuum cleaner?).
Remove the all RAM and start the system, if u don't hear beeps the board is gone.

You know the real meaning of peace only if you have been through the war.

Report •

July 19, 2012 at 09:47:58
As kuwese said, a CPU is a chip that fits in a socket on the motherboard. What you did was open the computer case.

"put everything back together"

Does that mean you actually removed parts for cleaning? if so, what did you remove? Did you unplug the power cord 1st? Did you unclip the heatsink/fan from the CPU? If you did, & didn't apply fresh thermal compound, that is most likely the problem. However, if you used a vacuum rather than compressed air, there may have been a static discharge from the hose that damaged something.

Report •

July 19, 2012 at 10:37:05
ok so because i am a dumb noob, i removed everything, yes i unplug the power cord first, and yes i unclip the heat sink form the cpu :( but i didnt have any thermal compound :( does that mean its fried ? :( and @ kuwese i did as you told and it did beep.. does that mean that my motherboard is working and i wont have to replace it? my word i feel like a bottom ohh and i use a small brush like of of those swiffer thingies

Report •

Related Solutions

July 19, 2012 at 12:13:47
Once the bond between the heatsink & CPU is broken, the compound MUST be replaced. Reusing the old compound or reassembly without using any compound will cause the system to non-boot. You didn't list your specs so find your CPU on this list & follow the instructions:

You don't have to use Arctic Silver though. The "heat sink grease" from Radio Shack works just as well & is generally cheaper:

Report •

July 19, 2012 at 14:43:24
ok thank you a million!!!!!! i'll try it and keep u posted on if it worked

Report •

Ask Question