Mobo doesn't recognize SATA

July 18, 2010 at 11:48:29
Specs: Windows 7 64-Bit
I put my system together a week ago and everything was running beautifully. Then on one boot, I attached an external hd during the boot. I got a "Disk Boot Failure, Insert System Disk And Press Enter" message. I thought I messed up the MBR, so I tried putting my Windows 7 disk in and restarting. Nothing happens on reboot. It wasn't reading my disk drive (also SATA). I was able to connect an IDE DVD-ROM and it read the Win7 disk.

I checked power connections and cables and everything seems fine. I think this is either an errant BIOS setting or perhaps the Mobo needs to be RMA. Here are some things I've tried, but obviously weren't successful.

Updated SATA drivers and Flashed BIOS for Mobo.
Tried various settings in BIOS for SATA (AHCI, etc)
Switched Power cables / SATA Cables
Reset CMOS
Unseated and reseated RAM

Here's my System

G.SKILL Ripjaws Series 4GB DDR3 1600
i5-750 2.66 ghz (not OC'ed)
GIGABYTE HD 5830 Video Card

Thanks in advance!

See More: Mobo doesnt recognize SATA

Report •

July 18, 2010 at 13:14:46
You may have had the boot order set to boot to the USB drive before the internal drive.

Did you remove the external drive and try again?

AHCI setting should work with Windows 7.

If you actually started a re-installation you may have pooched the original installation.

Report •

July 18, 2010 at 14:08:37
First thing I tried was to remove the external drive and reboot.

I've tried changing the boot order, but to no avail. The problem is that it doesn't recognize any SATA devices, so selecting these devices in the boot sequence has no effect.

I didn't perform any re-install procedures as the system doesn't recognize the hard drive to install. I only used the Win7 disk to attempt a repair, but it didn't recognize any previous OS installations (probably due to the aforementioned problem).

Report •

July 18, 2010 at 14:39:53
Do you have AHCI enabled in the BIOS screens?

Report •

Related Solutions

July 18, 2010 at 14:43:01
G.SKILL Ripjaws Series 4GB DDR3 1600"

G Skil does not list any modules that are compatible with your model.

"Flashed BIOS for Mobo."

Flashing the bios IS NOT A FIX - ALL !!
It's the riskiest thing you can do to a computer !
99 % of the time, doing that will NOT cure a problem you were NOT previously having with the bios version you had and the same CPU and ram installed !

If you flashed with a different bios version, flashing the bios usually does NOT load the contents of the Cmos for the changed bios version automatically !
To be sure the Cmos contents - what you see in the bios Setup screens - match the present bios version, you MUST either....
- load bios Defaults in the Bios Setup, Save settings
- or - clear the cmos by moving the jumper for that on the mboard, moving it back, while the AC power is disconnected to the computer.
or - remove the AC power to the computer, remove the cmos's mboard battery, re-install it, with the + on it where you can see it when it's installed.

For the two latter methods, you willl get a "Cmos Checksum Error" or similar message when you boot the next time. You must go into the bios and set at least the Date and Time, Save bios settings.

All three of those methods will load bios defaults that will clear any wrong settings you may have made and allow the hard drive to be correctly detected, assuming all drive connections are set to Auto detect drives by default, which is usually the situation .

If you have more than one hard drive, and at least one has no operating system on it, depending on which SATA header the bootable drive is connected to, or which header an IDE hard drive is connected to, and all drives are connected to the mboard, the default bios Boot Order or similar settings may NOT find a bootable hard drive partition - the bios will NOT check to see if partitions on other hard drives are bootable. In that case, you need to go into the bios and find the list of hard drives, that's often near the Boot Order or similar settings, or, less often, there is more than one hard drive listed in those Boot Order or similar settings, and make the hard drive that has the bootable partition that you want to boot from the first one in the list, Save bios settings.

If you're booting from a bootable drive connected to a SATA controller card that's installed in a mboard slot, the bios Boot Order or similar settings must be set to boot from SCSI before any hard drive.

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

The same thing applies for the SATA power connection.

If you were fiddling with connections,
- did you remove the AC power to the computer at ALL times while doing that ?
- did you remember to plug the molex or SATA power connector to the SATA drive back into the drive, as well as the SATA data cable ?

Check the current readings for what is supposed to be +3.3v, +5v, and +12v in the bios Setup. Those should be within 10% of the nominal values - if any are not, you must replace the power supply.

What capacity does your power supply have ?

"GIGABYTE HD 5830 Video Card"

System Requirements -
- 500 Watt or greater power supply with 2x 75W 6-pin PCI Express® power connector recommended (600 Watt and four 6-pin connectors for ATI CrossFireX™ Technology in dual mode)

Your power supply must have at least the minimum capacity required to support a system with the graphics card you are using installed, or the max graphics card you might install in the future.
(Onboard video - video built into the mboard - IS NOT A CARD ! )
If that info is not in the ad for the video card, you can go to the video card maker's web site and look up the specs for the model - often under system requirements - the minimum PS wattage, and, more important, the minimum amperage the PS must supply at 12v is stated. If you don't find that, any card with the same video chipset including any letters after the model number has very similar minimum PS requirements. Some power supplies have two or more +12v ratings - in that case, add those ratings to determine the total +12v current capacity.

If you're a gamer...
In most if not all cases, the max capacity rating of the PS is an intermittent rating. It's recommended that you do not load your PS to any more that 80% of that rating if you are going to be using something that puts a constant load on it, such as playing a recent game for hours on end. In that case, you multiply the min capacity stated for the system with the particular video chipset on the card by 1.25 to find the min. capacity of the PS you should get.

If you need to get a PS with more capacity, you can usually replace it with any decent standard sized standard ATX PS.

Standard (PS/2) power supply size - 86mm high, 150mm wide, 140mm deep, or 3 3/8" h x 5 7/8" w x 5 1/2" d , or very close to that, though the depth can be more or less for some PSs.

Don't buy an el-cheapo PS.
See response 3 in this:

Report •

July 18, 2010 at 15:20:00
Thanks for the OtheHill and TubesAndWires. I took precautions during swapping etc. I flashed the BIOS as a last resort as I know it's risky. Not sure why G.Skill doesn't list this mobo, but I know others have used this combo of mobo/ram.

After some further work, it doesn't appear to be the mobo at all. Looks like it might be a bad HD (or perhaps not?). Tried switching the cable around and it allows me to boot from the optical drive.

When the computer loads with AHCI, it says I have two devices connected (optical and HD), but under controller bus, it only lists my optical drive, but it doesn't detect my HD nor does it have an identifier.

I don't have another system around to pop this HD in to test, but is there a way I can check to see if the HD is bad and that it's not just a setting/driver/BIOS causing it not to detect it correctly?

Report •

July 18, 2010 at 15:26:14
"but under controller bus, it only lists my optical drive, but it doesn't detect my HD nor does it have an identifier".

Explain where you are culling this information from.

AHCI is a way to connect SATA drives without the need to supply a dedicated SATA controller driver. How the BIOS identifies the hard drive is not important.

If you boot to your Windows 7 DVD and elect to perform a repair it should find your old installation.

Report •

July 18, 2010 at 15:29:26
This is after the screen to go into BIOS and just before the Loading OS screen.

The screen basically lists your peripheral drives. I can boot to the Windows 7 DVD, but it still doesn't recognize my SATA HD which I now believe might be bad or settings aren't configured correctly.

Report •

July 18, 2010 at 15:32:00
See the notes I added to the above about your power supply capacity.

Are you SURE you remembered to connect a power connector the the SATA hard drive ?

Load bios defaults, Save settings, in the bios Setup to clear any bios settings you have have set wrongly.

If the optical drive is SATA, the same SATA cable that allows you to boot from a disk in the optical drive should allow you to boot from the SATA drive, however, sata data cables don't normally cause you problems unless the end connector won't "latch" in the socket you plug it into.

If you forgot to unplug or switch off the AC to the computer even once while plugging into or unplugging the power from the SATA hard drive, that MAY have fried the SATA drive's board.

USB external hard drives require the full max 500ma from the USB port(s) they connect to, and not all USB ports will work with them in any case.

If the USB cable you are using with the External hard drive did not come with the drive, if it is not definitely rated for USB 2.0 use, it may not be good enough.

Troubleshooting USB device problems including for flash drives, external drives, memory cards.
See Response 1:

Report •

July 18, 2010 at 15:40:00
Did you clear the CMOS by chance? If so, you may need to enable the SATA port you are connected to. Also, check the SATA data cable to verify the connections on both ends are solid. Sharp bends in a SATA data cable can cause data transmission failure. If you have any tight folds in the cable straighten them out or replace the cable.

Was the external drive you connected an eSATA or USB or what?

Report •

July 18, 2010 at 15:41:11
I have a Corsair 650W PS, so I believe that works. I tried connecting the SATA connector (as well as the power cord) that was working for the optical to the HD, but that didn't work. Made sure all connections latched correctly.

I'll try resetting the CMOS and loading BIOS defaults and report back. Thanks!

The external HD was USB 2.0. USB devices appear to be working fine. The External HD I used had it's own dedicated PS (not sure if that makes a difference with my current problem).

Report •

July 18, 2010 at 16:11:43
Reset the CMOS successfully (BIOS shows date as Jan 01, 2010 00:0X:XX).

Won't recognize SATA HD.

IDE Channel Master 1 - Optical Drive
IDE Channel Slave 1 - None
IDE Channel Master 2 - None (This is where HD should be)
IDE Channel Slave 2 - None

+5V and +12V are: 5.134V and +12.175V respectively.

Report •

July 18, 2010 at 16:20:58
Note that I forgot to mention one thing.
Some USB and firewire headers on mboards are identical.

Some mboards have both headers for two usb ports on (a) header(s), and for (a) single firewire port(s) on a header, that have identical headers with identical pin positions and numbers of pins.
E.g. On Asus mboards, 9 pins on a two row 5 position in each row header, one pin is missing in a corner.

The headers for the two purposes are different colors, and/or the markings on the mboard around the headers are different colors.

If you mistakenly plug a female wiring connector from the case ports, or from a plate in a slot space with one or more ports on it, for a pair of USB ports onto the firewire header, or for a firewire port to the header for two USB ports, nothing happens when there is nothing connected to the mis-wired port, but when you DO plug something into the mis-wired port, whatever you have plugged into the miswired port is probably instantly damaged, the circuits for that header are probably damaged in a very short time, and there may also be other mboard circuit damage.

If you have that situation, you are usually WARNED about that possibility in the mboard model's manual.

If you did connect the USB connected external hard drive to a mis-wired firewire header, or visa versa, the external enclosures circuits and/or the hard drive inside of it, are probably damaged - the external drive will not work anymore connected to any computer, and at least the circuits connected to the mis-wired header are probably damaged

"I'll try resetting the CMOS and loading BIOS defaults and report back"

You don't need to do both. Loading bios defaults is fine.

All three of those methods will load bios defaults that will clear any wrong settings you may have made and allow the hard drive to be correctly detected, assuming all drive connections are set to Auto detect drives by default, which is usually the situation .

"The External HD I used had it's own dedicated PS (not sure if that makes a difference with my current problem)."

In that case the drive or drives inside the external enclosure are 3.5" (desktop sized). That power supply that came with it must be plugged into the external enclosure, AND the USB cable to the computer must be able to get 500ma from the USB port it plugs into, AND you may need to plug into a physical USB port built into to the mboard.

Rarely, not all the ports on the back of a desktop case may be able to supply 500ma each.

If you have a desktop computer, Note that I answered a Topic on this site recently where a guy had an external drive, which does require the full 500ma, connected to a port on the back of a desktop case - it would not work properly when a webcam was in the port next to it, but it worked fine when the webcam was unplugged. Ports on the back of a desktop case often have two ports connected to the same USB controller module that are ports one above the other - you could try connecting the cable to one of those and leaving the other un-used.

Report •

July 18, 2010 at 16:36:14
I'm not having any issues with the USB ports or USB devices. I'm only having problems with the SATA HD. I've done a lot of searching in the last half day and it appears this problem isn't unique.

If my HDD is indeed dead. Is there anyway I can recover my data files. Unfortunately, I don't have a backup of the data on the HDD as I was in the process of offloading these to an external as backup.

Report •

July 18, 2010 at 16:44:53
Is your motherboard Ver 1.0 or 2.0? I am not sure what the differences are but ver 1.0 only has 4 SATA connectors.

The manual insructs you to connect the 90 degree end of the supplied data cables to the drive with the straight end to the board. Look at pg 24 for details.

When clearing the CMOS the default settings for the SATA ports is the IDE mode.

I suggest you disable the Gigabyte logo so you can see the POST screens at start up.

I suggest connecting the hard drive to SATA2_0 and the optical drive to SATA2_2. Are you selecting the auto option for all SATA ports?

With the logo disabled watch the POST screens. You will see an option to enable AHCI instead of IDE mode.

Report •

July 18, 2010 at 16:58:07
Motherboard is 2.0. Mine has 8 SATA connectors.

I've tried switching the SATA placements. 90 degree SATA connector is connected to the back end of the drive and straight end to the motherboard.

The HDD was originally in SATA2_0 and the optical in SATA2_1. When I started to have problems, I switched them around a few times to see if anything worked or to see if I perhaps had a bad SATA cord/port.

I've disabled the logo. I've selected AHCI, but I think I just have a bad hard drive as it doesn't appear to be recognized no matter what I do. Usually buy WD HDD, but took a chance on this Samsung due to all of the high ratings. I can't even tell if the HDD is spinning up at the start since it is supposed to be extremely quiet by design.

Report •

Ask Question