Mixing RAID & non RAID, Windows7 will not see Drive

February 14, 2012 at 05:48:49
Specs: Windows 7 64, i72600k/16GB
Hi tech folks,

I have a RAID 1 setup on my Asus P8P67 Pro mobo with a pair of SATA III WD drives (in Win7 64bit).

I started to run out of HDD space and so simply wanted to add another (SATA II) drive for data
in non RAID mode.

I hooked up the new drive but, although the CTRL+i facility saw it as a RAID 'non member'
- of zero bites - windows could not see it, so I could not format etc.

The manual says if RAID is enabled then all channels are RAID and if you un-RAID, all data will be lost, so I have been reluctant to mess with the drive in AHCI mode. But I also hear you can have a single non RAID drive in this existing RAID setup - just don't include it - but how?

I tried a different approach and enabled Marvel (as AHCI) thinking that this might solve the problem. Windows 7 installed the Marvel drivers and told me that the drive was ready to use, but still it was not showing up, so I disabled it.

My query is how to get this drive in ANY mode to be recognised in the OS?

There must be something obvious that I am missing (otherwise I have a duff drive?)

I'm guessing knowledge of this mobo is significant here, rather than WIn7?

Thanks in advance

See More: Mixing RAID & non RAID, Windows7 will not see Drive

Report •


#1
February 14, 2012 at 06:33:13
Why do you feel you need RAID at all & how big are the drives you're working with?

Report •

#2
February 14, 2012 at 07:21:05
Well, in hindsight, I may come to feel that RAID might have been a mistake - I don't know - I wanted some security on an unknown overclocked setup - but that hardly addresses my original question though, does it. The drives are all 1TB.

cheers


Report •

#3
February 14, 2012 at 10:49:12
RAID just unnecessarily complicates things. Speaking of which, why didn't you put your RAID drives on separate controllers for better performance?

"Windows 7 installed the Marvel drivers and told me that the drive was ready to use, but still it was not showing up, so I disabled it"

Did you partition & format the drive? Windows won't see it until you do.


Report •

Related Solutions

#4
February 14, 2012 at 11:31:47
Format!! Well, THAT could be the very obvious thing I haven't done - Because I don't want to break the RAID array in case I lose all data (as it warns - and I don't even know if just changing the SATA configuration in BIOS away from RAID will effectively break the array - or whether Ctlr+i is where that mistake happens)....I haven't dared fiddle and have been unable to check the disk on its own at all on any channel. I don't know what status it is in but I hoped I could use the WD tool from in Windows, but that wasn't seeing it either.

*Update*

I'm relatively new to this RAID and SATA lark and it's just been making me very wary.
Anyway, I bit the bullet and reactivated Marvell (I don't know if this is the best route)
and tried using Disk Management - and this time was met with a 'please initialise
drive' message. However, it failed due to an "device i/o error". I tried my WD tool and what freaks me here is that it shows an IDE (disk1) drive of 3913987GB "not available" - sometimes it is 0GB and not available.
I don't have any IDE controllers so I am a bit cautious of this discrepancy. However, it also shows a zero byte IDE drive2 "not available". (Surely these should read disk 0 & 1 not 1&2?)

On the non Marvel setup, Windows still refuses to see it at all But the RAID screen sees it as non RAID.

So, all in all, it is a bit daunting and problematic to do anything without further
exploration. I was expecting to hook up and go.


cheers


Report •

#5
February 19, 2012 at 05:49:18
Ha, Well for anyone who is remotely interested...

I took the drive it to be checked locally and they said there was nothing wrong with it. They got this ok message JUST like I had got when I used only the disk tool.
So I said ok, format it for me then. After which they said it couldn't be done as there was some disk access problem and it had randomly stopped spinning.

I guess this proves it was duff all along. So no replies could have helped.
thanks.


Report •

Ask Question