Missing drivers for ethernet and sound

March 9, 2010 at 12:24:29
Specs: Windows XP
I just recently had to do a clean install of windows xp on this machine due to a crash. This is a home built computer, but I had to use a Dell restore disk. Since doing that The computer wont recognize my ethernet controller which is integrated into the motherboard. The motherboard is via tech, and the ethernet thingy (excuse the tech language) says s tech p29-101-11k9. What can I do to get this back? if you need more info I'm sure I can find it.

See More: Missing drivers for ethernet and sound

Report •

#1
March 9, 2010 at 14:23:08
I'm surprised the Dell disc worked at all with something other than the original Dell pc. Go to the motherboard manufacturers web site find your model and download the drivers you need.
http://www.via.com.tw/en/index.jsp

Report •

#2
March 9, 2010 at 14:55:51
"if you need more info I'm sure I can find it"

The make/model of the board would be nice. VIA makes chipsets, not motherboards.


Report •

#3
March 9, 2010 at 20:04:25
I got it!!! Thanks for the help anyway. I went to the motherboard manuf. and downloaded the drivers for the chipsets, ethernet, and sound. I was also surprised the restore disk worked, but i think my only problem will be that i cant activate the windows. So I will have to do a clean install every month,but I will take what i can get. If you have any suggestions on solving that It would be much appreciated.

Report •

Related Solutions

#4
March 10, 2010 at 15:15:19
"If you have any suggestions on solving that It would be much appreciated"

Do a google search for "make XP 100% Genuine"


Report •

Ask Question