memory controller failing, or failed?

Asrock / Fatal1ty z97x killer
January 14, 2015 at 07:01:22
Specs: Windows 7 Ultimate, 16GB
Having problems with my Tyan S2696.
It will only show 8gb of memory and acts funny when 7 or 8 sticks are used.
seems ok when only 6 or less sticks are used but only shows up as 8gb.

using aida64 it shows the bus as 128bits when more than 4 sticks used but 256bit when 4 sticks are used in the black slots.
But even though it shows the bus change it still only shows 8gb.

going to test sticks in pairs or maybe in quad with memtest asap.

Can it be a failing/failed memory controller?

Have a few more configs to try out........

See More: memory controller failing, or failed?

Report •

January 14, 2015 at 09:00:17
Was all the RAM previously configured. If not, the issue may be due to limitations with the motherboard. Could be density, number of banks, etc.

Report •

January 14, 2015 at 10:07:56
Hey oth,nice to know your still around :)

Tyan had 16gb,all banks populated and was running fine.
Then one morning wouldn't boot or at least nothing came on screen.
Removed all the ram and tested with one stick at a time in the 1st slot.
Everything seemed fine with all 8 sticks one at a time.
Re-introduced 1 stick at a time and all seemed fine until the last slot.
Been working ok for a few days with the top slot empty.

Acting funny again now.
On bootup it seems it does not recognize one or more HD's occasionally but once inside windows they are showing.

If HD (sata) detection is connected to ram detection or something could explain it all?

Report •

January 14, 2015 at 11:45:30

Report •

Related Solutions

January 14, 2015 at 12:59:41
Did you run Memtest86 from a boot disk?

Report •

January 14, 2015 at 13:24:34
Hey riider,getting like the old days :D

Pretty sure the ram is the correct type.
It's been running ok for over a year.

I have 8gb in 4 sticks memtesting at the moment,just like in the pic.

Going to barebones it,test the other 8gb overnight.

Yep,memtest from bootdisk.
3 clean passes so far for 1st 8gb
All ram has passed using the 4 black slots.
It would not boot in the white slots,powers on but no video.

Barebones testing today......

message edited by indigian

Report •

January 15, 2015 at 04:07:07
16gb installed,showing as 16gb in windows.
Although it didn't show as 14gb when 14gb was installed,showed as 12gb.

Barebones is HD4870 with 1 sata SSD drive installed,seems quite stable for now.
Initial findings point to a dodgy sata port?

If I plug a HD (tried a few) into sata port 2 it hangs at boot up screen.
Although plugging the sata DVD drive into sata port 2 boot up is fine.

Can this happen to sata ports,sata port faulty to HD but ok to a DVD drive?

I'll keep the setup and see how it goes I suppose for now and if problems just remove the DVD and see how that goes.

message edited by indigian

Report •

January 15, 2015 at 20:00:34
Some SATA ports may not support a boot drive.

Is the hard drive the same speed as the SATA port?

Report •

January 16, 2015 at 00:28:20
Using port 1 as boot with a SSD.
All other ports are used as storage.

Maybe there's a data problem with the port?
HD not working but DVD does.

And we're back to square1,not booting.
took all the drives out,except SSD boot drive,still no boot.
will take out the SSD next and try that.

Corrupted bios maybe?

It now fires up but then stops after a short while.
No hard drives or DVD's in but all 16gb is in.

message edited by indigian

Report •

January 19, 2015 at 01:19:37
Must be something wrong with one or more ram slots.
Back to using 8gb in the black slots and working ok again so far.

Report •

Ask Question