Medion Akoya S2118 MicroSD Port

May 3, 2017 at 04:00:59
Specs: Windows 10
Hello,

I have a Medion Akoya S2218 laptop that was bought for me from Aldi (UK)

A few months ago a windows update file corrupted my OS and I was left with a brick. Not even the Win10 Adanced reset options would work.

Through LOTS of trial and error I have eventually managed to get Windows 10 (x86) running on the laptop but lots of things still do not work, namely;

- MicroSD Port
- HDMI Port
- Headphone/Microphone combi port

I tried the drivers supplied on Medions support page with no luck, I have also tried the drivers via the Chipset package and that still does not work.

I managed to get the sound working using a Lenovo sound bridge driver, and the display is running okay, but I really need, if nothing else, the MicroSD port to work.

From what I can gather, its something to do with the SD Host Controller drivers, and I have attempted uninstall/reinstall using both drivers from Medion and third party ones found elsewhere and nothing will work.

Does anyone out there have the same laptop of which they could create a system image file that I could do a fresh install with to fix the problem and have all the problems I am currently experiencing?

If not, would someone be able to have a look in there device manager and work out which drivers they are using and hopefully I will be able to source them online and get it working?

Any help on this issue would be greatly appreciated as I have given up hope now.

Laptop is;
Medion Akoya S2218
Model No. MD99910
MSN. 30021011

Thank you.


See More: Medion Akoya S2118 MicroSD Port

Report •

#1
May 3, 2017 at 11:00:57
You need to go to the support area for for your Medion...

This is a starting point:

http://tinyurl.com/qctjczt

Select your exact model form the product list (right colum in the box); then work your way around the assorted options, which includes downloads of drivers, and other software...

Driver selection is here; this one seems to be the one for your Medion:

http://tinyurl.com/n2zsqjb

Likely you need to re-instal the chipset drivers... (top of the list).

Be careful to get the drivers for your generation of Medion. I note there are several - each with what appears to version numbers (in brackets) Although regardless of which you select from the several versions of your model, it takes you to the same driver set...

The website has "everything" you need - manual included...

I advise you tp download "all" software and driers etc; and save to a DVD - ideally two sets... If possible an external hard drive too. That way you have it all for for future use if needs-be (and in-case Medion either take them down, or even worse they disappear...). Also make your own recovery set of dvd too; even if Medion provide a download as well.

As Aldi has both UK and Europea stores - where are you?

Incidentally Medion were often a version of an Acer system (in effect rebadged); often a half a generation (if not full generation) back from a current Acer item.. They have been generally OK within their limited specs.

message edited by trvlr


Report •

#2
May 4, 2017 at 01:38:31
Hi Trvlr,

Thank you for you response, however, as I mentioned in my original post, I have already tried to uninstall/reinstall all the drivers using the Medion Chipset (specifically for my Medion model and msn number) and yet they still do not work.at all.

I have completely uninstalled everything associated with SD Host Controller and reinstalled all via the chipset and still the items simply will not work. I have also checked in Device Manager to ensure that there is nothing showing as not installed correctly.

Strange thing is, if there is no MicroSD card inserted - when I look in My Computer or Disk Management the drive does not appear at all. Once I have inserted a MicroSD card, My Computer (via Explorer) shows a physical drive, but is reluctant to see that there is anything in there (keeps saying insert disk). When I try to load Disk Management whilst a MicroSD card is inserted then it simply refuses to load the Disk Management window at all (continually says "Connecting to Virtual Disk Management") but will not show any disks, not even the HDD (Flash Drive) of the laptop, but when I take the SD card out, the Disk Management works perfectly.

PLEASE NOTE: THIS IS NOT AN ISSUE WITH THE SD CARD ITSELF. This is has been tried with numerous capacity and manufactures cards, ALL of which have been tested in other devices and work seamlessly.

It is worth mentioning however, that when I first got the laptop, I am 99% certain that it was an x64 based operating system. Yet the laptop outright refused to accept a x64 installation of windows? So now when I look in my computer properties it says "32 Bit Operating System, 64 Bit Processor" could this be the reason why I am having such problems using the Chipset Package and other drivers to get my ports to work?

The reason, I believe, I couldn't get x64 to work (tried at least 15 different windows installations all in x64) is something to do with the UEFI boot system implemented on this laptop? It just wont accept a x64 boot for some reason, yet an x86 goes on straight away with no issues? (I did days and days of research learning about specific files that need to go in specific directories for a x64 UEFI boot and still it would not work!) Perhaps this is the reason why, and I will never get it working until I can get a x64 operating system, and perhaps it's also necessary for me to obtain a fresh windows installation repair disk from Medion itself, somehow...

I would also assume that if the Chipset Package and other Drivers were specifically for a x64 system then it wouldn't allow me to install the drivers to a x86 OS?

Thank you.


Report •

#3
May 4, 2017 at 05:57:08
How did you manage to get the 32bit version installed and working again? (presuming that it was 64bit previously - which I suspect it wasn't)?

Have you tried the built-in restore options as per page 33 onwards in the manual -

http://download2.medion.com/downloa...

And page 34 seems to discuss UEFI..?

Incidentally does everything else work OK apart from the microSD card reader (and the HD port)?

And re' 64bit processor; it can run both 32 and 64bit versions of software...

message edited by trvlr


Report •

Related Solutions

#4
May 5, 2017 at 02:51:00
@trvlr
I used a portable Ubuntu distribution to get into the laptop and remove all traces of the OS along with the revocery partitions to enable me to start again by using Windows Media Creator tool and a genuine copy of Windows 10 Pro x86.

Unfortunately, whatever happened to my laptop, it corrupted all partitions, so I was not able to access the recovery partition, I was not able to boot the computer in any capacity in order to use the Win 10 restore/recovery procedures. Now I am not on a Medion specific system image, just a genuine generic version of Win10 x86, therefore restoring now will only re-install the basic functionality that I currently have.

As for the laptop itself;

- Graphics are being run by a generic Intel HD Graphics driver I managed to source online.
- Sound is being run currently by Intel SSD Audio and a Lenovo Sound Bridge driver (only way it works)
- Bluetooth being run by default Windows Drivers but doesn't actually let me connect to anything.
- WiFi is being ran by default Windows Drivers.
- MicroSD Port isn't recognised as a physical drive until something is plugged in, then refuses to open.
- Microphone/Headphone combi port doesn't work at all
- HDMI Port doesn't work at all
- Touchpad mouse is being ran by default Windows Drivers

Please note I do have the chipset package and the other 3 driver packages specifically for my model of Laptop from Medion's Support page but none of the drivers seem to work when installed, most of the time even if I can force it to install the one I want, I restart my computer and it simply fails to work at all. At least using a combination of different drivers sourced myself I have managed to get it working up to this point.

Also, the laptop is still in immaculate condition and has never been dropped banged in anyway so I cannot see it being a hardware related issue when it was something that happened overnight during the Windows Update that it all went wrong?

Most of the problems I can live with, but the MicroSD port is pretty much essential given the miniscule size of the on board HDD (32gb flash drive)

Am I correct in thinking that it is something to do with the SD Host Controller? I can provide an image of my Device Manager so you can see what I have?

Thank you.


Report •

#5
May 5, 2017 at 04:52:37
As I've linked to this post in your subsequent, perhaps stay with your later/subsequent one from now on?

Out of interest, does usb work OK otherwise? If so then a workaround would ben an external usb multi-format card reader?

If you login here again again perhaps reply to my suggestion n your subsequent/later post?


Report •

Ask Question