maxtor one touch 4 external HDD not powering up

August 5, 2014 at 10:21:12
Specs: Windows 7
maxtor onetouch 4 not powering up

Working ok yesterday was left on overnight but this morning it is not working

Have tried replacing power lead but made no difference

See More: maxtor one touch 4 external HDD not powering up

Report •

August 5, 2014 at 13:12:26
Try it in another computer as this will tell you whether or not it is due to the external itself.

Always pop back and let us know the outcome - thanks

Report •

August 5, 2014 at 16:41:38
not sure how that will work as it has a separate power lead and usb lead

Report •

August 5, 2014 at 22:25:29
It's an external drive--designed to be moved between computers. I don't think the connections prevent that.

You say you tried replacing the power lead but it made no difference. Does that mean you connected a different COMPATIBLE ac adapter?

Don't forget to preorder your Hatch green chili for this fall. Many vendors ship world-wide.

Report •

Related Solutions

August 5, 2014 at 23:19:34
yes it is compatible

When I have tried again this morning with the original lead there is a pulsating light at the base of the unit but the lap top is not picking up the drive

Report •

Ask Question