Solved Linksys E1000 forwards 443 to the wrong port

Linksys Re1000 ieee 802.11n draft 300 mb...
February 15, 2012 at 13:23:46
Specs: 2.1.02, NA
I have a Linksys E1000 Router (version 2.1.02).
I have the following port forwards setup:

Outside 3389 | Inside 3389 | (any) | Destination: serverIP
Outside 443 | Inside 443 | (any) | Destination: serverIP
Outside 10245 | Inside 443 | (any) | Destination: serverIP

I tried them both when I set them up (form an outside location) and they worked fine.

For the past few days, 443 hasn't worked externally. It works fine internally. Below is a copy/paste of the log

Source IP Address Destination Port Number 3389 10245 3389 10245

It looks like the router is trying to forward 443 to 10245.

I have residential service and not business (COX Communications). I've heard that 443 is blocked at their level (even though it still does work for many people I know).

My question is this, if my ISP is blocking it, shouldn't it never hit my router? If it still does (they change https traffic to port 10245) how do I get around this?

If they aren't blocking it, does that mean it's hitting my router at 443 and it's changing it to 10245?

Any possible insight on this would help greatly.

I am running a SBS2011 server and simply trying to make Remote Workplace function.

- Nick

See More: Linksys E1000 forwards 443 to the wrong port

Report •

February 15, 2012 at 19:09:46
Outside 443 | Inside 443 | (any) | Destination: serverIP

Why did you put that in?

A Pit Bull is like a gun you can pet. And there is no safety on it.

Report •

February 15, 2012 at 19:46:27
I was under the impression I had to tell my router where to send this traffic, is this not true?

Report •

February 15, 2012 at 20:16:46
✔ Best Answer
Your router should work fine with default settings regarding what you're messing with.
You only need to modify those settings when some program can't get through a port it needs with the router's default settings, and usually the program maker's web site has the Help info about what you need to do in that case.

If you have a standalone high speed modem and a standalone router connected to it, you can find out whether the router is the cause of your problem by connecting your computer directly to the modem temporarily.

Report •

Related Solutions

February 16, 2012 at 07:06:15
Thank you both for your replies. As indicated by Jefro, I removed the forwarding of port 443 from the router. I am getting the same error

I have changed the bindings for my default site in IIS to port 444. I opened port 444 on my windows firewall. I set port forwarding of 444 on my router. Now, I can navigate to both OWA and my Remote Workplace using port 444. I'm having issues getting further, because the RD Gateway server isn't accepting my connections (another issue entirely).

I am still leaning towards my router or ISP as the cause. Either the ISP is changing 443 to 10245 (because I have residential service) or my router is forwarding it incorrectly.

I'll contact my ISP and see what their advice is.

Report •

February 16, 2012 at 15:24:06
"Either the ISP is changing 443 to 10245 (because I have residential service) or my router is forwarding it incorrectly."

See the last paragraph in response 3.

If you DO have a standalone router
- and if you still have the problem when you remove it, the problem isn't caused by the router .
- if the problem is gone when you remove the router, it's caused by some router setting, but I advise you that you should try setting it to default settings first.

You usually don't need to mess with default firewall settngs in Windows either, if you're using it's built in firewall.

On the oher hand, I know next to nothing about server op systems.

Report •

February 17, 2012 at 07:05:27
Unfortunately, the setup I have doesn't permit me to remove the router. I have a vm host machine that my servers are on, and all of them have static IP addresses (with the sbs controlling dns).

I tried spoofing a different MAC on my router and I polled a new IP address from my ISP, it still is showing that port as incoming.

While default settings work great if you have home machines that need internet. It doesn't work when you have one machine hosting a website. The router MUST know where to send those incoming requests. That's the purpose of Port Forwarding (NAT translations).

I'm still not sure where the issue lies. I'll see if I can get further information via Microsoft and report my findings.

Report •

February 17, 2012 at 07:50:18
This is resolved. I re-ran all the 'wizards' on the server. It reconfigured the router (using upnp) and everything is working currently. I am not sure what was causing the disconnect. I guess they have made sbs2011 wizard heavy.

Thanks again for brainstorming ideas with me.

This can be closed.

Report •

February 17, 2012 at 11:44:03
We're glad to here you solved your problem.

Thanks for the thanks - we don't always get that.

Thanks for tying up this thread.

Report •

Ask Question