LED fails to show activity

Abit Kv7 amd motherboard
February 2, 2010 at 00:21:26
Specs: Windows XP, AMD Athlon / 1gig
Upon reassembling my computer the hard drive light no matter how I put it on the correct pins won't light up except during various times during the bootup where the BIOS seeks it but after windows starts the LED doesn't even blink for a split second.

I'm pretty sure it's not a polarity issue as I've tried both ways. Also a goofy DVD drive I have flashes the HD LED when the drawer opens and closes (probably due to a defect) but the HD LED was not working before hooking that up.

I'm still from time to time working on it to find out if it's something simple but I'm sure I've exhausted all possibilities and I'd hate to swap back to another motherboard (I have a few) as it risk's damage to the CPU if I do.

Any ideas?

See More: LED fails to show activity

Report •

February 2, 2010 at 02:58:20
If it blinks during start-up there's nothing wrong with hdd, just make sure to enable S.M.A.R.T, and if there is hd led problem, it has nothing to with motherboard but it has something to do with pc case(bad bulb,or bad wire). Try to do something heavy and see if the hd led blinks.

Report •

February 2, 2010 at 13:27:55
I've done that just today and still the same pattern. It does flash for activity with SATA drive activity but not the IDE drive. I forgot about SMART and will look into that as probable cause! Thanks.

Report •

February 2, 2010 at 13:38:30
Ok, I've checked for SMART (enable / disable) in the BIOS on the Abit KV7 and there isn't an entry so I'm going to have to do some deep research, it's possible the board doesn't support it.

Report •

Related Solutions

February 2, 2010 at 15:04:49
I'm assuming the IDE drive is connected to a mboard IDE header.
If it's connected to a card in a slot, the led on the case may not blink or light up for it. The card often has pins to connect an led to.

It also could a problem with the data cable.........

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittant, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

Sometimes the led gets pulled out of it's mounting in the case front when you've been fiddling inside the case, especially if you removed the case front - the led may no longer be where it's supposed to be. That's happened to me several times.

Report •

February 2, 2010 at 16:53:02
On the LED. That's what happened before it 'failed'. I do really bet it's the IDE cable! Bingo! We'll see, thanks!

Report •

February 2, 2010 at 20:44:02
I have the same problem with my system, sometimes hd led blink sometimes not, but system works fine, if the ide cable is bad u will notice something with hdd (like hdd not working properly), anyway try it may be it will solve the problem.

Report •

February 2, 2010 at 23:30:46
All it takes is one lousy wire for the LED data to be 'lost'. My replacing the cable fixed it.

Each wire carries different information so if just one wire fails then file data can still be intact but other things may not work like in my case the LED. Other things can be on bootup where the drive isn't recognized. All sorts of things. I'd have to look up IDE (ATA-133 specs to be exact) to specify all the different wire assignments.

So files can come and go just fine from the drive but things like SMART data or drive status and such can be wrong.

Report •

February 3, 2010 at 06:48:37
We're glad to hear replacing the data cable fixed the problem.

Report •

Ask Question