Lcd won't power show anything?

June 27, 2009 at 00:00:12
Specs: Windows Vista, INTEL PENTENIUM 4/2GB RAM DDR3
I JUST BUILT A COMPUTER BUT WHEN I PLUG IT IN TO THE LCD NOTHING WILL SHOW UP? I HAVE AN ASUS EXTREME 2 MOTHER BOARD
1000W POWER SUPPLY,120GB HARD DRIVE NEW.EVERYTHING TURN ON BUT NOTHING WILL SHOW UP ON THE LCD.
IT ALSO HAS 2 INVIDIA G FORCE 6 SERIES VIDEO CARDS.

See More: Lcd wont power show anything?

Report •


#1
June 27, 2009 at 07:49:40
1st of all, turn off the Caps Lock. Many people will purposely NOT answer your question(s) because typing in all Caps is considered to be rude and/or shouting.

2nd, list your complete specs, not just in general terms. You have a 1000W PSU? What's the make/model? Same goes for the video cards...there are quite a few 6 series cards. Which CPU, motherboard, RAM do you have?

3rd, SLi configurations are generally a waste of money. The 6 series is outdated. You could get one 9 series card that would slap the snot out of your 2 x 6 series setup.

4th, did you benchtest your hardware before assembly or just slap it all in the case & expect it to work?


Report •

#2
June 27, 2009 at 09:07:32
oh sorry i didn't know.
i have a 1000w psu ultra x3
the model of the video cards are geforce 6800 ultra.
the mother board is asus striker 2 extreme,the intel is pentenium 4.and theram is xms3 ddr3 platinum series 2gb with both.
i did test everything before i installed it
i don't think the hard drives has an operating system
could that be the problem?

Report •

Related Solutions


Ask Question