Laptop battery, says Plugged in, not charging

Microsoft Windows 7 professional - upgra...
November 6, 2013 at 14:28:20
Specs: Windows 7 64b, toshiba satellite/3GB
I have a Toshiba Satellite c655-s5132, and my battery indicator says plugged in not charging. I tried restarting, removing the battery and putting it back in, uninstalling the ACPI compliant controller, updated BIOS and chipset, still says it. It will work without the battery in, and the battery still runs on a charge like normal. I fixed it once, I took the battery out and jammed it back in while it was running but it stopped again. So I don't think its the battery (unless its the connectors), any suggestions?

See More: Laptop battery, says Plugged in, not charging

Report •

November 7, 2013 at 00:45:44
Try to implement this fix. If that fails, it could be a faulty battery which needs to be replaced.

"I'm tired. But then again I'm so hungry I can't sleep. But what's the point of eating if your sleepy?" - Sniff, The Moomins.

message edited by paradoxwizard

Report •
Related Solutions

Ask Question