Solved Kingston 2GB DDR2 Module suddenly fell to 1GB

November 20, 2014 at 21:14:34
Specs: Windows 7, 2400/800
Hi everybody,

I bought for of these modules yesterday for my HP DC7800 CMT and installed them.
when checked using RamMon, it showed four modules of 2048 MB in a windows 7 64-bit Ultimate Edition environment.

Here's the link to the uploaded photo of the RAMs

Today when I checked, it started showing 1024 MB instead of 2048 MB, I checked it everywhere, even in BIOS, it now shows 1024 MB everywhere.

Fixes Attempted:
1. Reset BIOS (Both by pressing reset button and taking out board battery)
2. Flashed BIOS
3. Removed All extra hardware
4. Used on Ram stick instead of 4
5. Mixed it with different frequency/capacity ram modules

So far nothing seems to work

Now I am thinking may be the RAM module is of 1024 MB but if that's true, why did it show 2048 Initially.

Could any of you help me with the problem
These modules were sold to me as DDR2, PC2-6400, 800MHZ and 2GB per module.
Are they really of 2GB and if they are why am I getting only half of each (resulting in 4096 MB instead of 8192 MB)

Thanks In advance.

See More: Kingston 2GB DDR2 Module suddenly fell to 1GB

Report •

November 21, 2014 at 03:06:57
✔ Best Answer
The KVR800D2N5K2/2G is supposed to be a 2 gig 'kit' comprised of 2 sticks of ram and described as '2 x 1 gig'. That implies each stick is 1 gig. But the /2G makes one think each stick is 2 gig. And I thought I'd worked with some kingston 512 meg kit ram where each stick was 512 and not 256. Maybe it's just the odd way kingston labels its ram.

Specs show the ram is compatible and the computer can handle 8 gig.

Are you absolutely certain windows originally showed a total of 8 gig from the 4 sticks?

Report •

November 21, 2014 at 04:18:34
Absolutely certain, I couldn't get a screen though, since there was nothing to worry , however I only checked Installed RAM through the application RAM monitor by passmark, I think this application acted weird and reported wrong capacity of installed ram initially for some odd reason and later corrected it somehow.

Thanks for the answer I'll get these modules replaced.

message edited by usmanato360

Report •

November 21, 2014 at 05:10:32

Report •
Related Solutions

Ask Question