Solved Keyboard not working inside BIOS

November 28, 2014 at 07:50:03
Specs: Windows 7 Ultimate, AMD FX 4300
I have a Gigabyte g970a ds3p motherboard. And my keyboard is PS/2. The problem is that when the system boots up, I can enter the BIOS by pressing the Delete button, but once I enter the keyboard is not responding then. I cannot change my BIOS settings. I haven't tried using an USB keyboard.

See More: Keyboard not working inside BIOS

Report •

November 28, 2014 at 07:58:57

Report •

November 28, 2014 at 18:44:10
✔ Best Answer
The PS2 keyboard should work if it is working properly.
USB keyboards need to be plugged into the rear USB jacks that are directly on the motherboard and directly connected to the chipset. Avoid front ports, USB hubs, USB ports run through internal hubs. USB ports on expansion cards, and even motherboard USB jacks that are on add on USB controllers (on motherboard but not through the chipset directly).

You have to be a little bit crazy to keep you from going insane.

Report •
Related Solutions

Ask Question