keyboard and mouse not working

Dell / Xps 420
March 13, 2009 at 14:35:21
Specs: Windows Vista
i found out today that my computer's keyboard and mouse are not working. (writing this on my laptop) When i power my computer, everything seems to work fine but when i get to the page where i have to enter my password, i just cant. i cant write anything nor move the mouse. And i made sure that they are well connected and everything. The lights that tells if you are on Caps Lock isnt switching when i press the button, it's stuck open. The mouse's batteries have just been changed and the little light is there. I tried with other keyboards and mouses too... i tried running my computer in Safe mode and when i get to choose that, the keyboard works, since i have to choose that with the arrow keys, and the caps lock light switches too, but when i get to the password page nothing works anymore. I am using a Dell XPS 420 and running windows vista. It seems like the computer just disactivated both keyboard and mouse... because they are not broken. and the screen is working, when i run the computer in safe mode the little line at the beggining of where we are suposed to write the PW is flashing.
Anyone could help me PLEASE?^^
I didnt find any answers to the exact same problem in forums. Oh and sorry if i'm in the wrong section, i wasnt sure where to post.

See More: keyboard and mouse not working

Report •

March 13, 2009 at 16:04:42
I think the most likely thing is your power supply is failing.


"Power Supply Self Diagnostic Features
The XPS 420 computers have power supplies that include a self-diagnostic feature. The test button for the power supply is visible on the back of the system. This LED is not the same as the flea power LED on the motherboard. Press and hold the self-diagnostic switch on the power supply -
* If the LED stays green, the supply is functioning
* If the LED stays off, get the power supply replaced"

If the PS fails the test, let us know, and we'll help you further

"The mouse's batteries have just been changed and the little light is there."

Have you changed them before?

If so, did the mouse work after you changed them without you having to do anything else, such as activate a switch?

If you haven't changed them before....

A friend of mine has an older Logitech wireless ball mouse. When you change the batteries for that, you must move a lever on the mouse to activate a switch, when the computer is in Windows ? (on that model the lever curves around the top side of the ball in the mouse) , otherwise the mouse is not recognized by by the Logitech software. It may also be required that a setting be enabled in the software as well after having removed the batteries. In possibly both cases, you must temporarily use a regular PS/2 or USB mouse in order to be able to easily do those things.

Report •

March 13, 2009 at 18:26:15
I took a look on the web.

There are used PSs for this model (XPS 400, 410, 420) on the web. I don't recommend you buy any used power supply.
- many have wires coming out of the bottom of them rather than the back, or from both the bottom and the back, of the PS (???)
- I see no test button on the back of any of them

If you have no test button........

Failing power supplies are common and can cause your symptoms.
Check your PS.
See response 4 in this:

New replacement PSs listed on the web for this model are a standard size and have all the wires coming out of the back of the PS, the standard way.

I looked at the Dell Owners manual for XPS 420

- It appears there's no reason you couldn't use a power supply with the wires coming out of the back of the PS the standard way - there's enough room inside thecase.

"Removing the Computer Cover

"Lay your computer on its side with the computer cover facing up."
(The left side as seen when you face the front of the computer faces upwards)
"Pull back the cover release latch on the top panel."

Remove, replace the power supply; required connectors

According to info here:
this model came with either a 375 or 425 watt power supply.

The mboard has a PCI-E X16 slot for a video card.

If you need to replace the power supply,
- one that has the same wattage capacity, or more, is fine, unless the PCI-E X16 video card has been replaced with one that requires a greater power supply capacity, or you think you might require one with more capacity for a better video card in the future. One that has a 600 watt capacity or greater will handle any current PCI-E X16 card.
- get a decent power supply, not the cheapest one you can find.
See response 3 in this:

Report •

March 14, 2009 at 08:42:32
Well i doubt i have anything to replace, since my computer is less than a year old but I'll try what you said.
Thanks for your answers :)

Report •

Related Solutions

March 14, 2009 at 11:37:25
If the button is there to test the power supply, try it.

If you're sure it's under a year old it's probably still under warranty.
In that case, if there is a seal on the case that would be broken if you opened up the case, opening up the case might invalidate your warranty.
Contact Dell to see what you should do, or check that out on the Dell web site..

Report •

March 14, 2009 at 12:06:30
When you said you tried other keyboards and mice, we're any of them PS/2?

Sometimes resetting the CMOS can work wonders. Just open the case and remove that big round button battery. Leave it out for a minute and pop it back in. You'll have to reset the time in the BIOS.

I highly doubt the power supply is the problem if it's affecting just the mouse and keyboard.

WinSimple Software

Report •

March 14, 2009 at 13:46:12
"I highly doubt the power supply is the problem if it's affecting just the mouse and keyboard."

Both require the power supply is producing enough of what is supposed to be an accurate +5v, whether they're PS/2 or USB connected.
I've seen several failing power supplies where the PS was no longer doing that. In that case, the floppy and optical drives don't work properly either, even while booting.

Report •

March 14, 2009 at 14:02:09
"In that case, the floppy and optical drives don't work properly either, even while booting."

And neither would the hard drive since it also operates on both 5 and 12 volts. And also neither would any PCI cards, since they can also run at 5 volts. Don't forget some of the onboard chips as well. :)

I'm not completely ruling out the power supply, I just think it's somewhat unlikely if everything else in the system is ok. Alot of times, a failing 5v rail is accompanied by the hard drive disappearing from the BIOS.

WinSimple Software

Report •

March 14, 2009 at 14:58:07
There may still be what is supposed to be 5v but it's too low.

I don't know if ATX mboards will work if there is no 5v from the PS at all, but I know for sure an AT system can have no 5v at all from the PS and it can still work because I diagnosed a friend's system that had that situation. The system still booted (with a keyboard error, of course), it still had video (a PCI card in a slot), and the hard drives still worked. The PS/2 keyboard, serial mouse, floppy drive, optical drive, and the USB ports didn't work.

The PS's fan had stopped spinning - sleeve bearings - and the PS had cooked itself.
I replaced the power supply, and found the floppy and optical drive leds still lit up, the optical drive's tray would still eject and retract, but neither drive worked otherwise. I tried them on another computer - same thing.
The video card developed artifacts a short time later, and I found the dial-up modem no longer worked. I assume the 5v went too high before the 5v failed.
I replaced the floppy and optical drives, the PCI video card, and the dial-up modem card (the sound card still worked fine), and he continued to use that system with no problems for a long while after that.

Report •

March 14, 2009 at 15:05:23
Here's a page that describes in detail a common problem with Antec power supplies and a failing 5v rail. There are numerous examples of symptoms that go alot farther than just the mouse/keyboard not working.

WinSimple Software

Report •

Ask Question