Solved k120 Logitech USB locked but working

Logitech K120-taa keyboard (cable connec...
February 4, 2017 at 19:12:04
Specs: ??, PS4??
The backspace works if there is something to erase, and so does the enter of there is something to post. I just bought this less than a week ago for my new PS4 and it has worked flawless up until today. I was having a conversation with someone, went to grab some water and came back and boom. Nothing will type. I figured I hit some weird combination of keys and locked it up.. I played with it and had it fixed for about .5 seconds. I knew what keys messed it up because I made sure to press them type press them again and try to type. And press it back again for it to work. Is there a key combo i can try?

See More: k120 Logitech USB locked but working

Report •

#1
February 4, 2017 at 19:15:22
It got irritated and pushed a bunch of keys at the same time and got it to type gf before it didn't again. The keyboard is working but idk how to unlock it I guess

Report •

#2
February 5, 2017 at 04:47:15
There's a couple of key combos to try here:
https://ubuntuforums.org/showthread...

Otherwise try unplugging and re-plugging as there might be oxide on the USB plug. Also try another USB socket.

Always pop back and let us know the outcome - thanks


Report •

#3
February 5, 2017 at 07:53:37
✔ Best Answer
Did you check the Logitech support site? Try the link below.

http://support.logitech.com/en_us/a...


Report •
Related Solutions


Ask Question