it's a power supply issue

January 7, 2012 at 20:57:34
Specs: Windows Vista
xps 420 amber fix!!
solid amber light fixed..
on my xps 420. i just cut the connection to the hard drive the one bellow the fan . because i couldnt pull'em out.....got them out of the way and reconnected them using the extras hanging off of the power supply . the ideal here is to use the ones that were NOT originally hooked up before. i don't recommend cutting the ones to disc drive or any where on the motherboard . AND DONT CUT THE BIG BLUE OR ORANGE ONE. THE ONES YOU'RE LOOKING FOR ARE ABOUT AN INCH LONG AND SLENDER, "HINT study the one's hanging of the supply .that and after cutting each lead, wrap the wires in a bundle and mark them..just in case. major bummer to get them mixed up ! you can always get new connectors and EXTENSIONS.try wal-mart or radio shack ect..
*** if your like me you have nothing to loose. evidently the new lead or formerly unused leads draw on a different part of the supply ..not burned out YET.
after this it started just fine and is running like new .
bare this in mind it's at best, a temporary fix but it does get it running again . start shopping for another bigger power supply..alot bigger . mine is 375W way under what i need . currently shoppin for a 500 or 600W with the same connections.....:)
so thats it cut the one to the hard drive the one you can't pull out wrap and mark . pull the one off of the disc drive no cutting here and mark it"don't want to use it again. cut the" ties" holding the extras on the supply and reconnect . if your really desperate and the leads are too short . take the 4 screws on the back holding the supply and push it in the computer to dismount it . looks kinda crappy with the supply hanging out .

See More: its a power supply issue

Report •

#1
January 7, 2012 at 21:20:32
Horrible advice.

Report •

#2
January 7, 2012 at 22:19:37
XPS 420

Report •

#3
January 7, 2012 at 23:14:19
I think you've been smokin 420.

Report •

Related Solutions

#4
January 8, 2012 at 00:55:40
funny, i think thats what happened to it just before it quit.
my xps.. only had one hard drive very basic to begin with . the fine and outstanding genuis that worked at dell put in a rinky dink psu and stuck the other hard drive in his pocket . ...he was in a hurry to get home to smoke that 420.
allthough the other fine folks that designed the psu ..left two sets of extra power cables,complete with connectors ...just to remind me of what i did't buy.
how considerate of them .
and yes sometimes it is easier to cut the cable exspecially when you know you'll have to remove the fan and redo the heat sink that sit on top of the MOST EXSPENCIVE part of any computer. one little screw up and you might as well go to the pawn shop and buy another 420,10 to 1 it has the same problem."poorly designed to make a $"
the only up side is it comes in a pretty case and has a fair motherboard.
DEFINATLY "PIMPABLE"
STUDYING ON IT KNOW soon to come out with a "pimp my xps 420 "
i mean really why go buy new when you have such a nice box to put some really killer stuff in. "hint they do sell kits"
and no don't goto dell unless you want more problems like this.

Report •

#5
January 8, 2012 at 06:02:08
ALMOST the WORST thing you could have done!!!
I think the moderator should probably delete this post. If I thought this was posted to deliberately mess people up I would report it myself.

You have to be a little bit crazy to keep you from going insane.


Report •

Ask Question