It take me several attempts to get my comp on

March 8, 2011 at 03:10:53
Specs: Windows 7, 64bit/2Gig
Hi, this is a bit of a strange problem, about 2 months ago, i switched my comp on and after about 1 second it immediately powered down so i switched it on again and it booted up fine, now the problem is that its getting progressively worse, it now takes me about 20mins to get the comp to the point where it will boot and stay on, every time i press the power button it stays on a split second longer till it gets to the point where it stays on. Once it boots up and stays on, it will be fine and won't switch off, it will even have no problems switching back on for about 30min after I’ve switch it off but after that i have to start the process again......

Can anyone please help me with this problem?


See More: It take me several attempts to get my comp on

Report •

#1
March 8, 2011 at 05:57:11
Sounds like a failing power supply. I would rule out the switch because it does power up. If you have a spare psu, swap it out and see what happpens. If not, buy one at a place that you can return it if that doesn't cure it. I would almost bet it's the psu.

Report •

#2
March 8, 2011 at 06:03:36
yea its pritty much what i thought as well, i've got a mate bringing a spare one on the weekend.
Just thought i'd ask about though to see if anyone else had had this prob, thx for your reply.

Report •

#3
March 8, 2011 at 06:25:15
You're welcome and good luck.

Report •
Related Solutions


Ask Question