Is this motherboard defective?

Asrock / 890fx
December 27, 2010 at 10:45:18
Specs: Windows 7 Home Premium, phenom II x 4 970 / 8 gb ddr3
Is this motherboard defective? I ordered this from newegg. It has all the features I'm looking for, but it has problems. Had major problems trying to fire it up. There was no post. I reseated the RAM, checked all the connectors and tried it again. When i finally got something on the screen, the messge said, "DEFAULT SETTING ARE WRONG". I put in the time and date then it froze. So I unplugged everything and pressed clear CMOS the tried it again. The second time I got the same message. This time i went to the ram voltage. It was defaulted to 1.65 volts. This is ddr3. I changed it to 1.5 and save and exit. then i went back to put in the rest of the settings and loaded windows 7. the board is asrock 890fx deluxe 4. Why would the default setting be wrong? It was hell trying to get this thing set up. It's running ok now, but for a first time builder, it was rough. Stay away from the default settings in the BIOS.

See More: Is this motherboard defective?

Report •

December 27, 2010 at 11:22:02
Not all DDR III RAM runs at 1.5V. That is the JEDEC standard but many manufacturers juice the chips to get better specs.

You need to check the specs for the RAM you bought.

Did you look at the QVL for tested RAM for that board. Link below can get you there.

What power supply do you have? What graphics card?

Report •

December 27, 2010 at 13:48:25
Thanks for your reply. This ram is on the qvl on the asrock site. im using kingston KVR1333D3N9/2G. 4X2GB. at first i used only 2 sticks in the first 2 slots to fire it up. power supply is corsair ax750. i fired it up using nvidia gt220. also i should mention, i suspected the board battery might be bad because it wasnt saving the bios settings so i replaced it, and it seems to help. currently i am running the ram at 1.52 volts. no problems right now. here is a list of my build:

Cooler Master 690 II advanced case
ASRock 890FX Deluxe 4
8gb Kingston Ram, see above
Phenom II x 4 970 BE
Seagate 500gb hard drive
Corsair AX750 gold modular power supply
Zotac GTS 450 graphics card, new since build with latest driver
Zotac GT 220 in 2nd slot set as PhysX card

PS: bought my first game yesterday, battlefield bad company 2. took forever to load. have the resolution set to 1920x1080 and runs like a champ with my video cards.

Report •

December 27, 2010 at 17:00:02
Did you install the motherboard chip set drivers and the other drivers off the motherboard CD?

If the RAM defaulted to 1.65V you need to verify what voltage the RAM was made to run on. Read the sticker on the RAM itself.

Report •

Related Solutions

December 27, 2010 at 19:20:53
yes i installed the drivers from the cd. i took out a ram stick and it does say 1.5 volts.

Report •

December 27, 2010 at 19:30:05
That is odd then that the default voltage was 1.65V. I would check all the sticks then. The stick inserted into the #1 slot usually determines the default settings for all the RAM.

Report •

Ask Question