IS my power supply bad or am i just bad?

Amd Phenom 9850 quad core processor
December 4, 2009 at 14:37:30
Specs: Windows 7
I have a computer I custom built with Specs as follows

AMD PHENOM 9850 BLACK
8 GB RAM
2 X 9800 GX2
1 TB hdd
1200 w psu
blu ray player / dvd burner

Ok so my problem is about a year ago about 3 months after i built the monster it went out all at once. I have since replaced the MOBO 4 gbs of ram and now it turns on and has been working good. My video slowly got worse and now i had to take out my 2 video cards running on the mobo video asus m3n-ht and the other 4 gb of ram I have just sent for replacement. Guess what its STILL freezing as time goes on. Now my PSU is buzzing and all I have left in there is a wireless network card 4 gb of ram hdd and mobo. So my question is did I replace everything needlessly and my psu has been to blame this whole time? Also I havent changed out the psu yet, do u think it is the culprit of this problem. Also its not windows since half the time i cant even get into windows and I like to reinstall windows every 6 months


See More: IS my power supply bad or am i just bad?

Report •


#1
December 4, 2009 at 15:03:12
Listing your power supply as 1200W doesn't mean a hell of a lot. We need to know the make/model & amperage specs. You *should* have paid over $100 for a decent quality 1200W unit....

Report •

#2
December 4, 2009 at 15:04:47
Simply saying the PSU is 1200W tells us nothing meaningful.
What make/model is it?
"Now my PSU is buzzing"

Is it simply a dirty fan or is it an electronic hum?

Did you overclock at any stage?

Have you checked CPU cooling is ok?

Goin' Fishin' (Some day)


Report •

#3
December 4, 2009 at 15:06:10
Hi jam "snap"

Goin' Fishin' (Some day)


Report •

Related Solutions

#4
December 5, 2009 at 10:52:51
Ok im not sure on PSU specs but ima list everything I think is necessary on it.
ATX 12V 2.3
EPS 12V 2.92
COOLER master 1250 W
Made in china XD
product no. RS-C50-EMBA-D2
if u need something else off of this let me know


Also nah I didnt overclock because I built it so I wouldnt have to enough operating power. Also I have the asus cpu monitor up and check it on occasion i dont run in green I run in yellow but Never hit red.


Report •


Ask Question