IPAQ h2200 Stuck on Serial hp scree

Hp ipaq pocket pc / H2200
January 18, 2010 at 20:10:04
Specs: Windows Mobile 2003
I was trying to update the Bios when my pocket pc went to a screen that has the word "Serial" at the top, a hp blue logo in the center with the word invent underneath it and at the bottom it has a v1.08. I try to do a soft reset and it flashes and goes back to this screen with the information I listed above. I have even tried a hard reset and it does the same thing as a soft reset. Pushing the power button in does nothing. I'm stuck on this screen I mentioned above. When I take the battery out and put it back in, I have a blank powered off screen. I push the power button and it will not power back on. I place it in the charging cradle and it will not charge. I then do a soft reset it goes back to the "Serial-hp logo screen" and will not do anything else. What do I do? Help, Help, Help. Thanks.

See More: IPAQ h2200 Stuck on Serial hp scree

January 19, 2010 at 16:06:13
Did you read everything in the Release Notes for the ROM update???



"3. Important: Plan for enough time to start and complete the update process.
The total time to perform a ROM update is estimated to be as follows:
*USB - 20 minutes
*Serial - 90 minutes"

How long did you wait ??
If you didn't wait long enough, your ROM update is trashed !

"NOTE: Do not perform the ROM Update through a USB hub. This may cause your host PC to receive a General Protection Fault, thus force a reboot of the Host PC upon completion of the ROM Update."

Did you have it connected to a USB hub, or to the ports on the front of a desktop case, which sometimes don't work properly with USB connections?

"Users updating their ROM through a serial connection and their Host PC's operating system is Microsoft Windows 2000 or XP could receive a "Connection Error" during the Update. simply, follow the on screen instructions and try again. If the problem persists, unplug your serial connection and update through a direct connection to you Host PC's USB port. "

Did you get that error?

You could try contacting HP, but it sounds like your ROM update was trashed.

Report •

January 20, 2010 at 13:09:03

I was trying to update my BIOS to version 1.10 trough the USB port on the front of my desktop computer. I'm running Vista as my OS on my desktop computer. I have tried and re-tried installing this BIOS update, but I'm unsuccessful. I'm still unable to get off the USB/Serial/hp blue logo/v1.08 screen. When I do re-run the BIOS upgrade file (1.10), I receive a connection error that says my IPAQ HP2200 USB is not connected to my desktop. I have checked several times and the USB cable from the IPAQ to my desktop is connected properly. When I plug the USB into my USB port on the front of my dektop computer, my IPA switches from serial at the top of the screen it is stuck on to USB at the top of this screen. I don't have a recovery or original disk that came with this IPAQ h2200. I really need to get this IPAQ back up and running. I'm not sure what to do.

Report •

January 20, 2010 at 18:36:32
Usually you have only ONE opporotunity to get it right - when something goes wrong during the actual updating of the ROM, usually you can't start over - the ROM contents have been trashed. You can't interrupt that process when it's actually updating . The same goes for updating the firmware on an optical drive, or on a hard drive which is not normally done by the user but by the manufacturer, and most other things you can update the ROM contents of.

If the hard drive led on the host PC was flashing, the ROM contents were probably being updated. Going by what happens when a computer's bios is updated on a floppy drive when one boots with a flash floppy, the led would probably not flash constantly but intermittantly. You don't assume there's nothing going on until at the very least 5 minutes after the last time the led flashed or lit up.

Normal desktop and laptop computer bioses are a little different - they have ROM content, and RAM content (the CMOS), at the very least the time and date and the settings for your particular ram and cpu. When you flash the bios you're only changing most but not all of the ROM contents om modern computers. Over the years a safety feature has been added - a Boot Block Bios portion of the bios ROM code. The Boot Block portion of the bios code is normally not flashed when you update the bios, because it does not change from what it was for the original bios version for the particular mboard. If something goes wrong during flashing the bios, the Boot Block code is still there - it has just enough code in it for you to attempt to flash the bios again, by doing a special procedure.
As far as I know, your device probably does not have that feature.

"I have checked several times and the USB cable from the IPAQ to my desktop is connected properly. When I plug the USB into my USB port on the front of my dektop computer, my IPA switches from serial at the top of the screen it is stuck on to USB at the top of this screen....."

It sounds like you're not getting a good enough connection to the front USB ports.

It's VERY important that there be nothing wrong with the connection - with the cable or with the reliability of the USB port.

USB devices may not work correctly when they're connected to certain USB ports e.g. ports in a hub or on the front of a desktop case. If you have a desktop computer, you may have an IRQ sharing problem you need to fix, or your power supply may be starting to fail.
See response 3 in this:

Also - if you are using a USB extension cable, some of them have inadequate wiring and will not work properly with some USB devices.

If you're sure there's nothing wrong with the cable, you could try connecting directly to a port built into the mboard - on the back of the computer - but I think it's likely the ROM contents are already trashed. However there may be a way that I'm not aware of geeting out of your situation - and it's not clear to me whether the ROM updating actually started from your description - you could try contacting HP, supplying as much info about your situation as you can.

Report •

Related Solutions

March 18, 2010 at 15:08:17
Did you ever get this fixed?
it just happend to me
and i cant seem to find a way to fix it :(

Help PLZ!

Report •

March 18, 2010 at 16:37:55

Read and investigate all of the info I supplied in this topic.
Answer the questions I asked.
Contact HP.

Report •

March 21, 2010 at 19:21:28
When you say the RAM is trashed is there any way to recover from this?
I've tried a few things and read and re-read what you have said but i cant make much sense of what to do. It is pretty much non responsive

Report •

March 21, 2010 at 20:06:22

ROM = read only memory. The data on the chip it's stored on is always there even when the computer isn't running. You were trying to change that data in the ROM to a newer version, and something went wrong.

RAM = Rapid Access Memory - that's not what you tried to update the data in - whatever data is in the ram is gone once you shut off the device.

You haven't answered any of my questions or given me any background info.

You have to very careful that you understand how to do the ROM update correctly, and that you have a connection that's working properly BEFORE you even start. If you you don't understand the directions fully, DO NOT attempt it !

Updating the ROM on these things is like updating the bios version (the data on the ROM part of the bios chip ) on a computer. The difference is computer's bioses have a backup safety feature called a boot block bios that allows you to attempt to recover from a failed attempt to update the bios version (ROM contents), your device probably does not.

Report •

March 21, 2010 at 20:47:18


What you describe is a well documented issue in these and other windows mobile forums - ROM & Bios updates for older devices were not designed to be run on the newer windows operating system and many users have bricked their devices by doing so.

(Bricked = made their device useless)

If you were updating the BIOS from a Vista or Windows 7 computer, try running the update again from an XP machine.

Report •

March 22, 2010 at 19:10:40
Ok i will try the update on a XP and let you know how that turns out
thanks for the help :)

Report •

April 8, 2010 at 17:19:45
Hmm well i cant find an xp, do you think if i just downloaded the operating system and ran it as a seperate system it would work?

Report •

April 8, 2010 at 18:48:11
Nobody you know has a computer that's running XP, or is the problem no one you know who has a computer that's running XP wants you messing with their computer?

Read the info, see the link in Response 8 again. He didn't say it would work - it may already be too late - he just you could try that.

As I told the person who started this topic, you could try emailing HP about your problem, to see what you're chances are of it working in XP.

We don't condone you having an illegitimate copy of XP on this web site, and where are you going to get a valid Product Key for it?

Report •

April 12, 2010 at 19:00:30
When did i say i would get it illegally
i have a few copies from our old computers that i can use
but i guess ill try to email hp
and no one has one
most have windows 7

Report •

April 12, 2010 at 19:51:35
"....do you think if i just downloaded the operating system...."
sounds like you were going to get it off the web.

The term downloading is normally only used to refer to data you get off the web, or from a computer on a network that is not where you have your computer or local network of computers (e.g. a business or institutional network).

What operating system was on the computer you tried to do the ROM update along with ?

I don't recommend you install XP so it dual boots with Vista or Windows 7 just for this purpose, because EVERY TIME you boot XP, ALL the System Restore restore points are DELETED in Vista and Windows 7 !!
You can't stop that from happening, unless you have a Vista or Windows 7 Ultimate or Business version, and use the Bitlocker feature, or unless you use a third party boot manager program that can HIDE the Vista or Windows7 partition from XP while XP is booting (e.g. BootIt! N.G.is what I use) .

Install XP on it's own hard drive, remove or disconnect the drive with Vista or Windows 7 on it before you install XP.

Report •

April 13, 2010 at 16:44:12
i have windows 7
and yea idk if i can do that but i can try

Report •

Ask Question