IOGear Bluetooth USB Adapter Not Working on Windows 7 x64

Iogear Gbu521 usb bluetooth 4.0 - blueto...
November 14, 2013 at 14:16:36
Specs: Windows 7 64-bit, i7 3.5GHz / 32GB DDR3 2666
Bluetooth Adapter Not Working
I've been trying to install a bluetooth adapter, but I've been getting the same issue with multiple devices. Everything seems to install correctly, device manager shows the device, and the bluetooth icon appears in the system tray.

But windows will not find any device, it just sits on the page when trying to find something. Also, when the adapter is plugged in, my 'devices and printers' folder will not show any of my currently connected devices and just shows a progress bar across the file path bar, and will not show any of my devices until the adapter is removed and the pc rebooted. I can also turn the device on and off though the system tray, but if I click the settings it does absolutely nothing.

I've tried two different devices and had the exact same result with both:
IOGear GBU521

I installed the device on my WinXP box and it worked as expected, so it's not a hardware issue. Any ideas on how to get this to work?

CPU and motherboard:
Intel i7-4770K 3.5GHz
ASUS Maximus VI Hero

See More: IOGear Bluetooth USB Adapter Not Working on Windows 7 x64

Report •

November 15, 2013 at 07:06:00
You probably need to download and install a driver for that particular adapter model from it's manufacturer's website.

The manufacturer's driver and application software for the IOGear GBU521 on Windows 7 & Windows 8 is here:

I can only guess that it works okay on XP because the IOGear driver for XP is already installed.

Similarly, try the ASUS website for the driver for other adapter if you prefer to use that one, but be aware that it's a whopping 558MB download just for a tiny BT dongle, ridiculous:

The IOGear driver is only half that size.

message edited by phil22

Report •

November 15, 2013 at 13:06:48
Additional info:

I have tried installing the drivers for the devices from both the CD that came with the device, and from the most recent version downloaded from the manufacturer's website, with the no change in results.

Report •

November 16, 2013 at 03:23:58
Well I don't know what else to suggest that's relevant to your problem.

Report •
Related Solutions

Ask Question