Solved Interrupts shoot up after upgrading to 500 GB HD

Toshiba / Satellite a100
November 20, 2012 at 23:42:08
Specs: Windows XP, x86 1995 MHz
I replaced the old 120 GB SATA HD on my Satellite Toshiba laptop with a new 500 GB one. I noticed that the interrupts process keeps shooting up especially when the HD moves.
Are there any known issues with the 500 GB HD?

I use XP with SP3.

See More: Interrupts shoot up after upgrading to 500 GB HD

Report •

✔ Best Answer
December 4, 2012 at 20:48:59
I checked a running version of WinXP and the files are all dated 7/1/2001 so there may not be a newer version of IDE/ATA/ATAPI drivers.

Run scannow SFC and if there is no change then I really think you should install WinXP SP3 fresh.

Set the BIOS to AHCI instead of IDE compatibility BEFORE installing.

November 21, 2012 at 06:16:57
What do you mean when you say "the interrupts process keeps shooting up"?

How old is your laptop? Post the model number.

Post the brand and model number of the replacement hard drive.

Report •

November 21, 2012 at 07:18:49
When you look at the processes running in the computer you see the hardware interrupts consuming too much CPU.
Laptop: Toshiba Satellite A100-787 PSAANE-02Q01LAR year 2007
The new HD is Toshiba SATA.C05421 500GB

Report •

November 21, 2012 at 07:47:01
Post the exact content on the process line in question. I don't see any process that labels interrupts in my running processes.

What is the percentage shown for System Idle process?

The drive model you posted doesn't seem to be a Toshiba number. Is one of the drives in the link below the one you have?

Did you transfer contents from the original drive to the new drive or perform a clean install?

How much installed RAM do you have?

Report •

Related Solutions

November 21, 2012 at 09:03:17
The Hardware interrupts is a process just under the System Idle process which runs in different percentages from 30 to 90%

The HD looks like one of those.

Yes I transferred contents not fresh install

RAM is 2.5GB

Report •

November 21, 2012 at 15:43:13
I asked you to post all the exact verbiage across the line for that process. The reason being I don't think it is a legitimate Windows process.

Report •

November 21, 2012 at 20:30:43
There is nothing across the line for that process. It just says: Process Name: Interrupts and Description: Hardware interrupts. no other info about it. It is found in all computers including my company's network computer.

Report •

November 22, 2012 at 10:05:21
I am running Windows 7 and there is no such listing in Task Manager on my computer.

I also booted into WinXP to see if things were different there. They aren't. Also tried logging into 7 as the administrator, even though I have full administrative privileges in my normal account. Still no hardware interrupts.

My process screen has multiple columns labeled "image name, User Name, CPU, Memory, handles, threads, Image path name".

In Win XP there are less columns labeled "Image name, User name, CPU, memory usage."

There are values in all those columns for each process.

These columns can be accessed by clicking on View at the top of the process screen. Try checking the image path name to see what is actually using the resources.

Is the computer in question a company computer? If so, I suggest you speak with the IT folks about this issue.

I can't recall ever seeing that listing in Task Manager and I have been using Windows for many years.

Perhaps someone else here that may be following this thread will have some additional knowledge.

Report •

November 22, 2012 at 10:41:29
The computer with changed HD is personal. I use a company computer which shows also the process hardware interrupts but doesnt have a problem with consuming too much CPU. Both use XP.

Is there an updated driver for the HD? I imagine that updating the bios might help but that option is not available from Toshiba.

Report •

November 22, 2012 at 11:06:30
I am befuddled by the fact you say there are multiple computers you can access that have this process listed. I am wondering if we are looking at two different things.

Depressing Cntrl+Alt+Del brings up the task manager. You then select processes. Is this where you are seeing this information? If so, how many columns of information show there?

My problem is that the process is not universal.

I understand your logic in relating the new hard drive and the current resource problem. However, you can't be sure they are related.

You didn't answer how you got WinXP on the new hard drive. What I mean is what steps did you use.

From my post above:
"These columns can be accessed by clicking on View at the top of the process screen. Try checking the image path name to see what is actually using the resources. "
Try adding the column to show the path. Then list the path here.

Did you down grade from Vista to WinXP on the computer in question?

Report •

November 22, 2012 at 12:44:19
I use a special program called Process explorer. It gives a full view of all running processes. It shows this interrupt while Ctr Alt Del doesnt!! It looks like the program considers this a process while the triple keys dont. I could have attached a screen shot but that is not possible here. The program shows the full path of the process. This interrupt doesnt have any path.
I feel that the new HD is responsible because the interrupts shoot each time I see its diod lit.

I transferred a Ghost image to the new HD with already installed XP. I didnt downgrade from vista.

Report •

November 22, 2012 at 13:02:36
OK then, do you know if you are either using an IDE hard drive or if the BIOS is set to use IDE compatibility mode.?

Check in Device manager to see if you have any listing for IDE. If you did not install the chip set drivers the hard drive may be running in a PIO mode, which can cause the issue you are experiencing.

According to specs for you unit it came with Vista pre-installed.

Report •

November 25, 2012 at 12:05:34
My HD is SATA. There is no mentioning in the BIOS anything about the HD
Device manager lists the following under IDE controller:
-Intel SATA storage cotnroller
-Primary IDE channel
-Secondary IDE channel

Yes the vista was installed but I formatted the HD and installed XP from scrach. When changed the HD I transferred a ghost image from the old to the new HD.

Report •

November 25, 2012 at 14:28:20
Then it is running in an IDE compatibility mode.

Go to Device Manager> Expand IDE controller/s. Right click on the channels one by one and choose Properties> Advanced settings. Both your drives should be running in a DMA mode. There may be a box to check to run in DMA mode. If you have not installed the chipset drivers the drives will not run in a DMA mode.

Report •

November 25, 2012 at 18:55:31
If you mean the Intel chip that is listed under IDE controlled, that one has the driver installed. It's name is:
Intel 82801GBM/GHM.....

The advanced tab for the channels show the following:
Device 0
Type: Auto detection (Fixed choice)
Transfer mode: DMA if available (with a choice of PIO Only)
Current Transfer mode: PIO (with no option to change it)

Device 1
Auto detection
DMA if available (with a choice of PIO only)
Transfer mode: Not applicable.

I am not sure why there are two devices although I have just 1 HD.

Report •

November 26, 2012 at 05:44:53
Correct, you are running in PIO mode. You need to install the motherboard chipset drivers for WinXP.

Go to the link below to get the drivers.

Report •

November 26, 2012 at 10:05:18
My laptop model is Satellite A100-787 PSAANE-02Q01LAR. It is not found under supported models in the Toshiba site anymore (since Toshiba is so cheap) therefore I couldnt find an updated driver for the chipset. I already have the chipset driver which I downloaded in 2007 but installing it didnt make any difference. I got one for Satellite models in general which belongs to 2008 and installed it. The only thing changed is under device 1 which now reads: Multi Word DMA mode 2. Under device 0 it still reads PIO mode.

Report •

November 26, 2012 at 12:15:56
Go to the link below and allow Intel to update you drivers.

Report •

November 28, 2012 at 05:27:32
The Intel automatic update utility in your link determined that the chipset utility on my computer is up to date. So what is left?

Report •

November 28, 2012 at 05:48:16
Did you have an option to replace the files anyway?

When viewing the properties in Device Manager, is there a box to tick to enable DMA?

Report •

November 28, 2012 at 06:02:07
I found an update page for your model. You can try the chipset driver file there. Even if it is the same number replace the file.

Are you running SP3 plus all updates after that?

Report •

November 28, 2012 at 08:29:13
There was no option in Intel to reinstall anyway. In device manager the option of DMA is found in the secondary channel only not in the primary one.

The site you found for my model doesnt have recent updates. The driver installed is the same listed.

My computer has all the up to minutes updates.

Report •

November 28, 2012 at 10:40:33
Once Vista was out Toshiba may not have provided any additional updates.

As I stated above, I suggest you replace the current chipset drivers with the download even though the download is the same file. Your file may be corrupt.

Can you provide screenshots for the BIOS screens. Use photobucket or similar to upload photos and then provide a link here.

Is the primary channel the channel the hard drive is using?

When you look in Device Manager are both your Hard and optical drives listed using the correct model numbers?

Report •

November 28, 2012 at 11:46:34
According to Toshiba your laptop can with Vista pre-installed. See the link below.

Part of the problem here may be due to the fact that WinXP had no SATA controller support.

When you re-installed WinXP what service pack was integrated into the installation CD?

Report •

November 28, 2012 at 12:07:16
See the workaround section in the link below. There is a Fixit link that may help.

Report •

November 28, 2012 at 12:13:43
I already reinstalled the old version but no change.

I am not sure how to get screen shots in BIOS mode. This may require a special program. What exactly to look for in BIOS?

Both primary and secondary channels list device 0 and device 1. I am not sure why there are two devices and which one is the HD. In the primary channel, device 0 transfer mode is: DMA if available. but the current transfer mode is PIO mode with no other option. In the secondary channel the transfer mode is the same but the current transfer mode is Multi-word DMA Mode2

The HD model number in device manager is Toshiba MK5076GSX. The driver version is 5.1.2535.0 on 7/1/2001. There is no info at all under volumes tab. I have to look at the old drive to see if this is its model number since I am not sure of the new driver model number.
The optical drive info seem to match the installed one.

Report •

November 28, 2012 at 12:29:48
You didn't answer what service pack is included in your installation CD for WinXP. Also, what type of CD is it? Retail, Toshiba branded, etc.?

You use a camera to take a photo of the screen and upload as a named.jpg.

Your chipset is an Intel 945GM express. That chipset is flexible and can support both IDE and SATA drives. That may explain why there are two listings. I can't get much in the way of BIOS information from a Google search. As you stated, Toshiba isn't much help.

The driver version you listed above seems to be out dated. 2001? That seems to be a driver from WinXP original version which only supported 137GB hard drives.

I suggest you try the workaround I linked above.

The article suggests removing the driver and rebooting.

The drivers for the drives should be part of the chipset driver package. That is dated 2007/8.

If you installed XP with a CD that has anything less than SP3 then that could be the problem.

When you look at the hard drive in Disk Management does it show as 500GB? How many partitions and what size?

Actual capacity should be about 465GB total.

Report •

November 29, 2012 at 07:20:05
When I installed XP it was from a retail CD with no SP although I recently made a repair for windows using a XP CD with SP3.

I just uninstalled the HD and rebooted but the driver didnt change.

I ran the Fix it link but no change. I still have to edit the registry I suppose which I will do shortly.

The disk manager is showing the HD as 465 GB and there are 3 partitions in addition to the WinRE partition which is the Toshiba partition.

Which part of the BIOS exactly you need pics of?

Report •

November 30, 2012 at 07:14:49
I suggest you slipstream SP3 into the original XP files and then burn a new CD. You can use nliteos to accomplish that. Get nliteos from the link below.

I am not sure repairing with a newer version is the same.

What capacity is the primary (C) partition?

How did you get the Toshiba partition on the new drive? You stated above you performed a clean install?

Report •

November 30, 2012 at 09:58:12
I dont know what you mean by "slipstream" SP3. Now I have an XP CD with SP3 integrated in it. That is what I used to repair windows.

C partition is 24 GB larg. D is 268.

I got the Toshiba partition in place by transferring a ghost image.

While editing the registry I am finding that the existing values are the same as what I am supposed to enter when I edit the keys.

Report •

November 30, 2012 at 11:42:14
Things that should work are not working. You may need to start over with a fresh install of WinXP from the CD with SP3 on it. You may need to slipstream the chip set drivers into the files on the CD. If it comes to that I would try to install with the CD as is first.

Slipstreaming is the process of integrating SP3 or other items, into the original files and then burning the new package to CDR. nliteos can do that.

If you already have a CD with SP3 on it then you don't need to do that.

Some of your driver files are old. Scannow and/or Chkdsk may correct that.

Is S.M.A.R.T. enabled in the BIOS? If there are abnormalities in the hard drive performance SMART may flag the drive. Also, I am told both Hitachi and Seagate hard drive fitness tests will work with any brand hard drive. Toshiba does not have a fitness test.

Go to one of those websites and download the fitness test. Burn it to disk and boot to that disk to test the drive.

If the drive checks out then the issue is with Windows. Run CHKDSK and Scannnow SFC. See the link below for help with scannow SFC.

See the second link for help with CHKDSK.

Report •

December 4, 2012 at 18:59:39
I am resisting the idea of fresh install. That will cost me many hours of work.

The driver files are: disk.sys and partmgr.sys. The question is: There is on driver to install manually? How about using the XP SP3 CD? and where on CD to look for it?

By the way, when I try to update driver, the system doesnt give me the choice to check in the internet for a new driver, it just goes to the next screen of installing automatically.

I ran chckdsk a few times in the last month but I am yet to run Scannow and to check about SMART due to time restrain.

Report •

December 4, 2012 at 20:48:59
✔ Best Answer
I checked a running version of WinXP and the files are all dated 7/1/2001 so there may not be a newer version of IDE/ATA/ATAPI drivers.

Run scannow SFC and if there is no change then I really think you should install WinXP SP3 fresh.

Set the BIOS to AHCI instead of IDE compatibility BEFORE installing.

Report •

December 16, 2012 at 20:39:58
Finally I ran the SFC but I dont know if it made a difference.
There is nothing in the BIOS that deals with AHCI or IDE compatibility. Actually nothing at all about HD control.
I am resisting doing a fresh install because it is a big hassle.
I am going to mark your last answer as the best answer, however,

Report •

Ask Question