I'm looking for a Conner Peripherals CP3026

Conner peripherals / Cp3026
April 14, 2010 at 07:09:00
Specs: Dos

i'm near desperate... I'm looking for a Conner
Peripherals CP3026 Hard Drive, it should be
an IDE 20Mb drive.

If anyone has a working one, or has
informations about it, please contact me on

Thank you all

See More: Im looking for a Conner Peripherals CP3026

Report •

April 14, 2010 at 09:58:26
I have:

CP30084E--80 meg
CP-344--40 meg

and some others ~200 meg

Depending on your system you may be able to set them as type 2 in cmos and use them as 20 meg drives. Or partition them with a 20 meg partition.

You're not really green until you're soylent green.

Report •

April 14, 2010 at 11:15:48

this hard disk was in an Olivetti Pc1. I've tried to replace it
with other disks, but all do not turn on when i switch on the
pc... Better they turn on only when the data ribbon cable (40
pin) is not connected.

Only this CP3026 (the original shipped with the machine)
seem to work properly.
I don't know if is a MFM, RLL, IDE, or what else, so i don't
know with what i can replace it.

I'm not able to identify the controller on the mainboard...
Any hint will be very appreciated!! :)

Report •

April 14, 2010 at 13:00:04
It's not MFM or RLL since they've got different data cables. It's an old IDE.

Often, especially with those older PC's, if the drive cable is on backwards the system would appear to be dead. The IDE cable should have a red stripe along one edge. That side should be connected to the # 1 pin side of both the drive and motherboard/card connection. Most are keyed so they only fit one-way but some older ones weren't. So verify you're connecting it correctly.

Do you know what cpu is in it? The 8086/8088's didn't have cmos to configure the drives But If it's got an on-board IDE controller (isn't connected to a card) it must be somewhat newer.

The best thing would be to get into your cmos/bios setup--again assuming you have that--and see what drive types are available. Most 20 meg were drive type 2.

You're not really green until you're soylent green.

Report •

Related Solutions

April 14, 2010 at 13:17:33

i know about the red stripe on the data cable, anyway i've
tried in the two way.

All the hd i've tried seem to be dead when connected to the
data cable. Only a seagate st34323 seem to work, but i've
noticed that if i set it as master it's behaviour is the same of
the other.
Only configured as slave seem to work.

This seagate is not so old, is a 4.31Gb hd... I've tried other
seagate, an old 120Mb seagate (the original shipped with
amiga4000). But nothing... No response...

The cpu is a necv40, an 8086/8088 clone at 10MHz...
The controller is on board, not on an expansion card, even
because it doesn't have any expansion slot.

I've not been able to identify the controller, i've noticed some
wdc chips... But from what i've found on google it's fdc

From what i know and remember i doesn't have any setup.
The system was sold with or without hd, the one without hd
doesn't have neither the ide connector on the motherboard...

Report •

April 14, 2010 at 15:09:28
10Mhz? Didn't know they made one that fast; seen a couple and they only ran at 8Mhz max.

A trip to the garage verified that I'd recycled the old Conner drives I had. Seems I remember they were all pretty shaky drives and I finally just quit messing with them.

I knew they didn't come with any expansion slot, just that add-on slot thing that hung on the side.

I didn't know you could buy one of those without a hdd; thought the options were just one or two floppy drives.

I did find some information on the CP3026 though. It's a CP3024 remade for Olivetti; same CHS of 615 4 17. What I don't know is what "remade for Olivetti" means.

I wonder if the controller is looking for a drive with those particular parameters only?

Most of the drives I find with those parameters are MFM drives and wouldn't do you any good.

There are some ide drives though.

WD 93028A, WD 95028A, WD 95028AD, etc. A list of 21Mb drives is shown on this page...


Maybe one of them would work.


Report •

April 14, 2010 at 15:47:10
An 8088 with on-board IDE? I wouldn't have thought that was possible. It must have been incredibly advanced for its time.

Unlike MFM and RLL, IDE had a lot of the controller on the drive so it doesn't seem like that's the only one that would work. But I guess that would depend on what the bios was capable of. There were IDE size limitations with older bios'. Maybe the limit on yours is 20 meg.

Finding out if it originally came with some kind of setup disks might be the only way to see what drives are compatible.

You're not really green until you're soylent green.

Report •

April 15, 2010 at 04:23:03

there was three configurations... Single or dual 720Kb disk
drive or single disk drive and 20Mb hd, was a machine like the
sinclair pc200..

So it's a remade of a conner CP3024... This informations
could be usefull...
For example, the power connector is not like the usual 4 pins
plug, but it has a 7 pin connector...

I've verified, the nec v40 is at 8MHz not 10, i was wrong...

Report •

April 15, 2010 at 09:08:48

can you sell me the cp344 ? Maybe it work...

Report •

April 15, 2010 at 13:01:14
I"d have to check and see if it works. I probably just pulled it from an old PC and set it aside.

It has the regular 4-wire power connection. Will that work in yours?

Also, what version of Dos are you using?

You're not really green until you're soylent green.

Report •

April 16, 2010 at 07:57:04
I've no hurry, so if you've time and when you've time let me
know if it work, and if you want to sell it...

I'll have to make an adaptor for the power connector, but that
should not be a problem.

I've an image of the original Dos 3.2 shipped with it, but i've
other versions too. My problem is only to make it electrically
available to the system.
At present, when connected (data and power cables), all the
disk i've tried does'nt spin up like they doesn't turn on.

Report •

April 17, 2010 at 03:03:16
Sometimes the not-spiinning-up is due to the data cable. You've mentioned you made sure it was on correctly but maybe it's bad.

I don't think dos 3.2 will see a 40 meg drive correctly. I think you can still use it but with a partition no larger than 30 meg.

It'll take a few day before I can check it out but I'll post back once I've done that.

You're not really green until you're soylent green.

Report •

April 18, 2010 at 14:00:26
Hi, i've thought about that...
So, i've tried with the original cable, the one that came with the
original hard disk, that work correctly with the original harddisk...
The behavious is the same...

Now, i've noticed that some sort of liquid, like glue of a color like
dark yellow, is getting out from the original harddisk... I'm afraid
to try to turn it on again...

Report •

April 18, 2010 at 14:01:59
Before make you loose time, may be is better to check the
amount for shipping to Italy...

Report •

April 18, 2010 at 23:54:59
I never had a drive that leaked fluid before. But I assume it's some kind of lubricant.

Shipping might be a problem. It looks like the least expensive is a 'smal flat rate box' for US $13.45:


But the height of that box is 1 5/8" which is isn't enough for the drive. The next larger size is $43.45

I haven't weighed the drive but possibly it could go as a 'small packet':


where the box dimensions aren't so strict.

I'll see if the drive works and if so, weigh it, and then we'll decide what to do.

You're not really green until you're soylent green.

Report •

April 19, 2010 at 13:41:14

I suspect could be quite expensive, anyway, check the drive and
after we'll see what do to...

Report •

April 22, 2010 at 23:44:42
Sorry this is taking so long.

I connected it to a P-III and it was auto detected and I could access the drive so it's probalby OK.

I couldn't get it to boot but likely that's because its original partition was based on a different C/H/S configuration than what the auto detect supplies. I couldn't manually configure the C/H/S in the P-III's bios. I'm going to hook it up to a P-I which should allow a C/H/S configuraiton and see if it'll boot.

Edit Does your existing CP3026 have the C/H/S specs on the label or a drive type--maybe type 2? If so, post back that info.

You're not really green until you're soylent green.

Report •

April 24, 2010 at 13:37:21

no sorry, all i can see is the voltage and a small label reporting:


but i've no idea of what it mean...

Report •

April 25, 2010 at 00:40:52
Skipcox says it's 615/4/17 in # 5 above, which is type 2.

I got it to boot up in the P-I by using drive type 24. That doesn't matter in your situation, I just wanted to see if it was working OK. I'm going to copy all the old dos stuff off and then set it to type 2 and partition and format and install dos and see if it works as a 20 meg. I can probably do that tomorrow.

You're not really green until you're soylent green.

Report •

April 26, 2010 at 00:49:57
Well, after all that the drive appears to be bad. I got a few read errors and couldn't get everything copied. The I set it to type 2 in cmos and partitioned and formatted with dos 6.22. The formatting gave an error and wouldn't complete. I tried some low level formatting programs and they gave an error at about 25 % and wouldn't complete.

Oh well, we tried.

You're not really green until you're soylent green.

Report •

May 1, 2010 at 06:10:15


No problems, thank you very much for your time...
I want to try to connect a cf interface directly on the ide
connector of the mb...

thank you again for you time

Report •

Ask Question