Click here for important information about

IDE hard drive not detected

Wd Caviar 80gb hard drive
November 18, 2010 at 22:08:33
Specs: Windows XP SP3
I'm not sure what happened. It's a WD Caviar 80 GB drive, got it second-handedly from my father. At first, it went smooth, but about a month later, it sometimes couldn't be detected. After a few restarts and re-plugging the cables would it start to work again. I tried all jumper settings, and all cable settings, but the problem isn't easy. Please help.

note: my computer usually freezes when detecting hard drives, then I unplug and plug in the cables again, then it went smooth but couldn't detect the drive.

See More: IDE hard drive not detected

November 18, 2010 at 22:18:24
Are you messing with the cables while the computer is turned or plugged in?

Any thing else connected to the same cable?

If so, what else and how are the jumpers on the back of both drives set?

Report •

November 18, 2010 at 22:58:12
Kinda. I changed my cable from a no-name brand to a brand-new ASUS cable. It's approximately 1 and a half month ago. And the jumpers were just as before. I didn't touch it, although my dad keeps telling me to choose "Cable select". I'm not so sure about it. It's currently "Master" right now. The other is a Samsung 80GB SATA drive, stays untouched as it was.

Report •

November 19, 2010 at 04:03:46
You didn't answer the second question. Sounds like the drive is on a cable by itself. If that is the case then you may have the jumper set wrong. Western Digital drives have 2 Master settings. One of them is Master alone, which you should be using if there is not other drive on the cable.

Report •

Related Solutions

November 19, 2010 at 04:43:35
uh... I just found out that the power cable for the hard drive just BUSTED. It's loose, and bent and whatsoever. So I changed to another cable, and it worked again.

Also, the system drive was a Slave, whilst the second drive (the problematic one) is the master. Although there are not much problems from these (I think), but I still changed the system drive to Master, and the other to Master on another channel. Thanks OtheHill for the jumper tip.

So, the problem is (temporarily) solved. For any other guy facing the same problem, also check your power cable to see if it's busted or not.

Report •

Ask Question