I turn on my pc and the green light on the mo

January 25, 2011 at 12:06:02
Specs: windows 98
I turn on my desktop pc and there is no display, the monitor is good, the light is green but then turns amber after about 5 seconds. The computor is older and has been not used for a few years but was working fine when I put it away, Can any one tell me why or what to do? I have tried two monitor , neither work on the pc. Both work on other pcs I have.

See More: I turn on my pc and the green light on the mo

Report •

#1
January 25, 2011 at 12:18:32
If it was in storage for a few years, try removing the ram and cleaning it with a pencil eraser, then reinstall it.

Report •

#2
January 25, 2011 at 13:11:34
I did that. no difference. the computor is Dell XPS400r. It is all original . Nothing has been changed.

Report •

#3
January 25, 2011 at 13:22:35
Does it do anything when you turn it on? Any sounds like the fans spinning. I fixed a machine like that last month. The power supply was shot.

Report •

Related Solutions

#4
January 25, 2011 at 13:27:58
Yes , when I turn on the computor it sounds normal, the cd drives open and close, the green lights are on on the front of the computor, the fan is running, it all seems normal. The monitor , you can here it start to come on, the green light on the monitor is on for about 5 seconds, then it turns to amber.

Report •

#5
January 25, 2011 at 14:06:53
Since it's been 5 years, try changing the cmos battery.

Report •

#6
January 25, 2011 at 14:28:24
I changed it. I cleaned the ram, I reseated all the cards and the RAM. I started it again and it began to boot, the monitor came on and the DELL screen was on, it continued to boot for a while then it froze. I tried to start it again and nothing, back to where it was before , no display. I tried five or six more times. Nothing. I don't know if this is any clue to what is going on or not. HELP.

Report •

#7
January 25, 2011 at 14:46:13
That was good sign. Try disconnecting everything but 1 stick of ram, keyboard and mouse. see if it will post. It could be the hard drive went bad from sitting.

Report •

Ask Question