I just tried to upgrade my BIOS and it failed

March 16, 2011 at 22:37:01
Specs: Macintosh
I have an AFI mobo Asus M2N78-LA (Violet6) in a HP Pavilion p6310y.

I attempted to upgrade the BIOS by booting into a Win 98 formatted USB stick, copied AFUDOS.exe (version 4.33) and the VIO65.29.bin file to the USB stick, rebooted, and then ran the command from the Win 98 command prompt: 'afudos /iVIO5.29.bin /pbnc /n' and NOW MY MACHINE IS FRIED. It just beeps continuously, one short beep, and then one long beep, and then it repeats.

Please tell me there is a way out of this mess.

I used the BIOS from the first page of this thread, and I thought everything would work out fine, but I guess not....


See More: I just tried to upgrade my BIOS and it failed

Report •

March 17, 2011 at 00:53:48
There is always a way out of the mess. It involves purchasing a replacement motherboard.

Or you could always try these folk:


Was there a specific reason you were trying to update your bios? Was your system having a problem that was supposed to be addressed by that particular update?

There are several rules to follow when considering flashing your bios.
Rule 1. Don't do it.
Rule 2. Only do it if the update will correct a problem your system has that cannot be resolved another way. eg. support for a newer model CPU that was not supported at time of manufacture.
Rule 3. Only do it using an update obtained directly from the system manufacturer. In your case that means from HP.
Rule 4. Be prepared to accept the consequences of disobeying rule 1.

Try this. Use the CLR CMOS jumper and try again. You might just get lucky

Goin' Fishin' (Some day)

Report •

March 17, 2011 at 05:14:54
You have an HP board & should have used the HP BIOS. Doing a flash is somewhat risky in the 1st place, using an unoffical modded BIOS is even more risky.

Are you sure about that beep code? Generally the long beep comes 1st. Is it 1 short + 1 long or 1 long + 1 short?

Try using the Clear CMOS jumper as was mentioned above. Make sure the power cord is unplugged 1st. If that doesn't fix the problem, you're pretty much screwed.

Report •

March 17, 2011 at 05:28:00
The beeps go like this:
beeeeeeeeeeeep, then 1 second, then beeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeep
wait 2 seconds
then repeat.

I tried the Clear CMOS jumper. I put it on pins 1 and 2. Then powered her up. Same beeps. I also tried removing the CMOS battery for a while and then reinserted with the Clear CMOS jumper in the right place.

Same beeps.

Would there be a chance trying this? http://www.bios-mods.com/amirecover...

I just don't know if anything is happening on the mobo at all. Right now I only have the optical disk drive hooked up and I tried inserting a self booting windows dvd and no luck there, so i'm not sure how the above link would work........

Report •

Related Solutions

March 17, 2011 at 08:34:37
"You have an HP board & should have used the HP BIOS. "

HP usually uses Phoenix bios versions for their HP and Compaq model mboards.
The HP bios updates have the flash utility integrated into them

Asus does NOT use Phoenix bios versions for it's retail mboard models and often uses uses Aflash for the flash utility , which is meant for Award or AMI bios updates / bios versions.

If the mboard is an OEM only model - made by Asus ONLY for HP and possibly other brand name system builders, there is no retail Asus model - then you should NEVER use a bios update for a similar retail model because it's likely you'll end up with a mboard that will not boot properly. E.g. all it takes is for the two models to have a different I/O chip, or a different revision of a main chipset chip, which are frequently different and require different bios code.

"Would there be a chance trying this? http://www.bios-mods.com/amirecover...

You could try it but it probably won't work.

The mboard probably originally had a Phoenix bios version.
When the bios is flashed with a bios update, the Boot Block portion of the bios code is usually not replaced by default. You may now have the Boot Block code for a Phoenix bios version and the rest of the bios code is for an AMI or Award bios version. The Boot Block code for a Phoenix bios version is probably different from the Boot Block code for an AMI or Award bios version,even when the mboard model is identical

There are very good reasons that you are WARNED not to flash your bios if you are not having any problems with your computer.

The flash can fail, more likely if you do it in the operating system on the hard drive rather than if you do it after booting the computer from a disk,
or - the flash chip can physically fail while flashing,
even if you DID use the right bios update, and the right flash utilty if that applies, and did the procedure correctly.

If your computer EVER worked properly with the bios version it had, it makes no sense at all to risk flashing your bios because in that case your problem is not caused by the present bios version.

Usually the only legitimate reasons to flash your bios are so that...
- it will then be able to recognize a CPU type it can't presently recognize that is listed in a CPU support list for the model
- a problem you are having, that is specifically mentioned in the release notes of a newer bios version, will be cured


When you flash the bios yourself, that's the riskiest thing you can do with a computer.
You are taking a big risk when you flash your bios - if the flash fails, and/or the flash chip physically fails while flashing (this is COMMON - these cheap flash chips can only be flashed an unpredictable small number of times), you will have a mboard that will not boot normally..

If the bios chip physically failed while flashing, it must be replaced.
If it's in a socket and removable, you can order a new bios chip already flashed with the latest bios update.
If it's soldered into the mboard only an expert with specialized equipment can replace it, and in most cases you must ship it to him and have him ship it back - that can cost more than buying a used same mboard model on the web, or even a new one.

E.g. If you're in North America, this guy does both services:

Report •

March 17, 2011 at 10:24:20
Thanks for the detailed, yet disappointing explanation(s).

When I attempted to flash my BIOS, I used the /pbnc /n command switches. I believe the ‘b’ means that I overwrote, or at least attempted to overwrite the Boot Sector. Perhaps it overwrote the boot sector with AMI code….. Here’s to hoping. I will try the AMIBOOT.ROM tonight via the optical disk drive and report back.

Also, the mobo has a ROM Recovery connector that looks like this:

From the mobo manual:
ROM recovery connector
This connector allows qualified technicians to reload firmware into the SPI boot flash in case there is problem with the data.
          . SPI_MCSI

The two SPI_CS# pins are jumpered together (show by a straight line). Any possible way to use this?

More than likely, this seems like it is going to turn out to be a $100 mistake unfortunately, but it could be worse I guess…….

Report •

March 18, 2011 at 16:19:40
I tried the AMIBOOT.ROM via the optical drive. As expected, it didn't work.

To anyone else looking to fix their revving fan on their HP computer: DON'T TRY THIS. It's just not worth it.

The good news is that I bought a new mobo that was 90 bucks from Newegg that kicks the crap out of the dead HP OEM it is replacing.

Really impressed with the quality of this GIGABYTE board I just bought.

$90 lesson learned here....

Report •

March 18, 2011 at 18:48:10
We're glad to hear you found a solution.

Report •

Ask Question