Solved I can't read data from mobile + RAMs not recognised Related?

Custom / CUSTOM
April 8, 2018 at 06:38:27
Specs: Windows 7 Home Premium 32 bit, Intel Core i3 2120 - 3.30 GHz-4GB / 4GB DDR3 Ram
I cannot read the data from my mobile connected to my PC with a USB cable. My phone a Samsung Galaxy J5 1916 has an extra 16GB memory card in it. With explorer the phone is recognised but when I click on it, it shows an empty folder.

For the helpdesk Bitdefender I had to give details of my PC with motherboard ASUSTeK Computer INC. P7P55D LE (LGA1156) and I found that right clicking on COMPUTER, there was only 4 GB RAM installed. I have recently bought 4GB extra RAM (exactly the same Kingston part number) and put them in the two empty memory slots. Checking with the program Speccy (Piriform) it recognised only 6 GB RAM in 3 of the 4 slots. I thought one of the new RAM was faulty.

Now I understand that there is something more wrong. The helpdesk gentleman said that I should upgrade my BIOS.

My questions are:

1. are not being able to read data from my phone and the RAM problem related ?
2. How do I safely upgrade a BIOS without ending with black or blue screens as I found browsing ?


See More: I cant read data from mobile + RAMs not recognised Related?

Report •

#1
April 8, 2018 at 07:04:43
✔ Best Answer
Your specs show Windows 7 Home Premium 32 bit, is that correct? There's no point installing more than 4GB RAM with a 32-bit OS as the RAM will not be recognized or usable. The BIOS will see it, Windows will not. You will have to install a 64-bit OS for all your RAM to be recognized.

The latest BIOS version is 2101 dated 2012/11/06. Do you know which version you're running? There have been over a dozen BIOS updates over the years & many of them deal with memory compatibility. You don't need to install all of them, just the latest, as all previous changes will be included in the newest. Instructions on how to update the BIOS are in your motherboard manual, the BIOS file can be downloaded here: https://www.asus.com/Motherboards/P...

As for the problem with your phone, did you change the USB setting (on the phone) from charge mode to storage mode after the phone was connected to the PC?

message edited by riider


Report •

#2
April 8, 2018 at 09:11:49
2^32(bit)=4.294.967.296(4.29GB) is the max number a 32bit OS can read
so that's why the OS can only read 4GB (4.096GB) of memory, like riider explained
upgrading to an 64bit OS is the only way to use more than 4GB

i5-6600K[delid]@4.8GHz/4.5GHz@1.385v | 2x4GB Crucial-DDR4-2133@14-14-14-30 1T 2800MHz@1.37v
ASUS Z170K | Samsung 250GB SSD 850 EVO
MSI Armor RX 570 4GB@1411@1.25v/1930 BiosMod


Report •

#3
April 8, 2018 at 09:15:43
That is NOT correct, have Windows 7 Home Premium 64-bit SP1 installed. In my "System Information" the BIOS version is Americam Megatrends Inc. 1610 and the date is 11.05.2010.

When I installed the RAM and Speccy only showed 3 of the 4 slots functional, I made sure that the contact points were all working by putting the RAM in more than once, so that any dirt would be removed. When that didn't help, I concluded that the slot on my motherboard was faulty.

Have downloaded the latest bios from asus support. I will try to find out how to install that safely.

My Samsung Galaxy J5 apparently does not have mass storage mode see:
https://www.experts-exchange.com/qu...

I'll try that and see. will follow up


Report •

Related Solutions

#4
April 8, 2018 at 09:17:13
When you plug your phone into your computer, watch the screen on the phone and if it asks if you want to grant permission for access to your phone, choose yes.

Report •

#5
April 8, 2018 at 09:32:03
"That is NOT correct, have Windows 7 Home Premium 64-bit SP1 installed"

OK, then you should probably change the specs on your home page. You still have the OS listed as Windows 7 Home Premium 32 bit. Do you still have an Intel Core i3 2120 - 3.30 GHz, 4GB DDR3 Ram & an NVIDIA GeForce 7600 GS? If not, either update them all or leave them blank. It will prevent future confusion.

"BIOS version is Americam Megatrends Inc. 1610 and the date is 11.05.2010"

ASUS does not list version 1610 on their site. The closest to that version/date is 1808 at 2010/08/30. Do you have an OEM system? Rather than using "system Information", try CPUZ & click on the mainboard tab. See if the motherboard model number & BIOS version are the same.

https://www.cpuid.com/softwares/cpu...

message edited by riider


Report •

#6
April 9, 2018 at 06:03:44
To riider. Sorry for the incorrect info, I have a custom built PC. I will update the data on my home page in Computing.net

Thanks for the suggestion CPU-Z.

According to Speccy and CPU-Z, I have an Intel Core i7 860 @ 2.80GHz with Windows 7 Home Premium 64-bit SP1 installed & an NVIDIA GeForce 7600 GS

For the RAM data according to speccy and CPU-Z there is 6 GB in slots 1, 2 and 3, slot 4 physically has exectly the same DDR3 memory card, but according to CPU-Z and Speccy it is empty. When I installed the one in slot 4, I took it out and put it in a few times so that the connections would be good and not bad due to dirt. When that did not change things I concluded that the slot itself must be faulty. Or has this to do with the BIOS ?

The BIOS I downloaded from ASUSTek support is the latest BIOS, It is a zip file: "P7P55D-LE-ASUS-2101" and within it there is a *.rom file: "P7P55D-LE-ASUS-2101.ROM" and another zip file: "v10.5.0.1026_20110506_whql.rar". Do I have to unzip all these zip files or does the ROM file do that ?

My phone problem got solved with the link given above: https://www.experts-exchange.com/qu...

message edited by willem1933


Report •

Ask Question