HP Bios-change Parallel Port mode?

Hewlett-packard / Hp pavilion a410y
February 24, 2009 at 07:27:12
Specs: MS Windows XP Home Ed Version 2002 Service Pack 3, Intel(R) Pentium(R) 4 CPU 2.80GHz, 504 MB Ram
I'm trying to get a Zip 100 parallel port to work with Windows XP on my HP Pavilion A410Y desktop. I've been thru the wringer for a day now. The zip drive hardware lights up ok, I've installed the software and the driver, and the operating system still doesn't detect the Zip drive. I'm down to changing the parallel port mode settings in the Bios. I can get into the Bios (which calls itself Phoenix - Award Bios), but I can't find the parallel port settings. I have read that I should look for "peripheral Configuration, "Integrated Peripherals," "Configure I/O," or "Integrated I/0 Ports" on the Bios menus, but I don't see any of these choices. There is something about erasing the entire configuration, which option has me paralyzed with fear. Does anyone know what to do?

See More: HP Bios-change Parallel Port mode?

Report •

February 24, 2009 at 08:34:58
First of all, how is the ZIP drive connected to the computer? Is the drive internal or External?

Report •

February 24, 2009 at 10:22:54
Look in Integrated Peripherals> On board I/O Chip set. Parallel port should be listed there. Arrow keys or Pg. up/dn to toggle the selection. After the port is Enabled the type of port will then be available for change.

Try setting the parallel port to 378/IRQ7. That is the default setting. The type of port is dependent on the device. SPP is probably good for a ZIP drive but you will need to experiment some.

Report •

February 24, 2009 at 16:01:09
Hi, OtheHill, thanks very much for your reply. It's an external zip 100 parallel port drive. I can't locate Integrated Peripherals on the Bios. It is supposed to be in the Bios, right? --Alice

Report •

Related Solutions

February 24, 2009 at 16:06:09
Yes that is one of the options. You may not be moving around in the BIOS correctly. Do you see a list when you boot to the BIOS or a series of tabs across the top?

Report •

February 24, 2009 at 17:16:56
I see these tabs: Main, Advanced, Power, and Exit.
On the Main tab, I have these topics: Floppy Disk; Primary Master; Primary Slave; Secondary Master; Secondary Slave.
On the Advanced tab, I have these topics: Plug and Play OS; Reset Configuration Data; Onboard Video Memory; Primary Video Adapter; PS/2 Mouse; Local Bus IDE Adapter; USB Legacy Mode Support; Onboard LAN; Onboard 1394
On the Power tab, I have these topics: After Power Failure; Boot-time Diagnostic Screen; Quick Boot Mode; Boot Device Priority.
On the Exit tab, I have these choices: Exit Saving Changes; Load Setup Defaults; Discard Changes; and Save Changes

Report •

February 24, 2009 at 18:57:33
Sounds like it should be in 'Advanced'. If not, open device manager and see if you can alter its port settings there. You want a bidirectional mode.

(I downloaded the manual and took a look at it. It had nothing at all about bios setup.

Report •

February 24, 2009 at 21:09:49
DAVE, thanks very much for your response, and thanks for looking at the manual too.

As far as I can tell, the only possibility in Advanced is "Reset Configuration Data" and I'm too chicken to try that one. Would it wipe out everything, or give me choices? I'm clueless.

Then when I go to Device Manager I can't find anything relevant to a parallel port. So basically, I'm stuck. Lost in LA.


Report •

February 24, 2009 at 22:36:08
Reset Configuration Data will allow the System resources (IRQs) to be reallocated. That is of no help to you. Evidently you don't have a setting for Parallel port. Do you HAVE a parallel port? If so, it must be enabled at all times. Never saw a BIOS like that one.

It might be that you can reach additional settings with a secret keystroke. Don't know why that would be done but have heard is is done.

POST screens at startup would identify the parallel port if it is in use.

Do you see any screens when first starting the computer?

Download and use SIW.exe. That utility will give many details of your system. Get it at the link below.


Report •

February 25, 2009 at 00:46:14
The parallel port should be under 'Ports' in device manager. It may show as LPT1. The manual does show a printer port.

In the cmos/bios setup make sure 'PnP OS' is enabled.

You may want to still poke around in cmos/bios setup to see if you can find anything related to the ports--serial or parallel as they should both be on the same page. But it's not like a needle in a haystack so it shouldn't be that hard to find.

I just thought of something. Those external zip drives came in parallel, SCSI and USB. Obviously you'd recognize a USB connection but the parallel and SCSI connections looked the same. The SCSI were designed to connect to a Future Domain type connector which looks exactly like a parallel port. So the cables looked the same too but were not interchangable.

You can look at the back of the drive to see if it's SCSI or parallel. If it's SCSI it'll say it somewhere and they'll be something like a number wheel to change the SCSI ID. Anyway, if you've got one of those it's not going to connect to your parallel port.

If you've got a parallel drive then make sure the cable you're using doesn't say it's only to be used with SCSI drives.

Report •

February 26, 2009 at 14:13:11
OK. I've been working on this issue for 3 days. Today I paid Iomega $25 and HP $60 for support, and they were basically clueless. Also, I don't get a refund.

But while talking to HP support, I went again to the BIOS and found I had overlooked a scroll feature on the advanced tab. Scrolling down, I found and fixed the port settings. Not that it helped any.

On talking to Iomega support I got a suggestion to purchase a USB to DB25 parallel connector cable. But on surfing to remarks of those who have tried this ploy, I found the adapter cable, while a good idea, doesn't actually work with a Zip 100 parallel port drive, possibly because of a speed issue.

As I poked around the Iomega support site, it just now occurred to me that though Iomega no longer sells Zip 100 usb drives, it did at one time. So, I went to Amazon.com and purchased a used Zip 100 usb drive. Will see if that does the trick.

OtheHill and DAVE, thanks very much for your help. I really appreciate it.


Report •

February 26, 2009 at 15:30:04
One question that has been in my mind from the start. Are you doing this to retreive data off some ZIP disks?

I hope you are not doing it to use ZIP disks to save or tranfport data.

I am pretty sure that there are services that could have transferred any data you needed to retreive. As for using the ZIP drive as it was designed. That technology window has closed.

Optical disks have replaced them.

Report •

February 26, 2009 at 16:02:35
" just thought of something. Those external zip drives came in parallel, SCSI and USB. Obviously you'd recognize a USB connection but the parallel and SCSI connections looked the same. "

Are you SURE the Zip drive is supposed to be parallel connected? What's it's model number?
Some Zip drives are SCSI - one type of commonly used back then SCSI connector is a Dsub 25 pin hole (female) connector that looks IDENTICAL to one for a parallel port.
You would need a suitable SCSI card for the Zip drive, but it would not be worth the money for you to buy one new.
You used to be able to buy cheaper SCSI cards for single SCSI devices, such as scanners and Zip drives - but almost all of them were ISA.
XP does not support ISA SCSI cards, if your computer has ISA slots.

If it IS supposed to be parallel connected, Zip drives are recent enough I think it's more likely it requires you set the parallel mode to EPP, ECP, OR EPP/ECP mode - usually EPP is fine. I know most parallel connected printers and scanners made since about the early 90's require EPP or ECP mode or they aren't recognized as being connected at all, or you get strange error messages, and most of if not all Zip drives are newer than that.

Report •

February 26, 2009 at 16:52:12

I 100% agree that zip disks are ancient. I just want to get my data off and erase the zip disks on hand.

I had no idea it would be so hard.



Thanks for writing. This is model # Z100P2, identified on the Iomega site as a Zip 100 parallel port drive. I also saw a drawing comparing the backs of the zip 100 parallel port and SCSI drives. The SCSI has switches in the middle of the back, and the parallel port doesn't. So I'm sure I have a parallel port drive, and I hear from the HP support person that I definitely have a parallel port (called printer port LPT1 in Device Manager).

In BIOS, I tried all the parallel port mode choices -- EPP, ECP, and bi-directional mode one by one, uninstalling LPT1 from Device Manager and then restarting HP afterward so XP would reinstall the innards. No luck.

Per Iomega, the parallel port should work provided (in BIOS) the port is enabled, the mode is EPP or bi-directional, the I/O address is 378, and Interrupt is set to IRQ7, and provided (in Device Manager) the Port Settings are "Use any interrupt assigned to the port" and "Enable legacy Plug and Play detection." I did all this, and got zip (ok, poor word choice) for my efforts.

XP is making parport.sys the driver. I see other options (ppa3.inf Guest.inf ppa.inf) but the XP hardware installer spits them out. I asked Iomega support what the driver should be and they had not one clue. If I could locate someone with XP and a working Zip 100 parallel port drive, maybe I could find an answer to that question.

The Ioware support person said he had tried the same drive on his computer running XP, and that he couldn't get it working anyway. Which, in retrospect, would not make him the best candidate for tech support on this issue.


Report •

February 26, 2009 at 17:52:30
The USB zip drive would be preferrable. I swap the one I have between my working computer and any that I'm working on to transfer drivers.

Since you say you've tried the various parallel port settings in bios I guess that means you've found its location.

Report •

February 26, 2009 at 18:09:50

Eventually I saw a scroll bar on the Advanced tab in BIOS. Scrolling down revealed the parallel port options. Duh.

Some of the needed port options can only be changed in Device Manager, some only in the BIOS. Some are in both BIOS and Device Manager. I found some of the changes I made in Device Manager didn't take till I made them several times.

I'm happy to hear the USB zip drive works for you; I've ordered one. I hope it works better than my parallel port drive.


Report •

February 26, 2009 at 21:22:18
I can't figure out how my fonts got set to bold and smaller when I type in the Post reply box on this site!!

I forgot to mention a few things.
- EPP (Enhanced Printer Port) mode doesn't change anything you see in Device Manager regarding the parallel port. I prefer using it if a device works fine when set to it because it's less fuss.

Very few things that need the better modes will ONLY work in ECP mode - usually they will work in EPP mode too.

- ECP (Extended Capabilities Port) mode requires there be an available DMA channel - sometimes there isn't one available - sometimes there is but you have to select the right one in the bios Setup, often when you choose the ECP mode setting, near the ECP mode setting, at least you do in older bioses for use in Win 98SE.
Also, ECP mode is not loaded in 98SE unless the mode is set to ECP in the bios and you ALSO use Add New Hardware to find and install an ECP port. That probably applies to Win 95 to ME.

I don't know if XP (or 2000) finds an ECP port automatically, because I haven't tried setting a parallel port to that in 2000 or XP.
If it does it will display something like ECP Printer Port instead of just Printer Port in Device Manager.

I have installed maybe half a dozen models of parallel port connected Canon printers, and One Xerox all in one, and a few scanners, in EPP mode in Win 3.1, Win 98, 98SE, 2000, and XP and had no problems with those printers/scanners, and I didn't have to specify an IRQ or I/O address in Windows other than defaults. The I/O addresses Windows or the bios assigns for a parallel port never conflict with anything else, unless you have a second parallel port.
I found only some Dos programs require the IRQ be set to 7. Win 95 and up don't assign an IRQ to the printer port by default. Don't use IRQ 5 because that's often used by other things - if you assign 5 to the printer port in the bios it cannot be use by Plug and Play for other devices. On the other hand only a printer port uses IRQ 7, with the exception of old sound cards that could be set to that as a non-default setting.

I've only tried one thing in both EPP and ECP mode - the original greyscale Quickcam. It only worked properly with an ISA Multi I/O card with EPP/ECP capability (I was using a parallel printer on the mboard printer port) - I tried several PCI parallel port cards but none worked as well with it - the Lava one disables my SB16 sound. ECP mode is supposed to be superior but I didn't notice any difference so I used EPP. That QuickCam is poor in any case.

I have one Zip drive - it's IDE connected - I've never tried it - it was in a discarded system - no disks.

Report •

February 26, 2009 at 21:40:41
My fonts changed too. I think it's another attempt at a facelift here.

Report •

February 26, 2009 at 22:04:03
"My fonts changed too. I think it's another attempt at a facelift here.


I thought at first it was because my very old 98SE installation was getting beyond hope - it freezes too often - but then I tried loading a fresh installtion on the same computer that I hadn't been using and found it dos the same thing here.
I'm also getting the same occaisional Internet Explorer needs to close, or has encountered an error, errors, and Done, with errors, messages in the bottom left corner on web pages, in IE6 SP whatever in 98SE.

Report •

February 27, 2009 at 04:47:00
I got a PM answer from Justin. It is something he is doing.

Report •

February 27, 2009 at 13:31:01
I'm getting a lot of 'page load errors' too and only on this site So I know it's not me.

Report •

February 27, 2009 at 15:05:18
"I'm getting a lot of 'page load errors' too and only on this site So I know it's not me."

It happens to me on many sites in 98SE in IE 6 SP whatever, not just this one, but I do get those things I mentioned a lot more on this site. Starting a short time ago (a week or so?) clicking on any link to a "hit" on Tom's Hardware web pages froze IE in 98SE - the pages never finished loading - I've been avoiding clicking on any such link since.
They probably aren't paying any attention to whether the pages load without errors in ME and previous anymore.


If the 504mb figure you quote in your first post is correct, you're only sharing 8mb of ram with your onboard video. Look in your bios Setup to see if you can increase that amount - your onboard video will probably work better if you can - try each of the different settings with your system for a while - if increasing it more doesn't seem to do much, set the amount back a notch and that's probably the best setting - you never need more than 1/2 of your total ram.

Report •

March 6, 2009 at 16:57:12
You were right. I got a zip drive with USB, worked right away, no problem.

Thanks for the suggestion about increasing onboard video. I took a look, and 8MB, at which it's set, is as high as it goes. Old HP is why, I guess. Video works OK, just a little slow.

Thanks to all for your help. --Alice

Report •

March 6, 2009 at 19:04:57
You're welcome. We're glad it all worked out.

Report •

Ask Question