How to test USB cable?

July 19, 2018 at 13:00:07
Specs: several
I bought a toy from Brookstone. It was a display model
so I got it at a large discount. It was supposed to have a
USB cable to plug into a PC to charge the battery, which
is not removeable. The instructions say this cable has an
LED which lights up when connected to power, goes out
while the battery is charging, and comes on again when
the battery is charged. This cable was missing, so I was
given a similar generic USB cable that came out of a box
of miscellaneous electronics bits and pieces that had
collected over time.

The instructions say to "Connect the USB end of the cable
to your computer's USB port ..." and show a laptop. They
say average charging time is 40 minutes.

The salesguy charged it in the store for maybe 5 minutes
using this cable, and the toy worked fine for him.

When I got it home, I plugged the toy/USB cable combination
into the USB charger that came with my Sprint modem/router
for 42 minutes. I noticed that the battery was **very slightly**
warm, which I took to be a good sign that the battery was
charging. However, when I unplugged it and turned it on,
nothing at all happened. I tried the on/off switch 20 or 30
times over the next week, with no effect.

Yesterday I took it back to the store, and told salesguy what
happened. He plugged it in for just a few seconds, then
unplugged it and turned it on, and the toy worked perfectly.
He was not able to provide an explanation of why it worked
for him but not for me, but he put most of his suspicion on the
cable. I pointed out repeatedly that the few seconds he had
plugged it in could not have provided enough charge to
power the toy for the couple of minutes he had it working
before turning it off.

Before leaving the building, I turned it on myself, and it came
on for me for the first time. When I got it home I turned it on
and operated it for several minutes. Then it appeared to need
recharging. So I plugged it into the Sprint charger again, for
40 minutes. When I unplugged it, this time I noticed that the
cable itself was warm. Not quite hot, but surprisingly warm.
Suggesting to me that the cable might have a short.

When I switched the toy on, nothing happened. So I suspect
the cable, even though not everything points to it. I could try
plugging it into my laptop and charging the battery from it, but
if the cable has a short, I'm afraid of damaging the laptop.
I've plugged another cable into the laptop for several minutes
now, and after trying the toy again, there is no indication that
the battery charged at all. Neither the battery nor the cable
(which is longer than the short cable in question) got warm.

Is there an easy way to test the cable?

Any idea why the toy works just fine after it is charged in the
store for a few seconds but is completely dead after I charge
it for 40 minutes?

-- Jeff, in Minneapolis

message edited by Jeff Root


See More: How to test USB cable?

Reply ↓  Report •

#1
July 19, 2018 at 16:54:40
Test the cable with a different device. Or try charging your toy from a PC. Is there a label on the box listing the charging specs? Such as 5.0V @ 500 mA (0.5A)?

Reply ↓  Report •

#2
July 19, 2018 at 17:38:59
Got a multimeter? Use it on the outer pins. One's 5v DC, the other's your ground.

How To Ask Questions The Smart Way

message edited by Razor2.3


Reply ↓  Report •

#3
July 19, 2018 at 23:54:59
Buy the cable from the store that works. It's not as if they cost the earth.

Reply ↓  Report •

Related Solutions

#4
July 20, 2018 at 08:11:47
riider,

Because it was a display model, there is no box. I did get the
manual, but it doesn't have specs for charging. It does say the
battery is Lithium-polymer, 3.7 V, 140 mAh.

I don't currently have a desktop computer of my own ... but there
are two I have access to ... Maybe I'll try plugging into one of them
in the middle of the night tonight....

Razor2.3,

It's hard enough to get the multimeter probe inside the A-type
USB connector. The other end is micro. Probe too big.

But one thing that surprises me: No continuity between the metal
shields at the ends of the cable. Shouldn't they be connected?
Even if only to the ground line? I just tested 4 other USB cables.
The metal shields on all 4 show continuity. Apparently the cable
is bad! Yay! That means the problem may be only in the cable,
not the toy! Except that I did already try plugging the toy into the
laptop with a different cable, and nothing happened.

ijack,

I mentioned to the salesguy that USB cables apparently are now
self-replicating, like wire coathangers. I've got lots of other cables
that should work. But I've already tried one that I know *has* to
work, because I use it practically every day.

All the evidence should consistently point to a single explanation.
It is annoying when the Universe defies laws of physics.

-- Jeff, in Minneapolis

message edited by Jeff Root


Reply ↓  Report •

#5
July 20, 2018 at 08:34:51
Why the mystery about this toy? As with any other hardware questions, posting make/model is always helpful.

"it was a display model, there is no box"

Then go to the toy manufacturer's website & see what info is available there. You might even be able to order the correct cable.

"the battery is Lithium-polymer, 3.7 V, 140 mAh"

USB is 5.0V so it's possible the correct charging cable has an internal component that steps the voltage down to 3.7V. If that's the case, attempting to charge at 5V might damage the battery.

Just a guess: https://www.ebay.com/p/3-7v-Lipo-Ba...


Reply ↓  Report •

#6
July 21, 2018 at 02:29:59
Hi Jeff,
The original usb cable appears to be a 'Special'
eg has led - controlled by the toy (goes on/off/on indicating charging) status.

Suggest return to store and try fully charging there with a correct cable.

Then see how long the toy runs - if not long, the Battery could be faulty. .

Good Luck - Keep us posted..

message edited by Mike Newcomb


Reply ↓  Report •

#7
July 21, 2018 at 12:29:44
I'm a little afraid that I may have damaged the battery by
plugging it into the laptop or the Sprint charger (which says
its output is 5 V) or both with alternative cables. But it may
simply have not charged. I wonder if the circuit in the toy is
capable of turning off the current if the voltage is too high.
Since it has a special cable, that seems very unlikely.

The battery in the Sprint modem/router is also 3.7 V, though
it is much larger and lithium-ion rather than lithium-polymer.

If the store had the correct cable, I think the salesguy would
have given it to me. The display model was the only one
remaining because it was discontinued.

-- Jeff, in Minneapolis

message edited by Jeff Root


Reply ↓  Report •

#8
July 21, 2018 at 23:37:29
Never buy ex display models!

Almost certainly one or more items will be missing, plus maybe the item will have been rough handled and run continuously.

Yesterday I refused an ex display TV at Dixons/Currys in London and bought one elsewhere.

Good Luck - Keep us posted.


Reply ↓  Report •

#9
July 22, 2018 at 13:16:36
If the guy in the shop charged it then doesn't this mean that he did have a suitable cable?

Do any other devices that can be powered from a USB socket work with the suspect cable?

Always pop back and let us know the outcome - thanks


Reply ↓  Report •

#10
July 22, 2018 at 20:40:11
5.0V is suitable for charging a 3.7V battery, at 3.7V the battery would not charge more than about 30%, while charging the voltage rises slightly and the charge must be greater than the peak voltage just after charging (even if only momentary after charging) in order to continue 'pushing' the charge into the battery.
If the original cord had a charging circuit of some kind, it still may charge but is more possible to overcharge and reduce electrolyte and life slightly each time. Yes, try a different cord but try to purchase the original from the manufacture, even try telling them it did not have one in the package and see if they will send you one.
Some phone chargers (especially newer fast chargers) do not always work with other brands (apple vs Samsung, etc.), maybe to prevent damage to other devices. Safer to charge off computer or laptop.

You have to be a little bit crazy to keep you from going insane.


Reply ↓  Report •

#11
Reply ↓  Report •

Ask Question